locked
SharePoint 2007: Folders missing when using Upload Multiple Documents RRS feed

  • Question

  • Hi,

    I have a problem with the "Upload Multiple Documents" feature in SharePoint 2007.

    I have the following folder structure:

    └───Folder
        ├───Subfolder1
        ├───Subfolder2
        ├───Subfolder3
        ├───Subfolder4
        │   ├───SubSubfolder1
        │   ├───SubSubfolder2
        │   ├───SubSubfolder3
        │   ├───SubSubfolder4
        │   ├───SubSubfolder5
        │   ├───SubSubfolder6
        │   └───SubSubfolder7
        ├───Subfolder5
        │   ├───SubSubfolder1
        │   ├───SubSubfolder2
        │   ├───SubSubfolder3
        │   ├───SubSubfolder4
        │   ├───SubSubfolder5
        │   └───SubSubfolder6
        ├───Subfolder6
        ├───Subfolder7
        └───Subfolder8

    When I drag and drop "Folder" into the Upload Multiple Documents screen all the folders will come in the Upload screen except from the folder "SubFolder8". There is no error message saying what went wrong.

    When I change the name of SubFolder8 to SubFolder0 (so it's not the last folder) it will upload all the folders.

    When I remove 1 of the SubSubfolders the folder Subfolder8 will also be in the upload screen, even when I add a new SubSubfolder in SubFolder8. So it's not a limitation of folders.

    Some more details of the folders and documents:

    • Size: 25,6MB
    • 62 Files, 21 Folders

    I have full access to the documents and full access to the document library.

    Does anyone have an idea why this is happening?

    Kind regards,

    Sen

    Wednesday, June 27, 2012 11:47 AM

All replies

  • Hi SenV,

    Try checking the following:

    • Event Log Details
    • SharePoint Log (under the SharePoint 12 Hive)

    and share with us the details.

    Wednesday, June 27, 2012 12:00 PM
  • Hi,

    Thanks for your fast reply.

    I checked in the SharePoint Logs, but there is nothing in the logs of the upload. Which is logic, because I haven't pressed the upload button yet, I only did the drag and drop.

    The same for the event log details. It doesn't log something when I do the drad and drop.

    Kind regards,

    Sen

    Wednesday, June 27, 2012 12:13 PM
  • Hi,

    Does anyone have an idea why this is happening? Or does anyone have the same problem?

    Kind regards,

    Sen


    Monday, July 2, 2012 7:37 AM
  • Hello Sen,

    just as preliminary info, on SharePoint object model, contents(both folders and items) of a Document Library are internally coded as siblings, thus SPListItem.

    Uploading the list of folders you described would translate in adding a collection of SPListItems to SPList.Items.

    Please find below the Object model structure:

    DocumentLibrary(SPDocumentLibrary) contains Items

    Items can be: 

      --Folder (Microsoft.SharePoint.SPListItem)

      --document (Microsoft.SharePoint.SPListItem)

    Folder, thus acts as a metadata for his associated dicuments(still SPListItems)

    In order to prove this, try to create an RSS feed on the document library  with folders containing documents.

    You will notice that all folders and documents are listed at the root level ;-)

    I will do some further research and follow up on this but as I see it now is an expected behavior(at least from object model point of view)

    Hope this helps as of now!

    Best regards,

    Daniel.


    Questo contenuto è distribuito “as is” e non implica alcuna responsabilità da parte di Microsoft. L'azienda offre questo servizio gratuitamente, allo scopo di aiutare gli utenti e farli aumentare la conoscenza sui prodotti e le tecnologie Microsoft.

    LinkedIn

    Friday, July 20, 2012 4:49 PM
  • Hi,

    If this is an expected behavior, what is the reason it works perfectly when I change the folder name from SubFolder8 to SubFolder0?

    Kind regards,

    Sen

    Monday, July 30, 2012 12:02 PM
  • Hi,

    Does anyone have an idea?

    Kind regards,

    Sen

    Tuesday, September 11, 2012 6:56 AM