locked
Surface Pro 2 Won't Stay In Sleep/Standby With Windows 10 RRS feed

  • Question

  • I upgraded my Surface Pro 2 (did a full PC reset to start from fresh) from Windows 8.1 to Windows 10. Everything went smooth except this:

    - had to update graphics driver (was set to Windows Basic Display Adapter) to get sleep mode available

    - every time I put it to sleep, the Surface Pro 2 powers back on after a couple of seconds

    I ran powercfg.exe /lastwake and all it says is this:

    Wake History Count - 1
    Wake History [0]
      Wake Source Count - 0

    I'm hibernating for now as I found my surface pro 2 in my laptop bag super hot because it turned itself back on after I thought it was in sleep mode.

    Anybody else having this issue?  Any suggestions?

    Saturday, August 1, 2015 12:11 AM

Answers

  • I have the same problem with the three Surface Pro 2's that I have. I installed 10 on all of them and none of them will stay asleep. The only solution I can get to work is an unacceptable solution. That is: go to the device manager and disable all keyboards and mice from waking the computer. It works but is not acceptable because I want them to wake the computer when appropriate like when I hit a key or move the mouse not all the time or when the keyboard isn't even connected like it's doing now!
    • Marked as answer by S O'Connor Saturday, August 1, 2015 10:20 AM
    Saturday, August 1, 2015 4:19 AM

All replies

  • Having the exact problem on Surface Pro. Used Update Tool from MS to upgrade to Windows 10. Press power button or close Power Cover and Surface goes to "sleep". Screen will then either turn back on after awhile and the back of the Pro gets hot, or the screen will stay off but can hear the processor still running even though in "sleep" mode and the back gets hot.

    No idea what the fix or cause is. Until then switched power button and closing of type cover setting to Hibernate instead of Sleep.

    Saturday, August 1, 2015 1:17 AM
  • Out of any model to upgrade... why is Microsoft's own hardware not functioning 100% with Windows 10?  Frustrating!
    • Proposed as answer by mmorales913 Saturday, August 1, 2015 4:06 AM
    • Unproposed as answer by mmorales913 Saturday, August 1, 2015 4:06 AM
    • Proposed as answer by mmorales913 Saturday, August 1, 2015 4:06 AM
    Saturday, August 1, 2015 1:19 AM
  • I have the same problem with the three Surface Pro 2's that I have. I installed 10 on all of them and none of them will stay asleep. The only solution I can get to work is an unacceptable solution. That is: go to the device manager and disable all keyboards and mice from waking the computer. It works but is not acceptable because I want them to wake the computer when appropriate like when I hit a key or move the mouse not all the time or when the keyboard isn't even connected like it's doing now!
    • Marked as answer by S O'Connor Saturday, August 1, 2015 10:20 AM
    Saturday, August 1, 2015 4:19 AM
  • Hi MMorales913... I just prevented keyboards/mice from powering on and that worked!  True, not acceptable but at least you narrowed it down.

    Hmmmm... no Microsoft input on this thread yet.

    Saturday, August 1, 2015 10:20 AM
  • Glad that worked! You're right, we still need some input from Microsoft on getting an update. It seems to be only the Surface Pro 2's that have this problem as other laptops/tablets that I've updated to 10 are fine. Crazy that only Microsoft's own hardware is having this problem. I'm hoping it's just a driver update needed.
    Saturday, August 1, 2015 2:24 PM
  • Same problem here with a Surface Pro 2, ever since the Win10 upgrade it won't stay asleep irrespective of whether or not the Type Cover is attached or Bluetooth enabled etc. "Fixed" it the same way you did i.e. going into the power options and changing the lid close and power button actions from Sleep to Hibernate.
    • Edited by Myndale Monday, August 3, 2015 11:59 AM
    Monday, August 3, 2015 11:59 AM
  • I fixed it by disabling all keyboards and mice from waking the computer.

    Search "Device Manager" -> Device Manager -> "Keyboards" and "Mice and other pointing devices" separately -> for each device inside: Right Click -> Properties -> Power Options -> Uncheck "Enable device to wake up computer"

    Monday, August 3, 2015 5:32 PM
  • Unfortunately I'm in the same boat on this -- Surface Pro 2, won't stay asleep, overheats because it happens when in bags, etc. It's been an issue since joining the Windows 10 insider program about a year ago. Unfortunately Microsoft seems aware of and uninterested in resolving this, given the length of time it's been a known issue.
    Wednesday, August 5, 2015 4:20 PM
  • I narrowed it down a little further... it seems one of the first updates is the culprit! I did a clean install on one of my Surface 2s using the original ISO released on the 29th and then deferred the updates and the sleep mode works fine. Once I do the updates the problem of not staying asleep starts.
    Thursday, August 6, 2015 3:46 AM
  • Same issue here with the Surface Pro.

    Thanks for the pro-tip. Certainly is not the ideal situation, but hopefully it works. There is nothing more frustrating than expecting to have a fully charged unit, only to find that you have brick unless you can be tethered to a power source.

    Thursday, August 6, 2015 2:37 PM
  • What keyboard is everybody using here?

    I have the Surface Pro 2 with that power type keyboard, the one with the battery.

    While going through the device manager and disabling the devices from waking the computer, I noticed that I had 2 mice devices when my cover was attached and one when the keyboard is detached.  Checking the IDs, it actually loads a new mouse driver when you detach the keyboard.

    For whatever reason, I can disable all of my HID-compliant mouse devices, 2 when the keyboard is attached, and 1 when it is not, and my device still functions normally.  The mouse pad on the attached keyboard still functions, the touch screen still functions, and the pen still functions.

    I don't even know what these mouse drivers are but it is clear that they do affect the sleeping.  


    Thursday, August 6, 2015 7:41 PM
  • This isn't just a SurfacePro problem. I'm having the same problem on my Gateway after updating to Windows 10, including the subsequent patches. Put into sleep, the computer wakes after reliably after about 20 seconds every time.
    Friday, August 7, 2015 6:51 PM
  • Well I am another victim of this issue after update from win 8.1 to win 10. Suffering and frustrating.
    Saturday, August 8, 2015 8:53 AM
  • Hey man, Im Brazilian and you helped me. Muito obrigado. 
    Wednesday, August 12, 2015 6:53 PM
  • Same boat here. I just had to replace my SurfacePro2 (I dropped it), and so I'm starting with a fresh device without a lot of clutter (other than the OneDrive stuff). I updated to 10 this morning, and then took off for a bunch of errands & kids park day only to find when I got home that my bag (where I put the computer) was super hot & my tablet was running! I left the type cover at home, and just had it in an aftermarket case, but I didn't even use it after the update this morning. I just tried the work-around fix you all suggested, of changing the power button to hibernate, and so far it hasn't turned back on by itself.

    Sure does suck to own a Microsoft tablet that doesn't work properly with Windows!

    Wednesday, August 12, 2015 8:35 PM
  • Add me to the growing list of people with this problem.
    Thursday, August 13, 2015 1:12 PM
  • And add me to the list. Just changed the keyboard and mouse settings, we'll see if that works. Kind of sucks but it's not very inconvenient (for me), at least.
    Thursday, August 13, 2015 5:58 PM
  • Add another to the list! Updated Pro 2 yesterday and the screen keeps coming back on after about 20 seconds. Couple of times it has required password without having been fully shut down. If MS f**k it up can't we expect at least some reaction if only "We'll look into it?"

    Other problem I have is double ended arrows (the ones for re-sizing a window) in various places round the screen.

    Friday, August 14, 2015 7:54 AM
  • I fixed it by disabling all keyboards and mice from waking the computer.

    Search "Device Manager" -> Device Manager -> "Keyboards" and "Mice and other pointing devices" separately -> for each device inside: Right Click -> Properties -> Power Options -> Uncheck "Enable device to wake up computer"

    Thanks a lot mislagle !! :)

    Your procedure works like a charm !

    It's a great non intrusive workaround because I usually wake up my Surface Prod 2 with "Windows" button or "Power" button. So no matter if I cannot wake up my Surface with mouse, keyboard, or my cover...


    • Edited by Nanakin Friday, August 14, 2015 1:12 PM
    Friday, August 14, 2015 1:12 PM
  • Disabling wake up from mouse and keyboard does not work for me. The Surface still wakes up within a few seconds of closing the cover.
    Sunday, August 16, 2015 11:41 PM
  • I have the same problem on my surface pro 2. I just tried disabling the input devices (e.g., mouse, keyboard) to stop them from waking the computer; we'll see if that works. I don't have high hopes, however. My computer is overheating too because it is running inside my briefcase. Big problem. Will Microsoft replace my tablet when it finally dies from overheating too often?

    David Prince

    Monday, August 17, 2015 1:16 AM
  • I had the same problem with a Surface Pro 1 that would stay warm/hot despite all attempts to sleep it.  Per this thread, I disabled all the "Enable device to wake up computer" options but it appears the machine was not really going to sleep even though the screen looked like it was off.  I would see a spinning process (don’t remember the exact name) after unplugging the keyboard hogging a chunk of the CPU forever.  This would make the Surface Pro hot even if you had no apps running.

    I did eventually find a work around.  If you go into Settings/Update & security/Windows Update/Advanced Options/ Uninstall updates and uninstall the cumulative update for Windows 10 (KB3081438) from 8/14/2015, the machine will no longer be hot when sleeping.  You might want to check the “Defer upgrades” option as well so you don’t redownload the bad upgrade.

    This was on my Surface Pro 1.  I am not sure the same fix works on the SP2 and SP3.  I assume Microsoft will have an update fixing this issue soon.  Don’t know how this slipped through QA since I think the Surface Pro’s are common machines.


    • Proposed as answer by paulnerd Tuesday, August 18, 2015 3:02 PM
    Tuesday, August 18, 2015 1:57 AM
  • Same issue here - Surface Pro 2 won't sleep after Windows 10 upgrade.

    Thanks for the workaround suggestion, it worked for me as well.  Glad I was able to find this thread.  Hope Microsoft will address the issue soon.

    Thursday, August 20, 2015 2:17 AM
  • Add me in to another person increasingly frustrated by this issue. Will try the fix(es) suggested here. Too bad Microsoft isn't supporting their own product. No more Microsoft tablets for me! When this one dies, I'm going back to Dell!
    Thursday, August 20, 2015 3:45 AM
  • I had the same issue after upgrading to Windows 10. I re-installed Windows 8.1 on my Surface Pro 2.

    I would really like to know if Microsoft is still committed to fix this issue. Are you, Microsoft? When and how do you plan to fix this? I like my surface pro 2, but I also want to be able to upgrade to the latest Windows :-(

    Microsoft should make THEIR own operating system run smoothly on THEIR own hardware. A bug like this is not acceptable in the first place. Not fixing that bug is simply not excusable.

    Friday, August 21, 2015 10:51 AM
  • I had the same issue after upgrading to Windows 10. I re-installed Windows 8.1 on my Surface Pro 2.

    I would really like to know if Microsoft is still committed to fix this issue. Are you, Microsoft? When and how do you plan to fix this? I like my surface pro 2, but I also want to be able to upgrade to the latest Windows :-(

    Microsoft should make THEIR own operating system run smoothly on THEIR own hardware. A bug like this is not acceptable in the first place. Not fixing that bug is simply not excusable.


    Completely agree. Simply unacceptable Microsoft. Especially considering that I've been one of many people that had a defective power supply cord that was known to cause shooting sparks after the wire sheathing separated from the plug base! I was sitting on my couch with the SP2 when it began thankfully! Otherwise, I'd hate to imagine what could have happened. You would think given the potential nightmare scenarios caused from software/hardware malfunctions that lead to overheating/electrical failures, that Microsoft would be more inclined to address these issues with quicker responses. P.S.- On Microsoft Hardware being incompatible with Microsoft Software- I also purchased a Lumia Icon Windows Phone from Verizon a while back, and subsequently went right back to an iPhone after the device was incompatible with my company's Exchange/Office 365 email, which had no issues whatsoever on Apple Hardware/Software!!! In all fairness, there may be a fix for this now, but not in time for at least myself to be forced back to a Microsoft competitor. I mean seriously Microsoft, why in the world do you not realize how ridiculous these things make you seem? It's mind-boggling and really makes someone question your ability to make quality products. You would have a much more dedicated following if you didn't seem to be so careless with such simple things!
    Sunday, August 23, 2015 3:07 PM
  • After years of support, I'm starting to become a Microsoft not-liker. This issue so needs to be fixed, not worked around.... as i'm typing, my SP2 just woke up for no reason. I guess I'll just press the power button again like I've done the last 50 or so times.... Oh! It just turned back on, I'm not even kidding!
    Tuesday, August 25, 2015 3:06 AM
  • Yes, I have this exact problem too. Very frustrating. Have been doing full shut down to avoid having the computer run while in my bag. 
    Tuesday, August 25, 2015 2:40 PM
  • Just joining the chorus. Same issue after upgrading my SP2 on Saturday to Windows 10. I just changed the keyboard and mouse setting and, like everyone else, will watch and wait.
    Wednesday, August 26, 2015 10:08 PM
  • I also had the same problem with my Surface Pro 2 after upgrading to W10.

    Disabling Mice and other pointing devices didn't worked for me and also chat with MS and they said they are aware of this and will fix it soon via updates.

    But they also told me to try a clean install but if a upgrade screws things around then in the and the problem would come back.

    But for me I solved it turning on hibernation in the menu and when put in hibernation it stays in hibernation now so using this instead sleep modus now.

    Thursday, August 27, 2015 3:08 PM
  • Similar to some of you all, I tried the suggested fix of disabling the Keyboards/Mouse devices in the Device Manager, which did not work.

    However, it seems that there are distinct Device Manager profiles depending on whether peripherals, like the TypeCover keyboard, are connected to the device. I initially tried the fix with my keyboard connected, since I didn't want to fumble through a legacy app with my fingers, and once finished removed the keyboard and tried to sleep it...didn't work. A quick recheck of the Device Manager Keyboard/Mouse settings with no peripherals attached showed that the default Keyboard/Mouse devices in the Device Manager were back to being set to "Enable device to wake up computer". Disabling the options again with my fingers without anything connected finally allowed me to sleep the SP2.

    Monday, August 31, 2015 5:11 AM
  • Hello. I'm an Italian user, and have a surface pro. I found a solution this Centre issue by disabling the option "Allow hybrid sleep". This option is located in: PANEL Control> Power Option> change plan settings> Change advanced power settings> suspension, or sleep mode> Allow hybrid sleep. Turn off both. Sorry for my English.
    Wednesday, September 2, 2015 1:11 PM
  • To all yea that are affected by this, REPORT THIS VIA WINDOWS 10 FEEDBACK!!!

    Please remember to: "Vote" if my response was helpful. "Mark As Answered" if I answered your question correctly. V/R, Darrick West - Senior Systems Engineer, ConfigMgr: OSD

    Wednesday, September 2, 2015 8:57 PM
  • i did this and noticed a few days later, my choices on the settings had reverted back to enable wake up...anybody else have this problem?
    Thursday, September 3, 2015 11:56 PM
  • Just joining the chorus. Same issue after upgrading my SP2 on Saturday to Windows 10. I just changed the keyboard and mouse setting and, like everyone else, will watch and wait.
    10 days later and all is well. This did the trick for me, but I am not using any touch cover or peripherals so ymmv.
    Monday, September 7, 2015 4:26 PM
  • I hope Microsoft is planning on replacing my Surface Pro 2 for me when it melts down. It decided to turn itself back on inside it's case. The thing was roasting to the point of internal thermometer shutting it off today, and my battery was gone right when I needed it. I wonder if the NTSB would force a safety recall on them? lol #SurfacePro2Wontsleep
    Tuesday, September 8, 2015 1:07 AM
  • My Surface Pro 1 is doing this same thing. Thanks for the ideas on this thread. I also complained about the issue in the Windows 10 upgrade feedback box.
    Thursday, September 10, 2015 3:48 PM
  • While going through the device manager and disabling the devices from waking the computer, I noticed that I had 2 mice devices when my cover was attached and one when the keyboard is detached.  Checking the IDs, it actually loads a new mouse driver when you detach the keyboard.  

    This symptom description has made me think of something that no one has mentioned yet in this thread but it is something that I use (mostly on my Surface RT where I normally use the clip-on keyboard) but which evidently carries over to when I clip-on to the Surface 2 Pro (where I use it occasionally):   Surface Trackpad Settings app.  Normally I leave that with the Trackpad disabled.  Before that app existed I used a Desktop shortcut to expedite getting at the Mouse Properties Hardware tab so I could similarly disable the mouse pointer from that source

    C:\Windows\System32\rundll32.exe shell32.dll,Control_RunDLL main.cpl,,4

    Note that 4 gets overridden by Microsoft Mouse and Keyboard Center, so then I had to switch to the Hardware tab manually.  But now with the Surface Trackpad Settings app being available on both platforms I don't need that Desktop shortcut at all and only keep it for its documentation value, such as reporting it here.   ; )



    Robert Aldwinckle
    ---

    Thursday, September 10, 2015 4:41 PM
  • Same here
    Friday, September 11, 2015 2:33 PM
  • I turned off the wake on mouse and keyboard. It would still turn on.

    I then disabled the windows button (I used the Surface app) and now it seems to stay off.

    • Proposed as answer by AssafLi Monday, September 14, 2015 11:43 AM
    • Unproposed as answer by AssafLi Monday, September 14, 2015 11:43 AM
    Monday, September 14, 2015 11:43 AM
  • ¿¿How you disable the Windows Button??

    I'm on a Surface Pro 1 and suffer the same problem

    Wednesday, September 23, 2015 11:10 PM
  • Hello,

    This "extended" did the trick for me (it seem)

    thanks, and yes agree that an MS OS on a MS device should work nice (I also suffer of the Windows Foundation Driver consuming cpu)

    Thursday, September 24, 2015 10:01 AM
  • I then disabled the windows button (I used the Surface app) and now it seems to stay off.

    Thanks for the tip about "the Surface app".  Was that for Surface 3?  FWIW I have Surface 2 Pro and don't see anything in there which would help me change anything about its Logo button.  The app seems to be essentially a Modern UI version of Read Me (further complicated by the fact that now that I have W10 all the W8 help gets redirected to a W10 General FAQ page which completely loses the context of the Surface user's interest and furthermore has a Search tool which then completely loses even the W10 context--how disappointingly unhelpful.)   In any case searches about this on Answers were unfruitful too.


    Robert Aldwinckle
    ---

    Thursday, September 24, 2015 4:22 PM
  • Worked like a charm for my old original Surface Pro with Dell S2340T Docking monitor which does NOT have a W10 driver. Thank you, thank you! I was contemplating a roll back to 8.1 before I found this solution. I just wake with button on Surface now.
    • Edited by TechieMx Saturday, June 25, 2016 2:51 PM
    Saturday, June 25, 2016 2:50 PM