locked
exchange 2007 Sent Items not visible RRS feed

  • Question

  • I have a user whose sent items are not visible.

    I have checked to make sure there are no rules or views set up and have viewed the sent items folder by logging on as the user, opening the users mailbox as a secondary mailbox in someone else's profile and via OWA  in all cases the sent items folder appears empty but there is a message count on the status bar showing over 2,000 items.  This figure does increment each time a message is sent.

    I have tried resetting views and rules just in case, but given that the problem occurs when opened on OWA or as a secondary mailbox I don't think it is a view
    issue.

    I have tried creating a new profile for the user but the problem persists.

    The exchange server is a fully patched Exchange 2007 on SBS 2008
    Any assistance will be gratefully received. 

    Best regards





    James


    Tuesday, July 30, 2013 1:47 PM

Answers

  • Hi James,

    Please move user's mailbox into another database, see if that helps.
    If not, please save Sent Items folder data into PST file, and remove it with MFCMAPI. Then restore folder with /resetfolders switch
    http://mfcmapi.codeplex.com/

    Best regards.

    • Marked as answer by James McGinty Wednesday, July 31, 2013 2:25 PM
    Wednesday, July 31, 2013 1:26 AM

All replies

  • Hi James,

    Please move user's mailbox into another database, see if that helps.
    If not, please save Sent Items folder data into PST file, and remove it with MFCMAPI. Then restore folder with /resetfolders switch
    http://mfcmapi.codeplex.com/

    Best regards.

    • Marked as answer by James McGinty Wednesday, July 31, 2013 2:25 PM
    Wednesday, July 31, 2013 1:26 AM
  • Have you tried moving the mailbox to another database?

    If that's not possible you can dismount the database and run isinteg against it.

    Exporting to a PST is also a possibility.


    --- Rich Matheisen MCSE&I, Exchange MVP


    Wednesday, July 31, 2013 2:05 AM
  • Hi,

    I recommend you use C-Ex's suggestion and please check if it exists some hide rules.

    Best regards,
    Amy

    Wednesday, July 31, 2013 7:28 AM
  • Thanks to all for the assistance.

    I hadn't considered using another database as we support small businesses and none of them have a second database.

    Unfortunately when I moved the database it resulted in there being no sent items transferred across and the message count was reset to 0.  However when I sent a couple of test emails they are now showing in sent items so at least moving forward the customer will have his sent items.

    Best regards

    James

    Wednesday, July 31, 2013 2:36 PM
  • Running isinteg in "fix" mode may have been able to recover the messages. If the count of messages increased when you sent mail from the mailbox but you couldn't see the messages then your best bet would have been running isinteg.

    When you moved the mailbox were errors recorded? Check the directory C:\Program Files\Microsoft\Exchange Server\Logging\MigrationLogs (on the server that you ran the mailbox move from).


    --- Rich Matheisen MCSE&I, Exchange MVP

    Wednesday, July 31, 2013 9:47 PM
  • Thanks Rich

    I will bear that in mind if it happens again.  The customer is happy for now and hopefully we will be changing their server soon and they will upgrade to the latest version of Exchange.

    Thursday, August 1, 2013 1:40 PM