locked
Web URL Monitoring RRS feed

  • Question

  • I am trying to set up a URL site monitor, though the test results of the monitor on the Web Address do not result in a 200 HTTP Response Code. Testing gives me a 401 HTTP Response Code. Does this mean I need to get it to result to a 200? How do I do that? Is it because the end of the URL I am testing is not a .com, .corp, or something liek that?  The URL I want to monitor is a website starting with HTTP, but thelink opens a CSV

       http://servername/reportserver?/Support/View Running Processes (servername)&rs:Command=Render&rs:format=CSV.

    Monday, August 29, 2011 11:03 PM

Answers

  • Could be due to proxy setting and/or proxy settings for the computer account of the machine that is monitoring the website.
    Try to use an fqdn name for the server name, see if it helps (again also for proxy settings and exclusions this might have effect). The 401 is an error. The 200 is an OK :-)
    First check the short link (for instance http://servername/reportserver) and see what it does there before you go for the longer url.
    Bob Cornelissen - BICTT (My BICTT Blog) - Microsoft Community Contributor 2011 Recipient
    • Proposed as answer by Nicholas Li Thursday, September 1, 2011 2:26 AM
    • Marked as answer by Nicholas Li Tuesday, September 6, 2011 6:33 AM
    Tuesday, August 30, 2011 6:26 AM
  •  

    Hi,

     

    Regarding the code 401, please see to the following document:

     

    Troubleshooting HTTP 401 errors in IIS

    http://support.microsoft.com/kb/907273

     

    To monitor an URL, please also refer to the following methods:

     

    How to Create a Web Application Monitor

    http://technet.microsoft.com/en-us/library/bb381370.aspx

     

    Custom URL Monitoring Part I – The Design

    http://blogs.msdn.com/b/rslaten/archive/2009/07/07/custom-url-monitoring-part-i-the-design.aspx

     

    Automating the setup of URL monitoring

    http://blogs.msdn.com/b/boris_yanushpolsky/archive/2007/08/11/automating-the-setup-of-web-site-monitoring.aspx

     

    Hope this helps.

     

    Thanks.


    Nicholas Li - MSFT
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Nicholas Li Tuesday, September 6, 2011 6:33 AM
    Thursday, September 1, 2011 3:37 AM
  • First make sure that you are able to access the URL from the Watcher node you have configured.

     

    If it requires proxy to access the URL from watcher node then you have configure the proxy ifor that web application in SCOM.

     

    Thanks

    • Marked as answer by Nicholas Li Tuesday, September 6, 2011 6:33 AM
    Thursday, September 1, 2011 5:18 AM
  • In some cases where proxy settings are absolutely needed (for whatever reason) you will know this because your user account also needs these internet explorer proxy settings to browse anywhere. If this is the case there is a chance the execution account also needs this. If you are still on win03 boxes you could use the proxycfg command (for instance proxycfg.exe -u  to pick up the user settings) or the netsh command (http://technet.microsoft.com/en-us/library/cc731131(WS.10).aspx). In any case, take it one step at a time with testing and you will quickly find out where the problem is. Mostly it is something simple :-)
    Bob Cornelissen - BICTT (My BICTT Blog) - Microsoft Community Contributor 2011 Recipient
    • Marked as answer by Nicholas Li Tuesday, September 6, 2011 6:33 AM
    Thursday, September 1, 2011 5:53 AM

All replies

  • Could be due to proxy setting and/or proxy settings for the computer account of the machine that is monitoring the website.
    Try to use an fqdn name for the server name, see if it helps (again also for proxy settings and exclusions this might have effect). The 401 is an error. The 200 is an OK :-)
    First check the short link (for instance http://servername/reportserver) and see what it does there before you go for the longer url.
    Bob Cornelissen - BICTT (My BICTT Blog) - Microsoft Community Contributor 2011 Recipient
    • Proposed as answer by Nicholas Li Thursday, September 1, 2011 2:26 AM
    • Marked as answer by Nicholas Li Tuesday, September 6, 2011 6:33 AM
    Tuesday, August 30, 2011 6:26 AM
  •  

    Hi,

     

    Regarding the code 401, please see to the following document:

     

    Troubleshooting HTTP 401 errors in IIS

    http://support.microsoft.com/kb/907273

     

    To monitor an URL, please also refer to the following methods:

     

    How to Create a Web Application Monitor

    http://technet.microsoft.com/en-us/library/bb381370.aspx

     

    Custom URL Monitoring Part I – The Design

    http://blogs.msdn.com/b/rslaten/archive/2009/07/07/custom-url-monitoring-part-i-the-design.aspx

     

    Automating the setup of URL monitoring

    http://blogs.msdn.com/b/boris_yanushpolsky/archive/2007/08/11/automating-the-setup-of-web-site-monitoring.aspx

     

    Hope this helps.

     

    Thanks.


    Nicholas Li - MSFT
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Nicholas Li Tuesday, September 6, 2011 6:33 AM
    Thursday, September 1, 2011 3:37 AM
  • First make sure that you are able to access the URL from the Watcher node you have configured.

     

    If it requires proxy to access the URL from watcher node then you have configure the proxy ifor that web application in SCOM.

     

    Thanks

    • Marked as answer by Nicholas Li Tuesday, September 6, 2011 6:33 AM
    Thursday, September 1, 2011 5:18 AM
  • In some cases where proxy settings are absolutely needed (for whatever reason) you will know this because your user account also needs these internet explorer proxy settings to browse anywhere. If this is the case there is a chance the execution account also needs this. If you are still on win03 boxes you could use the proxycfg command (for instance proxycfg.exe -u  to pick up the user settings) or the netsh command (http://technet.microsoft.com/en-us/library/cc731131(WS.10).aspx). In any case, take it one step at a time with testing and you will quickly find out where the problem is. Mostly it is something simple :-)
    Bob Cornelissen - BICTT (My BICTT Blog) - Microsoft Community Contributor 2011 Recipient
    • Marked as answer by Nicholas Li Tuesday, September 6, 2011 6:33 AM
    Thursday, September 1, 2011 5:53 AM