none
Windows 10 IE 11 Enterprise List not switching automatically

    Question

  • Hello,

    I am having an issue with the Enterprise Mode IE Website List not automatically entering Enterprise Mode when I visit the specific site. If I choose Tools - Enterprise Mode it works, but I was under the impression this should happen automatically if using the list with the GPO

    Here is what is in my sites.xml

    <?xml version="1.0" encoding="utf-8"?>
    <site-list version="7">
      <created-by>
        <tool>EMIESiteListManager</tool>
        <version>10.0.14357.1004</version>
        <date-created>08/18/2016 18:51:30</date-created>
      </created-by>
      <site url="peoplefirst.myflorida.com">
        <compat-mode>IE10</compat-mode>
        <open-in>IE11</open-in>
      </site>
    </site-list>

    and the GPO is pointing to \\server\share\IE11EnterpriseMode\sites.xml

    This file is accessible to anyone on the network, and when I look in the registry under HKCU\Software\Policies\Microsoft\Internet Explorer\Main\Enterprise Mode the correct entries are listed

    The GPO is created on Server 2012R2 and the testing PC is a VM of Windows 10 Version 1607 (Anniversary Update)

    What have I missed?

    Thanks,

    Phil

    Tuesday, August 23, 2016 6:18 PM

Answers

  • if the GPO registry settings are applying to the user (enable EM and use a site list), and, you are launching the browser and waiting the suggested time period (up to 65 seconds?), the sitelist xml file should be downloaded and visible in the user's browser cache/TIF.

    The sitelist will be parsed and the version number recorded in registry.

    If that is all happening, then EMIE is working.

    If the expected docmode isn't being applied, check that you are using the matching name, specified in the same way.

    i.e. if you have specified somehost.somedomain.tld in the sitelist, the user must use the same form of name.

    We found that some users only enter/bookmark the unqualified hostname e.g. somehost, and this is not considered a match in the sitelist. So we found that we had to add internal hostnames in both forms, unqualified and fully qualified.


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    • Marked as answer by Phil_Adler Friday, August 26, 2016 2:34 PM
    Wednesday, August 24, 2016 10:19 PM

All replies

  • Check HKCU\Software\Microsoft\Internet Explorer\Main\EnterpriseMode -> CurrentVersion should be equal to your XML site-list version.  If it's not, then the PC is not reading the .xml file.

    If the version number matches, try setting this GPO: Computer Configuration -> Policies -> Admin Templates -> Windows Components -> Internet Explorer -> Let users turn on and use Enterprise Mode from the Tools menu. Set to 'Disabled'.  This will prevent you from manually toggling Enterprise Mode, but it can help determine whether or not IE is changing modes properly.

    Tuesday, August 23, 2016 8:56 PM
  • Well this is very strange. I have 2 non admin users on my test vm. Both are in the same OU and have the same GPO applied. One user has the correct version in the key you listed above, and the other user does not even have the enterprise mode key. 

    I have disabled Let my Users turn on Enterprise Mode and for both users the site in question does not automatically go into enterprise mode?

    What is next?

    Phil


    • Edited by Phil_Adler Wednesday, August 24, 2016 2:55 PM typo
    Wednesday, August 24, 2016 2:18 PM
  • After doing some further testing. I have gotten the registry settings correct. I mistyped the path in the gpo. I have tried with the Let user setting both enabled and disabled and neither way does the website in question automatically go into enterprise mode. If I have let users enable then click tools - enterprise mode it obviously works

    Phil

    Wednesday, August 24, 2016 8:04 PM
  • if the GPO registry settings are applying to the user (enable EM and use a site list), and, you are launching the browser and waiting the suggested time period (up to 65 seconds?), the sitelist xml file should be downloaded and visible in the user's browser cache/TIF.

    The sitelist will be parsed and the version number recorded in registry.

    If that is all happening, then EMIE is working.

    If the expected docmode isn't being applied, check that you are using the matching name, specified in the same way.

    i.e. if you have specified somehost.somedomain.tld in the sitelist, the user must use the same form of name.

    We found that some users only enter/bookmark the unqualified hostname e.g. somehost, and this is not considered a match in the sitelist. So we found that we had to add internal hostnames in both forms, unqualified and fully qualified.


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    • Marked as answer by Phil_Adler Friday, August 26, 2016 2:34 PM
    Wednesday, August 24, 2016 10:19 PM
  • also, note that if you are using Roaming User Profiles, this complicates EMIE, and strange/inconsistent things start happening...

    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Wednesday, August 24, 2016 10:21 PM
  • We are not using roaming profile just redirected My Documents Folder. So if my file reads peoplefirst.myflorida.com and they bookmark http://peoplefirst.myflorida.com it will not work? Also do I need to add a wildcard to the end because the main page redirects to a login page that is always different? 

    Something like this http://peoplefirst.myflorida.com/* then another entry for peoplefirst.myflorida.com/*

    Thursday, August 25, 2016 12:01 PM
  • No. What I meant was if you have people who use "peoplefirst" as the hostname but you have "peoplefirst.myflorida.com" in the EM sitelist, that unqualified vs qualified hostname reference will not be regarded as a match.

    the protocol prefix shouldn't be necessary, unless you needed http to get different DocMode compared to https (which would be unlikely but not impossible IMHO)


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Thursday, August 25, 2016 9:15 PM
  • Thank you very much I have everything working as expected.
    Friday, August 26, 2016 2:33 PM