locked
ManageTypes Registry Key setting: Unable to add or manage file type associations as a standard user RRS feed

  • Question

  • Hi

    We run an SCCM integrated App-V infrastructure.

    Right now, we cannot configure the App Virt Client to allow a standard user (non-local admin) to modify file type associations.

    I set the following registry keys:

    HKLM>Software>Microsoft>Softgrid>4.5>client>Permissions>ManageTypes to a DWORD value of 1 as per this article:http://technet.microsoft.com/en-us/library/cc843746.aspx

    I've even set the equivalent under HKLM>Software>Wow6432Node>Microsoft>  xx  to no avail.

    The option to add New associations is not present when these keys are set, for a standard user.

    Can anyone advise me on how this can be configured correctly? What have I missed?

    Regards,

    Max

    Tuesday, October 2, 2012 1:27 AM

All replies

  • After you set the reg did you restart the App-V service?

    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Tuesday, October 2, 2012 3:38 AM
  • ! trolling?

    of course... PC has been restarted several times

    Tuesday, October 2, 2012 3:47 AM
  • Hello,

    No need to be unfriendly when someone asks you to share information, you did not previously share.

    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, October 2, 2012 5:36 AM
  • What happens if you set the permissions via the App-V client console instead of the registry directly?


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    Tuesday, October 2, 2012 7:07 PM
    Moderator
  • Hi Aaron, the permissions show up as set on the permissions tab (Manage File Type Associations is checked), however user still cannot add a file type association
    Tuesday, October 2, 2012 7:37 PM