locked
Teredo and IPHTTPS connections both active when starting computer RRS feed

  • Question

  • I have come across an issue where the Teredo and IPHTTPS connections are both active when starting up my DA system. Even after I have logged into the system both connections are active, although if i disable the wireless and then reenable it again then only a Teredo connection is established.

    I am unsure why this would be the case and would have thought the IPHTTPS connection would be terminated once the Teredo connection was established. This is creating two seperate tunnels back to my UAG environment and I cant have that moving forwards as we deploy this to more and more clients.

    Any assistance in trying to find out what is causing this would be appreciated.

    Friday, February 10, 2012 11:02 PM

All replies

  • Monday, February 13, 2012 9:31 AM
  • I looked through that and from what I can tell it must be a network timing issue that is causing both the interfaces to start up when the DA client is booted up. Where would I even start trying to find out what is causing this to happen. Could it be related to an IPS?

    Monday, February 13, 2012 4:48 PM
  • Hi Amig@. Does it always happen or is it just a temporary issue?

    // Raúl - I love this game

    Tuesday, February 14, 2012 4:08 PM
  • This happens everytime I boot a DA system up. I even tried bypassing the IPS as a test but still got the same results.

    When I power the DA laptop up and it gets network connectivity it is activating the Teredo and HTTPS interface at the same time. If I do a nslookup on the DA laptop you can see both the Teredo and HTTPS addresses switching back and forwards.

    If i then disable the network connection and then enable it again it then just enables the Teredo interface.

    My question is why is it not just enabling the Teredo interface at the start and is there anyway I can change this so that I am not getting both interfaces active on startup

    Tuesday, February 14, 2012 5:29 PM
  • Hi Amig@. As per the article, there is no apparent way to change that behavior

    // Raúl - I love this game

    Wednesday, February 15, 2012 3:19 PM
  • I sort of had this. my issue was though with windows firewall. I had GPO settings which set some windows firewall settings to do with the teredo tunnels etc. this meant i had 2x each firewall setting. this then lead to connection confusion and i would randomly see certificate errors. some days i would connect fine others not at all and was all a bit random.I removed the GPO's so i only had the 1 default windows firewall setting and wallah.

    Otherwise try tracerts, pings and pingpath. it might just be your connection is to slow some where.

    Sunday, February 19, 2012 8:43 PM
  • I see this behavior too - it's a bug.

    I would like to see Microsoft release a hotfix as there is a performance implication since Teredo outperforms IP-HTTPS.

    Monday, February 20, 2012 11:19 AM
  • I haven't seen any activity in this thread in a while.  I too am seeing this behavior.  I can temporarily disable the teredo interface on the client and then set the state to "enterprise" client and the ip-https interface will deactivate.  Surely there is a setting somewhere to favor the teredo interface over the ip-https one?

    Thursday, April 25, 2013 1:12 AM
  • We are seeing the same issue here. DA-clients are connecting via iphttps and teredo at the same time, registering both 2001: and 2002: ipv6 in our DNS, which makes remoting/manage-out from our corp lan unreliable.

    I have tried to disable iphtts or teredo adapters (one at the time), but this just disconnects the DA-session.


    We are running DA2012, and the UDP Teredo port is opened.

    Thursday, June 27, 2013 9:42 AM