locked
SIP Trunk to ITSP - Inbound calls RRS feed

  • Question

  • Hello, I am trying to set up a SIP Trunk between our provider and Lync.  Outbound works fine but inbound we get a fast busy.

    Looking at the Lync SIP messages I see the Lync server is sending back a 401 Unauthorized.  Really not sure where to look from here and any help would be appreciated.

    INVITE

    TL_INFO(TF_PROTOCOL) [0]0B68.3130::02/09/2012-17:41:04.191.003c72e7 (SIPStack,SIPAdminLog::TraceProtocolRecord:SIPAdminLog.cpp(125))$$begin_record
    Trace-Correlation-Id: 307727242
    Instance-Id: 007BD8B1
    Direction: incoming
    Peer: 10.250.0.5:45353
    Message-Type: request
    Start-Line: INVITE sip:5035551212@172.20.1.9 SIP/2.0
    From: "OUTSIDE CALLER"<sip:9715551200@10.250.0.5;user=phone;03347-009-6bw=03347-009-6bwis-p5s6nm0ue2jt8>;tag=846622964-1328809262979-
    To: "ACME ARCHITECTS ."<sip:5035551212@mcleodusa>
    CSeq: 832184258 INVITE
    Call-ID: BW174102979090212-1493362431@64.198.149.137
    Via: SIP/2.0/TCP 10.250.0.5:5060;branch=z9hG4bKkuhcjq3048rhrrcb26m1.1
    Contact: <sip:9715551200@10.250.0.5:5060;03347-009-6bw=03347-009-6bwis-gu1l82t0ojep7;transport=tcp>
    Allow: ACK,BYE,CANCEL,INFO,INVITE,OPTIONS,PRACK,REFER,NOTIFY
    Accept: multipart/mixed,application/media_control+xml,application/sdp
    Supported: timer
    Min-SE: 60
    Max-Forwards: 47
    Content-Type: application/sdp
    Content-Length: 272
    Message-Body: v=0
    o=- 1100569074 1 IN IP4 10.250.0.5
    s=-
    c=IN IP4 10.250.0.5
    t=0 0
    m=audio 20040 RTP/AVP 18 0 8 101
    a=sendrecv
    a=ptime:20
    a=rtpmap:18 G729/8000
    a=rtpmap:0 PCMU/8000
    a=rtpmap:8 PCMA/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-15
    a=fmtp:18 annexb=no
    $$end_record

    REPLY

    TL_INFO(TF_PROTOCOL) [0]0B68.3130::02/09/2012-17:41:04.191.003c770a (SIPStack,SIPAdminLog::TraceProtocolRecord:SIPAdminLog.cpp(125))$$begin_record
    Trace-Correlation-Id: 307727242
    Instance-Id: 007BD8B2
    Direction: outgoing;source="local"
    Peer: 10.250.0.5:45353
    Message-Type: response
    Start-Line: SIP/2.0 401 Unauthorized
    From: "OUTSIDE CALLER"<sip:9715551200@10.250.0.5;user=phone;03347-009-6bw=03347-009-6bwis-p5s6nm0ue2jt8>;tag=846622964-1328809262979-
    To: "ACME ARCHITECTS ."<sip:5035551212@mcleodusa>;tag=863582BDEE39B598D5238773A681DEF1
    CSeq: 832184258 INVITE
    Call-ID: BW174102979090212-1493362431@64.198.149.137
    Date: Thu, 09 Feb 2012 17:41:04 GMT
    WWW-Authenticate: NTLM realm="SIP Communications Service", targetname="PDX-LYNC-1.fakedomain.local", version=4
    WWW-Authenticate: Kerberos realm="SIP Communications Service", targetname="sip/PDX-LYNC-1.fakedomain.local", version=4
    WWW-Authenticate: TLS-DSK realm="SIP Communications Service", targetname="PDX-LYNC-1.fakedomain.local", version=4, sts-uri="https://pdx-lync-pool.fakedomain.local:443/CertProv/CertProvisioningService.svc"
    Via: SIP/2.0/TCP 10.250.0.5:5060;branch=z9hG4bKkuhcjq3048rhrrcb26m1.1;ms-received-port=45353;ms-received-cid=112D600
    Server: RTC/4.0
    Content-Length: 0
    Message-Body: –
    $$end_record

    Thursday, February 9, 2012 6:40 PM

Answers

  • Hello, I am trying to set up a SIP Trunk between our provider and Lync.  Outbound works fine but inbound we get a fast busy.

    Looking at the Lync SIP messages I see the Lync server is sending back a 401 Unauthorized.  Really not sure where to look from here and any help would be appreciated.

    on what port your mediation service is running?

    Did you enable TCP port on your mediation server?

    Make sure the SIP trunk provider sends traffic to your mediation TCP port and not the port of your RTCSRV service.

    From the logs, it looks like you've enabled TCP port 5060 on your rtcsrv/lync front end service and inbound sip trunk traffic is hitting your FE service instead of the mediation one. That's why you are getting "401 unauthorized" response.

    • Proposed as answer by Noya Lau Thursday, February 16, 2012 5:17 AM
    • Marked as answer by Noya Lau Thursday, February 23, 2012 11:58 AM
    Friday, February 10, 2012 1:37 AM

All replies

  • is the SIP trunk Lync certified?

    is the DID 5035551212 assigned to a lync user or autoattendant?

    also, the DID is not coming to you as e164, do you have a normalization rule?

    some quick things.


    +Say thanks and observe basic forum courtesy:
    +If this post answered your question, Mark As Answer
    +If this post was helpful, Vote as Helpful

    windowspbx blog: my thots/howtos
    see/submit Lync suggestions here: simple and public


    Friday, February 10, 2012 1:08 AM
  • Hello, I am trying to set up a SIP Trunk between our provider and Lync.  Outbound works fine but inbound we get a fast busy.

    Looking at the Lync SIP messages I see the Lync server is sending back a 401 Unauthorized.  Really not sure where to look from here and any help would be appreciated.

    on what port your mediation service is running?

    Did you enable TCP port on your mediation server?

    Make sure the SIP trunk provider sends traffic to your mediation TCP port and not the port of your RTCSRV service.

    From the logs, it looks like you've enabled TCP port 5060 on your rtcsrv/lync front end service and inbound sip trunk traffic is hitting your FE service instead of the mediation one. That's why you are getting "401 unauthorized" response.

    • Proposed as answer by Noya Lau Thursday, February 16, 2012 5:17 AM
    • Marked as answer by Noya Lau Thursday, February 23, 2012 11:58 AM
    Friday, February 10, 2012 1:37 AM