locked
Cannot change network type to Home RRS feed

  • Question

  • Hello everyone!

    A week ago I decided create a homegroup. I wanted to change network type to Home on one PC with Windows 8.1.

    The issue is, when I open Network and Sharing Center and click to Work Network, it doesn't click and lettering is black there.

    I tried to change network type to Public first and from this point change it to Home, by disabling Network Discovery and Common Access for files, so Network Type became Public. However, I still cannot change it's type also from Public, as lettering is black. So I turned Network Discovery and Common Access for files back and network type automatically changed back to Work.

    The question is can I switch network type to Home for that PC?

    Monday, December 7, 2015 1:05 PM

Answers

  • Hi Kirill,

    At first, one thing we should realize is that there are just two network types(Public and Private) in Windows 8.1 system. The Home network which we usually talk about belong to Private network.

    In your scenario, current network type is Public, we could try the following steps to change network type.

    1.Open the Settings app

    2.Go to Network -> Connections

    3.Click on the connection type you are using.

    4.Change the option "Find devices and content":

    - if you need to turn your network into a Public network, i.e. unsafe for sharing, set it to "Off".

    - if you need to make your network Private, i.e. network is safe for sharing and common access, set it to "On".

    The web page below can make operations look more intuitive.

    https://tinkertry.com/how-to-change-windows-8-1-network-type-from-public-to-private

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Hope my suggestion could be helpful.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, December 8, 2015 7:17 AM

All replies

  • Hi Kirill,

    At first, one thing we should realize is that there are just two network types(Public and Private) in Windows 8.1 system. The Home network which we usually talk about belong to Private network.

    In your scenario, current network type is Public, we could try the following steps to change network type.

    1.Open the Settings app

    2.Go to Network -> Connections

    3.Click on the connection type you are using.

    4.Change the option "Find devices and content":

    - if you need to turn your network into a Public network, i.e. unsafe for sharing, set it to "Off".

    - if you need to make your network Private, i.e. network is safe for sharing and common access, set it to "On".

    The web page below can make operations look more intuitive.

    https://tinkertry.com/how-to-change-windows-8-1-network-type-from-public-to-private

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Hope my suggestion could be helpful.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, December 8, 2015 7:17 AM
  • Hi Kirill,

    We have not heard from you in a couple of days. Please post back at your convenience if we can assist further.
    Just checking in to see if the information is helpful.

    Please let us know if you would like further assistance.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, December 15, 2015 9:24 AM
  • Hi Teemo,

    Thanks for help and explanation! With this I understood the difference between Win7 and Win8.1 network types. Yesterday my colleague successfully changed network type to Private with your instructions, and created home group.


    Friday, December 18, 2015 11:46 AM