locked
Enable Readyboost after migration from SSD to HDD RRS feed

  • Question

  • Hi,

    I recently reimaged one of my laptop on hdd with the image of ssd installation. I need to test readyboost performance gain with expresscard ssd on this new hdd setup but somehow windows 7 refused readyboost saying system disk is fast. Ran performance index but no success. As far as I could check, windows 7 seems to be recognizing current system disk as HDD correctly but could not proceed further.

    Where does windows 7 store information whether current system disk is SSD or HDD? How can I fix my current problem?

    Thanks in advance.

     

    Wednesday, December 29, 2010 2:00 AM

Answers

  • Delete all file from the folder "C:\Windows\Performance\WinSAT\DataStore" and run WinSAT again to calculate the Index. Now your HDD score should be lower and you should be able to start Superfetch. This service hosts the ReadyBoost driver in Windows 7.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    • Marked as answer by Arthur Xie Friday, January 7, 2011 9:26 AM
    Wednesday, December 29, 2010 12:18 PM

All replies

  • Delete all file from the folder "C:\Windows\Performance\WinSAT\DataStore" and run WinSAT again to calculate the Index. Now your HDD score should be lower and you should be able to start Superfetch. This service hosts the ReadyBoost driver in Windows 7.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    • Marked as answer by Arthur Xie Friday, January 7, 2011 9:26 AM
    Wednesday, December 29, 2010 12:18 PM
  • Andre, thx for the tip but although I followed it, still no change.
    Thursday, December 30, 2010 1:26 AM
  • what have you made? Run WinSAT again? Have you enabled the Superfetch service?

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Thursday, December 30, 2010 12:27 PM
  • Superfetch was enabled right after reimaging and when Win 7 recognize the HDD. Ran WinSAT after deletion of the datastore files.
    Friday, December 31, 2010 1:51 AM
  • And? is ReadyBoost working now? When Superfetch is running, the ReadyBoost driver is also started.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    • Proposed as answer by stcdwc Tuesday, July 10, 2012 6:12 PM
    • Unproposed as answer by stcdwc Tuesday, July 10, 2012 6:12 PM
    Friday, December 31, 2010 3:07 PM
  • Hi

    I have the same problem.  Dead SSD so I restored W7 on HDD.  I reset Win SAT, which showed a slower disk, and set superfetch to automatic (checked this by looking at the registry).  But my USB drive persists in saying that the system disk is too fast, so will not readyboost.  So there must be some marker in the registry that is NOT reset.  If someone can tell me where this is, I'd be very grateful.  This set of comments seems to not have arrived at a solution.

    BTW I have given up on SSDs (OCZ) after 2 failures in a year.  Each time I have to reset/reload the family's computer, which takes a day of my time.  i.e. Time spent of fixing problems >> time saved by SSD.

    Tuesday, July 10, 2012 6:23 PM