locked
CM Hotfix KB4163547 pre-requisite check broke 1802 Service Update in pre-production state RRS feed

  • Question

  • I was running SCCM 1703 and decided to update to 1802 last week. I installed the 1802 service update (using a validation collection) and all was working well. Today I was intending on pressing the "Promote pre-production client" button but noticed a new update just released, Hotfix KB4163547 for 1802. 

    Instead of 'promoting' the 1802 Service Update, I ran the pre-requisite check for the Hotfix which passed however I did notice the CMUpdate.log was showing some errors:

    • Error information persisted in the database
    •  Waiting for changes to the d:\..  Cmupdate.box directories update will be      polled in 600 seconds

    * I think this is where I went wrong, I didn't fully commit the 1802 update before running the pre-req check on the Hotfix?

    I rebooted then noticed in the Updates and Service tab, the KB4163547 was completely gone, and also for the 1802 update the "Promote pre-production client" button was now greyed out (was not before)... now I am a bit worried what state my updates are in?

    I have tried running the following (with the GUID matching the Easyupdate name for the Hotfix update, however this failed

    Now in the CMUpdate.log I am seeing a 10 minute cycle of the following messages:

    Error information   persisted in the database.
    Waiting for changes to the   "D:\Microsoft Configuration Manager\inboxes\cmupdate.box"   directories, updates will be polled in 600 seconds...
    There is no redist version. Use default   redist version 201802
    INFO: setup type: 1, top level: 1.
    Update package will not install as it is   marked for prereq check only.
    INFO: SQL Connection succeeded.   Connection: SMS ACCESS, Type: Secure
    Error information persisted in the   database.
    Waiting for changes to the   "D:\Microsoft Configuration Manager\inboxes\cmupdate.box"   directories, updates will be polled in 600 seconds...
    There is no redist version. Use default   redist version 201802
    INFO: setup type: 1, top level: 1.
    Update package will not install as it is   marked for prereq check only.

    Any ideas of how to fix?




    Wednesday, June 13, 2018 7:55 AM

Answers

  • Just to update, the product group pulled the update as there was a delivery issue (not a problem with the update itself, just how it was being delivered to certain customers). They will be re-publishing it soon though.

    Jason | https://home.configmgrftw.com | @jasonsandys

    Wednesday, June 13, 2018 5:50 PM

All replies

  • Same behavior here!! Even with the 1802 client already deployed as "production" I launched this morning the pre-requisites check and it's been failing every 10 minutes since. No activity in C:\ConfigMgrPrereq.log at all


    Wednesday, June 13, 2018 1:11 PM
  • One of my client had the issue. it looped for about 24hours or so, but finally reported passed.

    I reran it to see how it would go, and returned pass quickly this time.

    Running the installation now.. will see how it goes


    Wednesday, June 13, 2018 2:18 PM
  • Just to update, the product group pulled the update as there was a delivery issue (not a problem with the update itself, just how it was being delivered to certain customers). They will be re-publishing it soon though.

    Jason | https://home.configmgrftw.com | @jasonsandys

    Wednesday, June 13, 2018 5:50 PM
  • Thanks Jason, this resolves most of my concerns.  I am assuming that because I initiated a Pre-requisite check on Hotfix KB4163547 this cleared the EasySetupPayload for 1802 therefore blocked me from "Promote pre-production client"?

    I still would prefer to install the Hotfix across my production fleet but hope I don't have to wait weeks for this?

    Thanks again!

    Wednesday, June 13, 2018 10:33 PM
  • David James (@djammmer) said yesterday on twitter that they'll have a fix in a day or two

    https://twitter.com/bachirica/status/1006888113887735813


    Thursday, June 14, 2018 5:02 AM
  • Hotfix is published again, I cannot install it right now in my environment, but at least the pre-requisites go through ok!!
    Friday, June 15, 2018 10:44 AM
  • I have installed 1802 Hotfix 4163547 and successfully promoted pre-production client.  Thanks for the assistance and updates Jason and Bernado!
    Friday, June 22, 2018 1:11 AM