locked
App-V 5 over https for non-domain clients RRS feed

  • Question

  • Hello, Is this scenario possible?
    Tuesday, December 18, 2012 2:42 PM

Answers

  • Hi there, I have managed to get this scenario working.

    Assuming you have a functional App-V 5.0 infrastructure in place, the first thing you need to do is install the App-V client on the non-domain workstation.

    Next, you need to run Windows Credential Manager, and enter the details for your App-V publishing server, and the domain account that is to be used.

    Next, you must manually configure the App-V client on the workstation to point to your publishing server (add-appvpublishingserver). Ensure you are running the powershell window as a local administrator.

    You should now be able to sync your non domain joined App-V client with your App-V infrastructure.

    For my own records I am going to put up an entry on a blog with a guide on doing this containing screenshots. Let me know if it is not clear from the above and I can provide this.

    Thursday, February 7, 2013 10:05 PM

All replies

  • Hello,

    As far as I know this is unsupported.


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, December 19, 2012 5:14 PM
  • Hello,

    As far as I know this is unsupported.



    Interestinly, apparently MS over here have advised they will support this scenario, so long as Windows Credential Manager is being used, and only if a 3rd party credential management application was used would they not support it.
    Wednesday, January 23, 2013 10:24 PM
  • Hello,

    See this document to review how Microsoft seems a workgroup environment to leverage App-V 5 from an infrastructure perspective, if you do not leverage another 3-party solution.

    http://support.microsoft.com/kb/2780807


    Nicke Källén | The Knack| Twitter: @Znackattack

    Saturday, January 26, 2013 12:51 PM
  • Hi there, I have managed to get this scenario working.

    Assuming you have a functional App-V 5.0 infrastructure in place, the first thing you need to do is install the App-V client on the non-domain workstation.

    Next, you need to run Windows Credential Manager, and enter the details for your App-V publishing server, and the domain account that is to be used.

    Next, you must manually configure the App-V client on the workstation to point to your publishing server (add-appvpublishingserver). Ensure you are running the powershell window as a local administrator.

    You should now be able to sync your non domain joined App-V client with your App-V infrastructure.

    For my own records I am going to put up an entry on a blog with a guide on doing this containing screenshots. Let me know if it is not clear from the above and I can provide this.

    Thursday, February 7, 2013 10:05 PM
  • Hello and thanks for the procedure

    However I can't seem to make it work . I have a non domain computer , not on the network of my Appv Infrastructure.

    I installed appv client on the computer, configured it with the proper command lines (add-publishingserver), using the external name of my publishing server for which I have a certificate.

    I configured my credentials, using control panel, credentials manager.

    But every time I try to sync with the publishing server ( with the APpv client, or the powershell), I end up with the following error in the event viewer:

     

    It is like it manages to see the applications ( there are 2) but cannot deploy them.

    Any help would be appreciated.

    Thanks

     

    Wednesday, March 27, 2013 7:30 PM
  • It may be a problem with the credentials as I set them up in the credentials manager. Can you provide more information on that part ?

    Thanks

    Wednesday, March 27, 2013 7:41 PM
  • Hey Proximitynz, where can I find that blog post (if you made it)?
    Thursday, April 18, 2013 1:25 PM
  • Hi,

    here's how I have it set in my lab. Your mileage may vary, but hopefully this should give you all the different components of how I managed to get it to work, and allow you to try something similar.

    Firstly, my publishing server is: HTTPS://CSC-APPV5.CSC.local:8016

    I have an application published through the app-v console, with the package URL configured to be: HTTPS://CSC-APPV5.CSC.local/APPVSHARE/Notepadplusplusx86/notepadplusplusx86.appv

    This is published to the AD group CSC.local\notepadplusplus, of which the user CSC.local\appvuser is a member of.

    On my Windows 8 non domain joined computer, Press Start, type "credential manager", and click on this option under settings.

    Click on "Windows Credentials", then click "Add a Windows credential".

    It will ask you for the Internet or network address. Based on the information I stated earlier, I entered the address: CSC-APPV5.CSC.local

    for User name, I entered: CSC.local\appvuser

    and lastly for password I entered the current valid credentials for this user.

    To test this, I then browsed to the publishing server mentioned above, but found that it still prompted me for a password (but remembered the user ID I had specified), and that the app-v client would not sync through powershell.

    I then added http://csc-appv5.csc.local into this devices local intranet zone (im sure you can avoid this step by adjusting a various number of settings, this was just the first quick test I performed).

    Browsing to the publishingserver address now no longer prompted for a username/pw - correctly showing the application published to this user. I then performed a restart (unlikely to be required, but I just wanted to have a clean run from a user perspective), and straight away, there was my shortcut to the appv application, and running it resulted in the normal streaming you would expect.

    The one thing I will add is I was very particular around fully quilifying everything, to eliminate this as a potential issue, and would be one of the first places I would start if you are attempting to troubleshoot why you were not able to get this to work.

    Friday, May 17, 2013 3:59 AM
  • Hi there,

    I never got around to it as I was going to have to create a whole new blog at the same time. Essentially I have the bones of the article, including screenshots, but no home to put it yet. It's still on my to-do list, especially as a few people have stumbled across this thread and contacted me on Twitter about it.

    Friday, May 17, 2013 4:01 AM
  • I have the same problem. But after enabling the debug log of Streaming - Transport. I find that there are errors in URI for File Reqest with UNC path to the .appv file stored for adding in Management Server web interface. The .appv file are stored in a shared folder of another domain server. Following that error, there is another one saying that CreatFile failed with status: The user name or password is incorrect.

    Then I type the UNC path in File Explorer in the non-domain client computer  and enter the domain username & password. After that, although there are other errors in other debug log in various App-V client components, the update in App-V is successful and the application can be launched from the shortcut.

    I orginally thought the package is sent from Publishing Server to the client through HTTP. But seems that I am wrong and the package is obtained from a shared folder.  Or is this behavior is due to my configuration ?


    • Edited by normanhk Wednesday, June 19, 2013 10:09 PM missing the fact that the shared folder is on another server
    Wednesday, June 19, 2013 10:04 PM
  • Hi there.same scanrio here.i want run app-v on a workgroup and non domain network.

    please do me a favor and leve a link from your article with screenshots here for me.thanks a lot.

    Saturday, December 20, 2014 4:51 AM