locked
Facing issue in HPC 2016 pack installation on windows 2012 r2 RRS feed

  • Question

  • We are working on a proof-of-concept, wherein we are planning to install Microsoft HPC (High Performance Computing) Pack 2016. We have one head node and 2 compute nodes in this architecture. All nodes are Virtual machines on a CentOS 7 blade server.

    We have passed through the initial step of installing certificates on all the 3 machines.

    Now while installing HPC Pack on head node, we are getting an error when the installation reaches this step:

    i) installing Microsoft Service Fabric Cluster Error is :

    Component Microsoft Service Fabric Cluster cannot be installed with error code 1. If a different version of Service Fabric runtime or SDK had already been installed in this machine, uninstall them and rerun setup .

    Possible solutions that we came through while googling:

    1) Head node installation may fail if the installation files are blocked

    The installation package downloaded from Microsoft Download Center may be blocked by your operating system for security reasons. If you extract the installation zip file package without unblocking, the extracted installation files may be blocked as well. In this case, the head node installation will fail when installing the Microsoft Service Fabric cluster. To fix this issue, unblock the installation zip file in the file Properties, as shown in the following figure. Then, extract to a new folder, and run Setup.exe from the new folder again.


    2) Head node installation may fail on Windows Server 2016 Anniversary edition if secure boot is enabled

    Due to an issue with the Service Fabric lease layer driver, if your head node machines run Windows Server 2016 Anniversary edition with secure boot enabled, the HPC Pack head node installation may fail when creating the Service Fabric cluster. The workaround is to disable secure boot on all head node machines and install again.


    But we are unable to resolve the error, using above mentioned solutions. Because,

    • For 1), There is no Security Info in the properties tab.
    • For 2), Secure boot isn't available for the head node.

    Can anyone provide some pointers on this?

    Thanks in advance!

    Wednesday, August 30, 2017 9:43 AM

All replies

  • Please try to clean the fabric by using the PowerShell as administrator and open the file "C:\HPC\HPC Pack 2016\ServiceFabric\CreateServiceFabricCluster.ps1"

    This has helped me.
    Thursday, October 5, 2017 2:07 PM