locked
AD photos not showing up in Office 365/Skype for Business RRS feed

  • Question

  • I've gone through and added profile photos to all the employees we have that I have photos for.  I'm using a program called CodeTwo Active Directory Photos.  It'll scaled and size my photos for me and applies them to the AD attribute thumbnailPhoto.  DirSync has synced the changes, but nothing is showing in Outlook or Skype for Business or logging in to the O365 web portal.  What gives?  It's been over 12 hours since the changes were pushed to O365.

    Any help is appreciated!!

    Wednesday, April 6, 2016 2:10 PM

Answers

  • Hi,

    May I know if all of sfb users are hosted on O365? Have you deployed sfb server 2015 on premise or Exchange server? So that you can create a on premise test account to verify if the photos can show from the on premise end. Moreover, I suggest you pick up one test account to do following test:

    1. Change an AD attribute(such as Work Phone) of this account manually
    2. Run DirSync
    3. Check the DirSync details to confirm if the updated AD attribute has been synced with O365.

    4.  Sign into sfb or Outlook to confirm if the AD attribute can display normally

    5. If it works, please remove the AD attribute thumbnailPhoto, and upload the phone manually, and perform the same steps from step2 to step4.

    Hope these help.

    Best Regards,

    Cindy Li


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help.


    • Edited by Cindy_lim Thursday, April 7, 2016 11:40 AM
    • Proposed as answer by Liinus Friday, April 8, 2016 1:03 AM
    • Marked as answer by Eason Huang Thursday, April 14, 2016 6:23 AM
    Thursday, April 7, 2016 11:20 AM

All replies

  • Hi,

    May I know if all of sfb users are hosted on O365? Have you deployed sfb server 2015 on premise or Exchange server? So that you can create a on premise test account to verify if the photos can show from the on premise end. Moreover, I suggest you pick up one test account to do following test:

    1. Change an AD attribute(such as Work Phone) of this account manually
    2. Run DirSync
    3. Check the DirSync details to confirm if the updated AD attribute has been synced with O365.

    4.  Sign into sfb or Outlook to confirm if the AD attribute can display normally

    5. If it works, please remove the AD attribute thumbnailPhoto, and upload the phone manually, and perform the same steps from step2 to step4.

    Hope these help.

    Best Regards,

    Cindy Li


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help.


    • Edited by Cindy_lim Thursday, April 7, 2016 11:40 AM
    • Proposed as answer by Liinus Friday, April 8, 2016 1:03 AM
    • Marked as answer by Eason Huang Thursday, April 14, 2016 6:23 AM
    Thursday, April 7, 2016 11:20 AM
  • Hello NSH-Guy,

    As stated in this article: http://windowsitpro.com/blog/synchronizing-user-photos-across-office-365-workloads-isnt-easy, as long as user’s photo is 96x96 pixels and up to 10 KB it should be synchronized to Office 365 without issues.

    You can also check this thread on a similar topic: https://community.office365.com/en-us/f/148/t/31174.

    However, any inconsistence in displaying user’s photos would require Microsoft to unify the location of those photos across Office 365 services. 

    Best regards,

    Adam (CodeTwo)

    CodeTwo: Software solutions for Exchange and Office 365

    Friday, April 8, 2016 8:45 AM