locked
NLB CAS only works with one Node RRS feed

  • Question

  • Hi,

    I have 2 servers CAS / HUB physical with Exchange 2010 SP3.
    The network card configuration for these servers is:

    Server: CAS1
    NIC1-Service: 10.10.10.98 (GW, DNS, activate ipv4 and ipv6)
    NIC2 NLB: 10.10.10.198 (IP and Mask Only, disable netbios, dns register. IPv6 desactivate. Forwarding interface = enabled)

    Server: CAS2
    NIC1-Service: 10.10.10.99 (GW, DNS, activate ipv4 and ipv6)
    NIC2 NLB: 10.10.10.199 (IP and Mask Only, disable netbios, dns register. IPv6 desactivate. Forwarding interface = enabled)

    NLB:
    Name: nlb-cas.contoso.local
    IP: 10.10.10.200
    Unicast
    Ports 25 and 465 (Disable) ,80,110,135,143,443,587,993,995,1024-65535 (Multiple and Single affinity)

    Created point in the DNS for nlb-cas to 10.10.10.200
    Alias ​​for rpc client access to Outlook.contoso.local

    When installing the server CAS1 build the NLB and everything worked properly. I recently installed CAS2 server and when I've been in the NLB, has stopped working access to OWA, ActiveSync ...)

    It's funny because from the same subnet 10.10.10.X/24 if accessed with both nodes, but from the outside or another subnet (10.10.11.X/24) not accessed.

    The traffic was never by TMG or FWs nor between the network and the network 10.10.11.X/24 10.10.10.x/24. I can do a ping and tracert correctly.

    I tried to put GW in NIC2 NLB and still not working.

    I tried to shut down the server first and start the second in the NLB and it works but when I turn on the first server and get in on the NLB does not work.

    The configuration is identical on both servers, but I can not work with the two in the NLB. A level event viewer no errors.

    Please I need help in order to have high availability for CAS / HUB.

    Thank you very much.

    Tuesday, June 4, 2013 8:10 AM

All replies

  • Hi there,

    First, I'd suggest you verify the CAS Array configuration according to Microsoft article below:

    http://blogs.technet.com/b/samdrey/archive/2012/09/27/exchange-2010-links-to-how-to-setup-cas-array-with-a-load-balancer.aspx

    And then, just a reminder,

    • A CAS array object does not service Autodiscover, <acronym title="Outlook Web App">OWA</acronym>, <acronym title="Exchange Control Panel">ECP</acronym>, <acronym title="Exchange Web Services">EWS</acronym>, <acronym title="Internet Mail Access Protocol">IMAP</acronym>, <acronym title="Post Office Protcol">POP</acronym>, or <acronym title="Simple Mail Transfer Protocol">SMTP</acronym>

    See <acronym title="Simple Mail Transfer Protocol"></acronym>http://blogs.technet.com/b/exchange/archive/2012/03/23/demystifying-the-cas-array-object-part-1.aspx


    Fiona Liao
    TechNet Community Support

    Wednesday, June 5, 2013 2:06 AM
  • Thanks for reply Fiona,

    I have read all the items (very good), CAS Array configuration, and I see that I have anything misconfigured. The only differences I find are:

    - I use NLB. It should not be a problem not using HW Balancer.
    - The configuration of ports in the NLB, use for both protocols, not just TCP. I do not think it's a problem.
    - I have not set the dynamic RPC ports in static, using the port range 1024-65535. I do not think it's a problem.
    - The name of the NLB is NLB-Exchange.contoso.local with IP: 10.10.10.200. For the mail (owa), autodiscover, outlook (RPC Client Access), I have configured for each of these an Alias ​​in DNS and not a Host (A).  But I understand that this is not a problem, because:

    NLB-Exchange.contoso.local responds to 10.10.10.200
    Mail.contoso.local (Internal OWA url) responds to 10.10.10.200
    Mail.contoso.com (External OWA URL, split DNS zone for contoso.com) responds to 10.10.10.200
    Autodiscover.contoso.local responds to 10.10.10.200
    Outlook.contoso.local responds to 10.10.10.200

    As for your second point about the CAS Array and services autodiscover, owa, ews ... I have all set. I followed the link and I have everything correctly configured.

    With the two CAS servers in NLB, nothing works except if coming from the same subnet. You may have a routing problem in the two CAS servers? As I said I have two NICs in the same subnet,  GW is defined in Public NIC and NIC for NLB has forwarding = enabled.
    I may have to add routes to this netsh interface NLB NIC to work?

    But, with one CAS in NLB everything works fine ...

    Very Thanks for everything.


    Wednesday, June 5, 2013 8:27 AM
  • Are these servers physical or virtual?  Unicast or Multicast for NLB?

    Also, check your bindings on the network adapters.

    http://www.kraftkennedy.com/blog/bid/102109/Configuring-NLB-for-Exchange-2010-CAS-Load-Balancing

    Wednesday, June 5, 2013 3:39 PM
  • Hi ty72182,

    The servers are physicals. NLB is Unicast.

    In the network cards, I have two. The order of the cards is:

    1. - Public (GW)
    2. - NLB

    NLB Nic has forwardind = enabled.

    I followed step by step this URL. NLB only works with a server (CAS01 or CAS02), if I put the two servers does not work.

    As said before, from the same subnet works but from other not accessed ...

    Thanks for answering.

    Wednesday, June 5, 2013 6:36 PM
  • Greetings

    Were you able to find the fix for this issue. Am facing same issue in my Exchange environment.

    Thanks


    • Edited by K 2 Tuesday, September 22, 2015 9:41 PM
    Tuesday, September 22, 2015 9:41 PM
  • Please do not re-activate multiple threads.

    Replied to your other re-activate posting.


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Wednesday, September 23, 2015 1:01 AM