none
Configure Logon Script Delay GPO issues

    Question

  • In deploying a Logon script via GPO on the first 2012R2 server that I've done this on (done it plenty on 2008R2 and earlier), I stumbled across this little gem that Microsoft put in there to delay the running of GPO based logon scripts. After discovering the five minute delay, I found the GPO setting to adjust or disable it. This is where my problem is.

    If I leave the policy alone, everything default, five minutes after logging in, the script runs and the application I'm launching launches. If I set the GPO (domain or local) to Enabled/1 minute, the script runs and the app launches one minute after I log in. The problem is if I set the policy to Enabled/0 or disabled, the script NEVER runs. Enabled/0 and Disabled are supposed to disable the delay and make it run immediately, not never.

    I've spent a decent amount of time searching, and maybe I'm not searching for the right terms, but I haven't been able to find anything helpful. Everything I've found has been related to the GPO and people saying 'yes setting it to disabled or enabled/0 made my script run right away'. Nothing similar to my issue seems to have come up.

    Does anyone have any ideas what might be happening here?

    Thursday, August 06, 2015 6:57 PM

All replies

  • What exactly is the script doing?


    Darren


    Darren Mar-Elia MS-MVP, Group Policy
    www.gpoguy.com
    www.sdmsoftware.com - "The Group Policy Experts"

    Friday, August 07, 2015 3:45 AM
  • > Does anyone have any ideas what might be happening here?
     
    Your system possibly boots too fast :) Increase Startup Policy
    (refers to W7, but should be still valid).
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:
    Friday, August 07, 2015 10:00 AM
  • I made the 'Startup Policy processing wait time' changes recommended via the registry and rebooted the server as well as changed the GPO setting for the script delay to zero and the behavior is the same.

    Darren, the logon GPO is just launching an in-house executable that loads fonts for individual users.

    Friday, August 07, 2015 3:01 PM
  • > and Disabled are supposed to disable the delay and make it run
    > immediately, not never.
     
    Anything about that in the Group Policy Eventlog?
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:
    Monday, August 10, 2015 3:16 PM
  • I don't know why it's not showing here, but I got an e-mail that Martin had replied again, but for some reason, I'm not seeing that reply here.

    In response, though, there are no warnings or errors of any kind in the Group Policy event log. Everything there is 'informational'. I have 4018 and 5018 events that indicate that a script was started and completed successfully, and the time of the last one correlates with 1 minute after I logged my test user in (that's what I just set the GPO scrip delay to).

    Monday, August 10, 2015 4:41 PM
  • On the affected machine, go into the registry under HKLM\Software\Policies\Microsoft\Windows\System, and see if you see a value of EnableLogonScriptDelay, with data set on it. If so, delete the value and see if the problem goes away. If you do see the value, it could mean that GP is not picking up the change you made to it in policy (which is another problem).


    Darren


    Darren Mar-Elia MS-MVP, Group Policy
    www.gpoguy.com
    www.sdmsoftware.com - "The Group Policy Experts"

    Tuesday, August 11, 2015 4:43 AM
  • The key was there, but I had the GPO set to enabled/0. I removed it and rebooted, and it came back - I then went into Group policy management and changed the policy to disabled and the entry dissipated when I refreshed, then reappeared when I set the GPO to enabled/1, so the GP is making the appropriate changes to the registry.

    The mystery here is why when I set the DELAY to 0 or disabled, it never runs the file, but if I set it to anything greater than or equal to 1 (or 'not configured'), it runs when it's supposed to based on the GPO or default delay.

    Tuesday, August 11, 2015 1:41 PM