locked
AHCI functionality recently lost RRS feed

  • Question

  • Vista Business 32bit. Intel PA35 chipset (mobo: gigabyte ga-p35-ds3l rev 2), ICH9 southbridge (not ICH9R), core2 quad 6600. 2 seagate SATAII 320GB perpendicular-recording HDs (not raid), 1 DVD-RW sata drive, 4gb DDR2 800mhz.

     

    Vista was installed clean with AHCI functionality pre-enabled in BIOS (mobo bios is v.F5; the AHCI function, enabled within BIOS, is from Intel, iSRC 1.07 08042006 [I think]) .

     

    The AHCI functionality I was expecting (hot-plug an external SATA drive) functioned okay for the first month. Sometime after New Years, it stopped. It also appears my device mgr hardware enumeration has changed somewhat, though I'm not sure, as I didn't really document things before and after. All I know is that suddenly I could no longer hot-plug external SATA drive to do backups. (I use both USB and ESATA hard drives for backup, alternating between them. The last successful ESATA hot-plug backup was on 12/26. The next few backups were done with the USB drive. Somewhere around 1/12 I tried an ESATA hot-plug backup and it no longer worked. But it can still be used, in its external enclosure, in a non-hot-plug context, so there's nothing wrong with it hardware-wise.)

     

    The only change made between the last successful AHCI hot-plug and the first unsucessful one was Windows Update: these were installed between the above two dates:

    -Security Update for Windows Vista (KB941644)
    -Update for Windows Vista (KB943411)
    -Windows Malicious Software Removal Tool - January 2008 (KB890830)
    -Update for Windows Mail Junk E-mail Filter [January 2008] (KB905866)
    -Update for Windows Vista (KB943302) 'application compatibility issues'
    -Update for Windows Vista (KB943899) 'reliability update'
    -and several Windows Defender definition updates

     

    Does anyone know of similar issues? I've considered trying to uninstall those last 2 listed updates, or disabling and then re-enabling AHCI in bios, or checking 'detect HAL' in msconfig, or re-installing ACPI driver from the Vista DVD, but I'm reluctant to try any of them without at least inquiring for feedback.Other than the lost AHCI functionality, everything is fine (if Vista can ever be called fine, with its file-copying, LAN, and folder-opening slowness), and I've already run into activation issues just by reinstalling Vista from scratch on the same machine. (Originally I had installed Vista using the full Intel Storage Matrix stuff, but that cause all kinds of problems, so I started from scratch in early December, skipping the Intel Storage Matrix and letting Vista handle AHCI natively. At that point, my attempt to activate for the 2nd time was denied; I had to get a new product ID via phone. Inexcusable! This is a full retail version of Vista Business!) I don't want to 'borrow trouble', but I'm also irritated at having lost the AHCI functionality.

     

    Any knowledgeable/helpful comments would be appreciated.

     

     

     

     

     

     

     

     

     

    Monday, January 21, 2008 7:48 AM

Answers

  • Hi,
     
    Please perform a system restore to narrow down the cause of this issue.
     
    1. System Restore
     
    We will check whether the problem caused by applying windows update.If it is,then we have to uninstall windows update list in your post.

    Note: If you have some important documents or files which were created after the restore point, please copy them to My Documents. By doing this, even if you back the system up to the initial status, the documents will be saved in My Documents.

    To restore your system to a previous state(windows update has not been installed), we can use the following steps:

    1. Before you start, please close all open files and close all open programs.
    2. Click "Start"; click "Programs or All Programs"; click "Accessories"; click "System Tools"; and click "System Restore". The System Restore user interface should appear.
    3. Select "Restore my computer to an earlier time" and click "Next".
    4. From the restore points available, select an appropriate restore point when your system was working correctly and click "Next".
    5. Click "Next" again. The restore process will run and your system will restart automatically.
    6. After restarting, check whether your system functions correctly now. If not, you can undo your last restoration or select another restore point in the System Restore user interface.
     
    What is System Restore?
     
    2.Please check the status for AHCI in BIOS,whether it has been enabled.
     
    3.Please check  'detect HAL' in msconfig and update the driver for it (including motherboard driver)
     
    Intel® P35 Express Chipset
     
    Intel Chipset
     
    Hope it helps.

    Best regards,

    Xiu Zhang - MSFT

    Microsoft Online Community Support


    Thursday, January 24, 2008 9:28 AM