locked
Exchange Server 2007 Sync Problem with Windows Phone 7.5_ RRS feed

  • Question

  • Hi all, I have got this weird problem with Exchange Server 2007 sync with Windows Phone Mango. I have got the following HTC Model.

    Specifications

    Smartphone       : HTC Titan x310e

    Windows             : Phone 7.5

    OS Version          : 7.10.7720.68

    Firmware             : 1600.2200.10902.401

    Bootloader          : 1.8.160015.3(132000)

    Chip Soc Ver       :1.6.0.0

    Exchange            : 2007 Server with the Latest Updates

    Access                 : OWA Enabled / Active Sync Enabled

    Certificate Auth   : Local Certificate Authority. NO third-party

     

    What I need

    I am not able to send and receive E-mails on my Smartphone. Always require Outlook information pops-up although the information I have entered is correct. In short I need to Sync my Exchange e-mails on my HTC TITAN Windows Phone 7.5

    What I did

    1.       Went to HTC TITAN Mobile Settings > Add Email accounts

    2.       While adding exchange account, it doesn’t find my exchange server settings. Error message “ We couldn’t find your settings”

    3.       Enter manually all the Details such as

    4.       E-mail address

    5.       Password

    6.       Domain Username

    7.       Domain that I logon to at my workplace

    8.       And then click “Sign-In”

    9.       Message comes up “we couldn’t find your settings”

    10.   I click now “advanced” tab

    11.   Enter my Mail server “mail.domain.local” (this is the OWA address that I type on the IE bar i.e http://mail.domain.local

    12.   Then I click on “Sign-in”

    13.   Error message “Not trusted certificate for the domain”

    14.   I then installed the ROOT CA from my domain that issued to the Exchange Server. (I can confirm this because next to the Certificate it states “Root Certificate”, DER Coded binary). I created another Hotmail account and e-mailed it to that. From the Hotmail account, I installed the certificates. Don’t know where it got installed on my Windows Phone

    15.   After which another messages pops-up “ you would require a private certificate”

    16.   I enrolled and requested a Private certificate from my CA. I exported all including the Private keys

    17.   After which it syncs my e-mails, Temporarily

     

     What is happening now

     

    1.       But after few minutes of inactivity, I get pop-up message “ Update your information for mail.domain.local and press save”

    2.       I look at my Exchange OWA under mobile devices, it says Sync Status is “OK”

    3.       I have entered more times that I can remember and it still asks me

    4.       Leaving it alone won’t do any good as it won’t sync AT ALL

    5.       I have Resetted the phone and re-installed the certificates

    6.       I have recreated the Outlook account, works for first 10 Minutes ONLY

    7.       Made sure all the Windows Phone 7.5 updates are in place using Zune

    8.       Made sure all the WIFI and Data Connections are available.

    9.       Created Hotmail account simultaneously and it SYNCS very well

    10.   What am I doing wrong ??? L

     

    Thanks for all your help. Funny iPhone and Android Devices don’t ask for all this and in one short, everything works perfect.

    Joseph

    Friday, November 18, 2011 5:15 PM

All replies

  • You should use ActiveSync feature to configure your email account. You will see ActiveSync pressing the HOME KEY (in most smartphones.)
    Where Technology Meets Talent
    Friday, November 18, 2011 6:10 PM
  • Hi I did that but still its asking for please update your Outlook information as it is incorrect. Made sure I am in the Right Time zone, Right system locale i.e US, time, date, Certificates are valid dates and not expired ones etc. Any other options. Thanks for your help.
    Friday, November 18, 2011 6:50 PM
  • I've got the same issue. Have you figured it out yet?
    Friday, December 2, 2011 11:12 PM
  • Hi Bgarland, I have tried all the possible methods and still no luck. This is weird that off the shelf iphone and other handled devices sync fine without any issues and this Windows Phone can't talk properly with their own species..

     

    Joseph

    Monday, December 5, 2011 10:51 AM
  • Have you tried to set it up with advanced settings instead of picking Outlook? 

     

    I had the same problem but when i used advanced it worked!

    Wednesday, January 11, 2012 11:12 AM
  • I am experiencing this very same issue. why does it only work for a short time.

    I have also heard this too many times on this forums, but why did MS break this on thier own phone, where as it works just fine on android and idevices?  That is my biggest complaint so far.  But it would be nice if some of the apps were free and quality. 

     

    Mods/Devs we need answers to this issue.

    Jack

    Friday, January 13, 2012 6:05 AM
  • Joe,

    I am also experiencing issues with connecting to our Exchange 2003 SP2 environment from and HTC HD7 device running 7.5.  Although, I did not have errors with certificates, I am getting constant prompts to update my password on the device.  It's intermittent, and seems to happen more often when switching between WiFi and cellular service.  Not sure if that's just coincidence or an actual indication of where the problem may in fact lie.

    Really wish we could get this problem fixed sooner than later.  Hard to make the case for Windows Phones when I can't even get them working with Exchange. :(

    Phil

    Thursday, February 23, 2012 3:16 PM
  • I have the same problem but using Exchange 2010 and Windows Phone 7.5 (refresh).  The strange thing is that it works fine unless I am on the internal WiFi network.  Anyone else have that exact issue?

    Exchange 2010 SP1

    Nokia Lumia 900 (Previously same problem with Samsung Focus)

    HELP!


    Mrl1te

    Saturday, April 14, 2012 12:06 AM
  • Same problem here, did you figure out how to solve it ?
    Saturday, April 21, 2012 9:57 AM
  • Hi all

    For those of you are having the Exchange Server 2007 sync to HTC titan (any models) please read through. Finally, thank God it is working after spending 5 months to resolve this. By now someone would have figured it out but I want to post it as it might help everyone. These are the different permutations that I have tried, hopefully Microsoft would resolve this in their update patches.

    SCNARIO ONE

    IMPORTANT: Your password for both Hotmail and Exchange Server should be this format . It should contain only wild characters and letters only NO numeric. Example O@%%rdi^ and it should be 8 characters in length. Please do this before proceeding below. This is only applicable if your Exchange Server Admin has enforced this weird policy.

    a. You should RESET your HTC phone (any model). This is required to have all the old certificates flushed out and new ones to be imported. To do this, go to Settings>About>Reset your Phone (Backup all contacts, picturers etc). All your certificates should have VALID dates and NO EXPIRED certificates, please !

    b. You should have a certificate based on all of the following. This is needed, else it won't work. Usually your Domain Administrator can help on this. See picture below

    Note: Make sure you export all of them one by one. Regarding Personal certificates, you can enrol from your computer to the CA(certificate authority) on your domain controller. I repeat this, make sure you export all certificates path if possible(see picture above). If it is asking to put password also for personal certificates, please make it as '123'. Short and simple

    c. Change your Hotmail Password or Yahoo Password or Gmail Password to the one you are using at your Office Exchange Server. Don't know why, but when I used to sync, I noticed my password length getting changed and the usual pop-up appearing that your settings are incorrect. Do this also, else it won't work.

    d. Now configure your Hotmail, Yahoo or gmail on your HTC any model phone. Once done. E-mail the certificates you had done in the previous steps.

    e. Open the e-mail certificates and it would ask whether you want to install. Install all of the certificates one by one.

    f. Now configure your Exchange e-mail. Please ensure the setting this way.

    • E-mail should be      full FQDN (fully qualified domain name, in my example joseph@domain.com)
    • Password should      be the one you logon either to your Outlook Web Access (Exchange Server)
    • Domain should be      the actual domain you logon on to the workstation. Your Techsupport can      let you know this or easy way to find out is joseph@domain.com. The one after'@' is your domain      name you logon on to
    • Username, should      be only the Username without'@' in the option      when prompted
    • Server, usually      the OWA webpage you logon onto. This is usually in this formatmail.domain.com. This settings      also can be provided by your System Administrator/Techsupport etc.
    • All other      settings as normal and Press 'Tick' to have the sync begin

    Once you have done this, wait for few minutes and all your e-mails would start to populate. I have tested this after even few hours and all is good.

    SCENARIO B

    Without configuring Hotmail or Gmail or Yahoo account on your HTC model, download the certificates via the Internet explorer browser on HTC phone. Do this because sometimes, accounts gets mixed in their password and password prompts appear. After you have successfully installed all the certificates, and then configure the Exchange account via the Active Sync.

    SCENARIO C

    The account name what you create for your Exchange server should be different. It should read some other name i.e EXCHANGE OFFICE, Domain EXCHANGE, Domain EXG, MY EXG. It shouldn’t have the name of your domain as in domain simply.

    SCENARIO D

    Restart your Phone if the password prompts appear again and again. Also, try to sync from your Office Wifi (which is not necessary) but a try.

    To check that it is actually syncing, Open your (OWA)web access e-mail i.ehttps://mail.domain.com. Once logged in. Go to options on the top right corner > Mobile devices. You would now see your Mobile devices synced and all other relevant details regarding your Phone synced and updated.

    SCENARIO E

    Try to go tohttps://www.testexchangeconnectivity.com and enter all the necessary details based on your exchange setup. I tried in Exchange ActiveSync and all connectivity tests showed fine.

    Note: Please make sure under your IIS, under Exchange ActiveSync>Right Click Properties and see the main properties as shown below. It has to be Ignore Client Certificates. If it is set to Accept client certificates, then you would have the problem stating that you need to update your passwords every now and then on your Mobile Device.

    These are the various methods I saw to resolving this.

    Let me know if you or anyone else is having the same problem. Thank GOD for his guidance on this.

    Regards

    Joseph

    • Proposed as answer by Amit Raichura Saturday, October 27, 2012 1:28 PM
    • Unproposed as answer by Amit Raichura Saturday, October 27, 2012 1:28 PM
    Saturday, June 9, 2012 6:25 AM
  • Same here. Omnia 7. Two factor authentication with certificate and password in Exchange Server. Never worked. Microsoft product does not like each other.

    :(.

    Monday, June 11, 2012 2:35 PM
  • Hi, All,

    My phone is Lumia 710, got same synch problem. Our company IT guys helped to look into it, but found no solution.

    But this problem's solved by simply add more specific domain name. For example: your email address is XYZ@ABC.com . We may think that ABC.com is your Domain name. That's what I believed and it is a default setting in my cell, but the connection had never been built up. Then I checked my Outlook settings on the computer. Our email domain's name is XXXX.americas.ABC.com. So I tried to add americas into the Domain name, americas.ABC.com. Problem solved!

    Your problem may not be the same as mine, it's no harm to have a try.

    Amanda

    Friday, September 7, 2012 2:17 AM