none
IE11 Ignoring Unattend.xml Customizations RRS feed

  • Question

  • Hey Everyone,

    We have added IE11 to an image for one of our sections, and are encountering an issue with any values added to the unattend.xml not being processed by IE11 when it brands itself. I confirmed that all customizations specified were present in the unattend.xml located in the panther directory of a test client.

    I checked the sysprep action log for the test client, and found that the customizations were being processed. I reviewed c:\users\username\appdata\local\microsoft\internet explorer\brndlog.txt and can see that it doesn't seem to be making any changes. However, all the values are present in HKLM\SOFTWARE\Microsoft\Internet Explorer\UnattendBackup\. Restoring the advanced settings in IE, which retriggers the process produces the same result, the values are not read, or seem to be skipped in brndlog.txt.

    I also noticed that the brndlog.txt contains the following two lines:

    "Active Setup stub for branding doesn't exist: Branding component not installed"

    "HKCU Active Setup Key not found"

    I checked the ActiveSetup keys in both HKCU and HKLM, and neither has an entry referencing iedkcs32.dll. There is one for ie4unint.exe -UserConfig.

    This is using the exact same process as we do for images with IE8 installed, which works without issue. Are there changes in IE11 that need to be accounted for in the imaging process? I can't use GPP for this as we maintain areas that have not yet migrated to a domain, and need to be able to control what is set during the imaging process.

    Thanks,

    Garrett

    Friday, October 31, 2014 2:26 PM

All replies

  • Hi Garrett,

    What tool did you use to deploy the image?

    Please upload the unattend log file in order to narrow down the issue. Located to this path:

    %WinDir%\Panther\UnattendGC

    compress this folder and upload it to OneDrive, paste the shared link in your next reply.


    Karen Hu
    TechNet Community Support

    Monday, November 3, 2014 3:09 AM
    Moderator
  • Hi Karen,

    The image was deployed by MDT 2013, and was originally captured from a Hyper-V VM configured with Windows 7 x64 SP1. The image originally had IE8, and was upgraded to IE11 via Windows Update.

    This process worked fine with IE8, on the same image.

    UnattendGC folder: http://1drv.ms/1GeU3Et

    I had checked through the logs enclosed, and confirmed that the registry values for the customizations as well as the lines intended for Install.ins are being written. It just seems like IE is ignoring them.

    As you'll notice in the logs, we are using copyprofile to specify a standard default user profile. I will turn that off in the unattend and see if it works as intended without it. We will require it, as we do need the customizations to the profile we are performing, but its possible something is being carried over that is causing this issue.

    Thanks,

    Garrett

    Monday, November 3, 2014 1:37 PM
  • Hello,

    I've confirmed that the two customizations in the unattend file, the home page and the search provider do work if copyprofile is not used. So, I guess there is something in the profile that causes IE to not update its values to match what is in the unattendbackup registry key and Install.ins.

    Any idea what that might be? I can always delete it manually from the profile before the image is created.

    Thanks,

    Garrett

    Monday, November 3, 2014 2:55 PM