none
Server 2016 Hyper-V trying to install 2016 guest black screen RRS feed

  • Question

  • This is now the 7th time I have tried to install Server 2016 as a guest on a Server 2016 host running Hyper-V. This is a brand new server we purchased 2 weeks ago and it has ample resources to virtualize over a dozen resource hungry guests. The first 3 times I attempted this, I created a fixed vhdx on an SSD raid array (not OS partition) and then used another SSD raid array to house the VM files. I set it for 8gb ram, the os image for cd and 4 cores. no network. All 3 times the install went seemingly well and rebooted to finalize the OS install. When I should be asked for an administrator password the screen was black. I could see the os booting BUT once the loading animation went away it was left at a black screen. On each attempt I deleted the VHDX and the vm files to start from scratch, i mean, i must be making a very simple mistake right?! I have only created VM's about 100 times in server 2012R2. The 4th try I decided to try a Gen2 VM with UEFI. I couldnt get the VM to boot off the 2016 x64 iso no matter the settings. Doesnt seem right as the iso should be UEFI but nevertheless I deleted the VM files and went back to Gen1. This time the OS got me to the administrator password entry but upon reboot to get into the OS, black screen... 5th try back to no screen before admin password entry and the 6th try YAY! i finally got into the OS... that was obnoxiously painful and very disheartening knowing this will be my new DC that i cant seem to get a remote view of... Yeah so i left it running with RDP open that night still not having a network connection. Today I shut the VM down to assign a physical nic from the virtual switch and what do you know? black screen and cant get into the OS. running out of space on our existing DC I dont have time to play with this anymore I reloaded the OS overtop of the existing attempt and this time with an active NIC. The OS is installed and updating BUT i do NOT trust this thing.

    Can anyone explain what this OS is doing and how I can get a screen out of it with RDP when i dont have a physical device to plug into? I know 2012 had this issue (black screen when trying to RDP into it) and it was resolved with an update long ago. This is the latest server 2016 x64 installer supplied by microsoft. Host is fully updated before trying to install vm's.

    Thursday, November 15, 2018 12:27 AM

All replies