locked
Autosave turned off - This workbook contains features that prevent it from using Autosave. RRS feed

  • Question

  • Hi, Please I need some help here. 

    I have a ton of excel files that come up with this error and I am unable to enable the autosave feature on these work books.

    Excel files are in all saved in .xlsx

    I have tried deleting all the sheets in the workbook but still have this error. 

    Can someone please help me understand why this is happening and how to fix it. Many thanks

    Monday, May 20, 2019 4:20 PM

All replies

  • Hi,

    Where did you save and open the file?

    Did this problem appear in all Excel files? How about creating a blank Excel files?

    What version number of Office did you use? Please go to File- Account and provide the information as shown in the following picture:

    As far as I know this feature is used to autosave to OneDrive or SharePoint. I suggest you check if you sync OneDrive or SharePoint automatically.

    This feature is only available for Office 365 subscribers, if the file is saved to another location (or if it hasn't been saved at all, yet), then AutoSave is disabled. This will happen if your file is on a SharePoint On Premises site, a file server, or saved to a local path like C:\.

    There are other reasons AutoSave could be disabled as well. Here are some common reasons for it to be disabled:

    • Your file is in an older format like .xls, .ppt, or .doc.
    • Your file is in a local OneDrive folder and OneDrive synchronization is paused.
    • Your file is being synced by an older version of the OneDrive sync client. For more information on updating OneDrive, see Get started with the new OneDrive sync client in Windows.
    • Your file is embedded inside another Office file.
    • Your presentation is in slide show mode.

    If you are using Excel, and tried the above, you may have a file that contains features that are not supported by AutoSave. Do one or more of the following to enable it:

    • Turn off the Shared Workbook feature. This feature is an older method of sharing. It has many limitations, and has been replaced by co-authoring.
    • If possible, remove password encryption from the file: Go to File > Info > Protect Workbook. Then delete the password and click OK.
    • If possible, remove restricted access: Go to File > Info > Protect Workbook > Restrict Access and click Unrestricted Access.
    • If you are opening a workbook snapshot from SharePoint, choose to open the file instead of the snapshot.
      Turn off the Refresh data when opening file setting on all tables and PivotTables in the file. Select the table or PivotTable, then go to Table Tools Design > Refresh > Connection Properties. Then uncheck Refresh data when opening file.
    • Inactivate an add-in that's causing AutoSave to be disabled. Select File > Options > Add-Ins > Excel Add-ins > Go and then clear the check box for the add-in.

    Please try these methods and check if you can get any help from it.

    Regards,

    Emi Zhang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Office 2019.

    Tuesday, May 21, 2019 8:12 AM
  • Hi,

    Just checking in to see if the information was helpful. Please let us know if you would like further assistance.

    Regards,

    Emi Zhang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Office 2019.

    Thursday, May 30, 2019 9:21 AM
  • Same issue.

    1. Closed the file without saving
    2. Opened the file in O365
    3. Allowed Excel Online to "fix it" in the web app
    4. Saw the "Saved" status at the top of the browser window
    5. Closed browser window
    6. Opened the file from Excel File > Open

    The AutoSave feature worked as expected without errors.

    Tuesday, November 12, 2019 7:24 PM
  • I found this to happen when there is an embedded object in the spreadsheet (like a word document or other ActiveX object).  I also found that AutoSave won't ever work with either an embedded object or link to external file in the spreadsheet.  No way around this and I could find no way to shut down the warning with VB. 

    BUT, I did find a way to shut off the warning for a file.  That is to delete all such objects and links in the spreadsheet, then turn off Autosave, save the spreadsheet, re-open it, add back the objects and save (never trying to enable Autosave for this file again).  The spreadsheet showed Autosave off, but no stupid warnings.  Whew!   

    It seems like something was out of sync.  Kind of a pain, but this worked.  I hope this helps.


    • Edited by Paul DL Saturday, November 30, 2019 8:27 PM
    Saturday, November 30, 2019 8:25 PM
  • This set of solutions / suggestions specifically did not work for me; I removed all metadata, and deleted all sheets, creating and saving it with only a new, empty sheet that did not exist previously.  Still, Autosave was turned off.  The fix was to go through all of the sheets and copy them into a new workbook.  I am uncertain what changed, but the file with the exact same everything was a few hundred KB larger, and now Autosave works just fine on the new file with all of the same content.

    NOTE:  There were no embedded objects or anything found in the original spreadsheet, and inspections and problem checking found nothing.  Strange, that it can detect Autosave should not be allowed, but cannot find any problems that would cause it to not work.
    • Edited by Darkpoetcc Thursday, December 5, 2019 3:51 PM Reword.
    Thursday, December 5, 2019 3:51 PM
  • The last time this happened at my company the employee, who has a touchscreen laptop, had accidentally "inked" the spreadsheet. The inking mark was a single dot, about 5 pixels in size, and took me quite some time to realize that was the cause. It would be nice if Excel would identify why/where it is being prevented from autosaving.
    Tuesday, May 26, 2020 3:59 PM