locked
SCCM 2012 SP1 Distribution Point Problem RRS feed

  • Question

  • Hi all,

    Today I reinstall the DP by go to \Administration\Overview\Site Configuration\Servers and Site System Roles\

    and remove and recreate again my DP because this DP OS corrupted and rebuild again.

    after I recreate again the DP and I getting the error msg at below :- Failed to find an available disk drive on the distribution point.

    and I quickly remote in to the DP and check I got pretty empty disk space on my D drive about 160GB free disk space.

    Not sure why failed to find an available disk drive.

    At sccm primary site server I getting in distmgr.log 

    Action taken :-

    Delete all the existing all the sccm dp folder :- d:\smssig$ ;d:\sccmcontentlib; d:\smspkgd$

    remove IIS

    still the same .. Help ...

    Sunday, November 3, 2013 6:52 AM

Answers

All replies

  • Doesn't distmgr.log tell any error code? Have you added the computer account of the site server to the local admins on the DP?

    Torsten Meringer | http://www.mssccmfaq.de

    Sunday, November 3, 2013 10:31 AM
  • Hi,

    Have you specified the value of Drive space reserve (MB) in Drive Settings page when you install the DP? If this value larger than the space in your computer drive, the error would appeared. (By the way, I cannot see the pictures above. Is this my problem?)

    Best Regards,

    Joyce Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Wednesday, November 6, 2013 4:35 AM
  • Problem Solve after reading this post.http://social.technet.microsoft.com/Forums/en-US/c831d3a9-ada6-4d1e-b0b7-59f052f20501/sccm-2012-sp1-remote-dp-install-issue?forum=configmanagerdeployment

    Riverbed issue.

    IF the SCCM 2012 SP1 is running on Windows Server 2012 and your remote site DP also is running on Windows Server 2012.so the communication for both  is using SMB 3.0 and the Riverbed not supported SMB 3.0 will it have issue ?

    Or can we use set SMB 3.0 to SMB 2.1 in Windows Server 2012 ? is there any option or feature can do this ?

    • Marked as answer by Joyce L Monday, November 11, 2013 10:50 AM
    Wednesday, November 6, 2013 1:17 PM
  • I'd fix the Riverbed issue first. Isn't there a new OS for them available that can handle SMB 3.0? Or can't you tell those devices to not touch communication between ConfigMgr and the DP?


    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, November 6, 2013 1:30 PM
  • Torsten , I use windows server 2008 R2 as DP no issue because it's using SMB 2.1.

    if I use windows server 2012 as a DP I had a problem. this is because of Customer Riverbed not support SMB 3.0.

    correct me if I'm wrong.

    Wednesday, November 6, 2013 1:35 PM
  • Hi Friends,

    Same issue with one of our server, and in my case the BITS Service was off

    I turned it back on and its working fine now

    Just thought of adding it here for it might help others too

    Regards

    Tanoj


    OSLM ENGINEER - SCCM 2007 & 2012

    Monday, November 9, 2015 12:34 PM
  • I was having the same issue but have a different fix... I found this on another site for different errors (http://visualplanet.org/blog/?p=274) but thought it may work for what I was dealing with. 

    I took over an SCCM environment. WMI errors happened on 4/30/16 and now for 2 months NOTHING has been deployed, distributed, or updated. I tried to communicate with WMI from my primary site to my DP and got 'Invalid Class' errors. Then when removed DP role and readded. It always failed with the same error as the OP.

    I found it impossible to restart the WMI service.

    I ran this command in powershell (which I found from the above site): Stop-Service winmgmt -Force; winmgmt /resetrepository

    Voila! I was able to add DP as a new role and distributed content. Not sure how long this fix lasts, but for now I am satisfied. 

    Tuesday, June 28, 2016 6:40 PM