none
Connect to non-standard port number on local development machine from win 10 emulator (referred)

    Question

  • I was referred here from this thread:

    https://social.msdn.microsoft.com/Forums/windowsapps/en-US/e5f2b1ea-7407-4b48-ab8a-acd603b57037/connect-to-nonstandard-port-number-on-local-development-machine-from-win-10-emulator?forum=wpdevelop

    I was told to ask this question here.

    ORIGINAL POST:

    My environment:

    • Visual Studio 2015 14.0.25431.01 Update 3
    • Windows 10 phone emulator
    • Universal windows app project
    • Dev machine is windows 10 Ver 1607 build 14393.577

    So I can launch my simple starter app and it appears in the emulator and I can debug it and all that is good.

    Then I try to send a simple JSON web request to a WebAPI on my development machine, running under IIS (not repeat not IISExpress) port 84. Get an triple nested exception stating : "The text associated with this error code could not be found.\r\n\r\nA connection with the server could not be established\r\n"

    So I fire up the browser on the emulator. I can connect to http://169.254.80.80 ... that's fine ... but when I try to connect to http://169.254.80.80:84 ... that's a problem. I get the vague check-engine-light error message "Hmm, we can't reach this page"

    Machines external to the dev machine can connect to port 84 on the dev machine. So it doesn't sound like a firewall thing on the dev machine.

    What do I need to do to get this emulator talking to port other than 80?

    Thanks,
    --Kerry

    Tuesday, February 21, 2017 2:05 PM

All replies