Service <NAME> failed to start due to error 1AA0182A-00000420.


  • Hello, we are attempting to sequence a fairly heavy duty clinical application with App-V, consiting of 7 dependency MSI's and 13 application MSI's. The application is Varian ARIA 11, it's a medical application and one so large and cumbersome to install, App-V is the only way we'll be able to deal with automating it IMO. When installing the framework component, two services are installed, one running as SYSTEM, the other as LOCAL SERVICE. The first attempt as sequencing missed the second service, running as LOCAL SERVICE until we changed it to run under SYSTEM and re-sequenced, where it was picked up the second time.

    We validated both services start under SYSTEM context (on a locally installed system) and of course having it run as SYSTEM is necessary for App-V to even virtualize the service. The issue we are having is the first service starts when the virtual application is launched but we get many errors with the other modules and all seem to be related to the second service, which fails to start (based on errors in the event log) with the following error; "Service Varian Syslog Daemon failed to start due to error 1AA0182A-00000420."

    We have tried to using advanced settings to "Allow COM objects to interact..." and "Allow all named objects to interact..." to no avail, we're stuck at this point looking to find out if that error code might point us in the right direction (no hits when searched). We are locally installing the 7 dependency MSI's on the sequencing box before sequencing the application and of course are also locally installing them on the clients before running the sequence, this issue doesn't seem to be a missing depedency issue...


    Jack Fetter

    • Edited by JFetter Wednesday, December 19, 2012 7:58 PM
    Wednesday, December 19, 2012 7:57 PM

All replies

  • Hello,

    If you start the service - where does it log its error messages?

    If you start the service manually, what happens then?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, December 19, 2012 9:32 PM
  • The error I am reporting is being logged in the App-V event log, I'm not sure how to manually start a virtualized service, is this possible? I was able to get into the bubble and review the application logs but all I see is the end result, nothing on why the service failed to start or what specific message it returned. All I can find is an application event log for the first service, which is starting up, I don't see an event logged to Windows for the second service. I did find something that MAY be related;

    The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID


    and APPID


    to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    This error may be generated from the service that's failing, I just don't know. I saw some rather cryptic errors in the application log seeming to point to a failed connection to, I just can't confirm what is trying to initiate it, the failed service or one of the modules and if it really means anything. On a side note I decided to give SYSTEM all the rights that LOCAL SERVICE has, just to see if it's a rights issus, no dice. We have confirmed the application works fine with SYSTEM when locally installed, I really would love to know what that error code from App-V maps to...

    Jack Fetter

    Wednesday, December 19, 2012 10:29 PM
  • I found more information about the daemon and a management GUI located within the bubble, which I can launch in the bubble but still not start the Syslog service or really get any meaningful information on the failure. The "setup" option within the management console has been "disabled by the vendor" so I'm not sure if given the chance I could find somthing that could be changed. I am trying to see if I can put it in debug mode to get better reporting, the exact product is; Varian Syslog Daemon, 8.1.7

    I have the option to uninstall, re-install (which creates a local install of the daemon, worth playing with I suppose depending on how these services communicate) but the logging is wanting...

    Jack Fetter

    Wednesday, December 19, 2012 10:59 PM
  • Hello,

    The App-V error code is probably not relevant, but if you want spend time investigating that as opposed to determing what your application does - you can read this;

    Lets put App-V aside for a minute and determine some basic Windows-knowledge and troubleshooting methodology;

    1. What happens if you NATIVELY installed the application and open a command-prompt. Locate the executable file, which makes up the service and execute it. What happens then?

    2. Have you contacted the vendor regarding the possibility to understand the service and retrieve logging capabilities?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, December 20, 2012 8:52 AM