[Internet Explorer] Flash Video and MP4 Video Are Not Displaying Correctly in Internet Explorer 10. Video Output Comes Green


  • Hello,

    Recently I faced with the problem were any Flash video or MPEG-4 video cannot be displayed correctly in either flavor of Internet Explorer. Videos are displayed like:

    These same videos are displayed correctly in Chrome browser...

    Well this is the world we live in And these are the hands we're given...

    Friday, July 27, 2012 9:29 AM

All replies

  • What is the model and manufacturer of your PC?

    Did you installed any software before problem happen?

    Run Windows Update and install all updates.

    Do you have same issue in other websites which are using flash too?

    As a workaround, try run youtube in HTML5 form, to do that start:


    Saturday, July 28, 2012 3:13 AM
  • Hi,

    I have the same problem. Suddenly it seems mp4 video don't play in IE 10.
    I installed all updates of Windows 8 Release Preview. I tried also youtube in html 5 but I still see green background instead of the video.

    I recently installed Microsoft Office 2013 preview, Virtual Box and enabled Hyper-V. I also installed the latest version of Zune.

    Monday, July 30, 2012 3:37 AM
  • Open internet explorer in desktop and go to tools->internet option and then in advance tab uncheck use GPU Rendering and then click apply and close and reopen IE and see what is the result.

    Monday, July 30, 2012 2:48 PM
  • Hi,

    I didn't find the option "Use GPU rendering", instead I found "Use software rendering instead of GPU rendering". I checked it and restarted the computer but the problem is still present, green background and no video played.

    Tuesday, July 31, 2012 3:40 AM
  • Hi,

    I solved the problem enabling the option "Use software rendering instead of GPU rendering" in Internet Explorer (computer restart is required) and disabling "Enable hardware acceleration" in Flash settings.

    Could this problem be caused by the latest Flash update? I have Flash 11.3.370.178

    Wednesday, August 01, 2012 3:33 AM

  • I recently... enabled Hyper-V.

    this is the cause. If you need hyper-V use your workaround (software rendering), otherwise remove Hyper-V and use other tools like VMWare or VirtualBox

    "A programmer is just a tool which converts caffeine into code"

    Wednesday, August 01, 2012 1:10 PM
  • Hi,

    yes, I enabled Hyper-V. I will follow your suggestion.

    Thank you very much.

    Wednesday, August 01, 2012 3:34 PM
  • I had the same problem, I was only able to watch videos if I change to a low resolution. 

    In my case what solved was install the WebM plugin from google...

    You can download it here: https://tools.google.com/dlpage/webmmf

    Hope it helps

    Sunday, August 12, 2012 11:26 PM