locked
Pictures messing with Aero? RRS feed

  • Question

  • Today I noticed that after opening a bitmap picture(screen snapshots) the screen would flicker and the taskbar would become a brighter color(it's supposed to be dark blue, but becomes more grayish). It also seems to mess with windows when they are being dragged. To fix this I had to go into personalize from the desktop and run the troubleshoot for Aero. This will change the screen back to normal  and the error it tells me is that Desktop Windows Manager is disabled. I can see in the task manager that DWM.exe is running now. I was wondering if anyone could tell me why this is happening. The screen does this anytime I open a bitmap picture.
    Saturday, January 30, 2010 7:06 PM

Answers

  • If the issue persists after updating the display card driver and BIOS to the latest one, please check if the Desktop Windows Manager Session Manager service is started properly. To do so, please refer to the steps below:

     

    1. Click on the Start Button, type "services.msc" (without quotation marks) in the Start Search box and press Enter.

    2. Double click the service "Desktop Windows Manager Session Manager".

    3. Click on the "General" tab; make sure the "Startup type" is "Automatic" and the "Service status" is "Started". If not, please select "Automatic" from the drop down menu and click the "Start" button to start the service.

    4. Click OK.

     

    If the issue persists, please Lower the Resolution and Refresh Rate:

     

    1. Right click on the Desktop and choose Screen Resolution

    2. Change it to a lower value

    3. Click Advanced settings.

    4. Click Monitor tab.

    5. Change the refresh rate to a lower value.

    6. Click OK.

     

    Also, you can access Clean Boot to check the issue. If the issue disappears in the Clean Boot environment, we continue to narrow down which entry is causing the issue.

     

    Regards,

    Linda

     

    • Marked as answer by Linda Yan Monday, February 8, 2010 2:42 AM
    Monday, February 1, 2010 7:01 AM
  • Honestly, it sounds as though your graphics adapter just isn't up to the task of putting all these images on screen.  Or maybe there's a bug in the current drivers.

    What video hardware does your laptop use and what model is the laptop?

    Have you tried running the Aero troubleshooter?  Click the Start orb and type Aero fix into the search box.

    -Noel
    • Marked as answer by Linda Yan Monday, February 8, 2010 2:42 AM
    Friday, February 5, 2010 1:12 PM

All replies

  • Sounds like your system is dropping out of Aero Glass when you are opening your image.  I'm betting the transparency goes away as well when it happens.

    Check to make sure you don't have a "mirror" driver installed in your Hardware Manager.

    A program can be set to disable Desktop Composition for compatibility purposes.  Check to make sure none that you are running have this compatibility mode set.

    Other than that and advising you to update your video drivers I can't offer any other solution.  If the problem persists with the latest download of video drivers, I suggest you contact your video card manufacturer and let them know this is happening.  They may fix the problem in a subsequent release.

    If it's a particularly old card (and "particularly old" means more than about 1.5 years old in video card land)  then you might want to consider updating to a modern video card.

    -Noel
    Sunday, January 31, 2010 9:46 PM
  • If the issue persists after updating the display card driver and BIOS to the latest one, please check if the Desktop Windows Manager Session Manager service is started properly. To do so, please refer to the steps below:

     

    1. Click on the Start Button, type "services.msc" (without quotation marks) in the Start Search box and press Enter.

    2. Double click the service "Desktop Windows Manager Session Manager".

    3. Click on the "General" tab; make sure the "Startup type" is "Automatic" and the "Service status" is "Started". If not, please select "Automatic" from the drop down menu and click the "Start" button to start the service.

    4. Click OK.

     

    If the issue persists, please Lower the Resolution and Refresh Rate:

     

    1. Right click on the Desktop and choose Screen Resolution

    2. Change it to a lower value

    3. Click Advanced settings.

    4. Click Monitor tab.

    5. Change the refresh rate to a lower value.

    6. Click OK.

     

    Also, you can access Clean Boot to check the issue. If the issue disappears in the Clean Boot environment, we continue to narrow down which entry is causing the issue.

     

    Regards,

    Linda

     

    • Marked as answer by Linda Yan Monday, February 8, 2010 2:42 AM
    Monday, February 1, 2010 7:01 AM
  • Thanks for the responses. I wasn't able to get to my laptop yesterday, so I couldn't test the problem. 

    My laptop is only three months old and I updated the drivers a few weeks ago. I just checked the video card driver and it is up to date. I can find no mirror driver in the device manager. 

    I did realize that I had the Zune software running at the time that I had trouble with Aero. After being unable to duplicate the problem by just opening a bitmap picture (very frustrating as it was the only time I actually wanted my problem to happen) I tried opening the Zune software. When opening the Zune software my laptop seemed to slow down some, then the taskbar color changed again. This also happened the second time I tried it. After being able to duplicate the problem I found that DWM.exe was no longer a process when the problem happened.

    This still only happens if I have both the Zune software and a bitmap image open at the same time. It doesn't seem to do it with any other types of pictures. 

    Noel, regarding your post about how a program can be set to disable desktop composition. How can I check to see if the Zune software has this setting? 
    Wednesday, February 3, 2010 12:28 AM
  • Right-click the program shortcut (and possibly executable), choose Properties, and click the Compatibility tab.  Check to see if [ ] Disable desktop composition is set.

    -Noel
    Wednesday, February 3, 2010 2:49 AM
  • Well the Disable desktop composition isn't checked. I guess I'll just have to remember not to open those pics when I'm using the Zune Software.
    Wednesday, February 3, 2010 7:52 PM
  • ...or use another program as your picture viewer.   I recommend the free and excellent "Windows Live Photo Gallery", which despite the name, does not require Windows Live services.  It's free and downloadable from Microsoft's website at http://get.live.com, and the only reason it's not built-in to Windows is because of European legal issues.





    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Thursday, February 4, 2010 7:25 AM
  • I'm already using windows live photo gallery to view these pictures. I just had the Zune software running, I wasn't using it to view these pictures.
    Thursday, February 4, 2010 9:55 PM
  • Honestly, it sounds as though your graphics adapter just isn't up to the task of putting all these images on screen.  Or maybe there's a bug in the current drivers.

    What video hardware does your laptop use and what model is the laptop?

    Have you tried running the Aero troubleshooter?  Click the Start orb and type Aero fix into the search box.

    -Noel
    • Marked as answer by Linda Yan Monday, February 8, 2010 2:42 AM
    Friday, February 5, 2010 1:12 PM
  • My laptop is a sony vaio VPCCW17FX

    My video card is NVIDIA Geforce G210M with 256MB dedicated Ram

    If I run the Aero troubleshooter after the problem occurs it fixes it, but the problem will happen again if I open a bitmap picture while the zune software is running.
    Friday, February 5, 2010 10:19 PM
  • I use the same software (Zune and Windows Live Photo) and I can't seem to get this to happen to me.  I'm using an nVidia GeForce Go 7700 on this laptop, which has more video memory, but that really shouldn't happen.  I'm at a loss to even think of an idea of why it could happen.



    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Friday, February 5, 2010 10:53 PM
  • Certainly a machine that new should be able to run Aero under all conditions.

    I have heard of many, many problems with nVidia drivers.  I'm not saying that's what's going on here, but it might be an avenue to check with your online searches.

    -Noel
    Saturday, February 6, 2010 12:47 AM