locked
Icon - Windows 7 RRS feed

  • Question

  • I have WIN7 Ultimate Edition and I have many icon shortcuts on desktop.

    My problem is that, when I use some shortcuts (Excel file), after close the file, the shortcut changes its place on the screen . 

    How can I block icons position?

    Note This problem occurs only in Excel file icons

    Thanks

    Monday, January 30, 2012 7:51 AM

Answers

  • Run registry editor
    Run | Regedit | Enter

    Quote

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    HKEY_USERS\.Default\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    HKEY_USERS\.Default\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

    In the right pane find a DWORD value "NoSaveSettings"
    The DWORD should be located in any of above mentioned locations, but possibly in the last one.
    Once you find the DWORD value, delete it and restart your system. This should solve your issue and windows should remember your desktop settings from now on.

    • Proposed as answer by zhen tan Wednesday, February 1, 2012 9:26 AM
    • Marked as answer by Arthur Xie Tuesday, February 21, 2012 5:31 AM
    Monday, January 30, 2012 3:39 PM

All replies

  • when you right click on desktop and go to view....is auto arrange icons on?

     

    If not how comfortable are you looking in the registry?

    Monday, January 30, 2012 12:48 PM
  • No, isn't auto arrange on

    I could work in registry

    Monday, January 30, 2012 3:12 PM
  • Run registry editor
    Run | Regedit | Enter

    Quote

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    HKEY_USERS\.Default\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    HKEY_USERS\.Default\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

    In the right pane find a DWORD value "NoSaveSettings"
    The DWORD should be located in any of above mentioned locations, but possibly in the last one.
    Once you find the DWORD value, delete it and restart your system. This should solve your issue and windows should remember your desktop settings from now on.

    • Proposed as answer by zhen tan Wednesday, February 1, 2012 9:26 AM
    • Marked as answer by Arthur Xie Tuesday, February 21, 2012 5:31 AM
    Monday, January 30, 2012 3:39 PM