locked
Problem with renamed user. RRS feed

  • Question

  • Hi folks,

    I've got a problem with a user on our Sharepoint Portal 2007 installation.  I renamed the user account in AD recently, which seemed to cause a problem where I could no longer add the user to groups in Sharepoint.  I noticed the user information hadn't updated correctly in "People and Groups" on our main Sharepoint site, so I figured if I deleted the user from here, and deleted their profile it would simply re-import the correct user profile and repopulate People and Groups (the user had no content in Sharepoint yet, so that seemed safe).  It didn't work, and now I realise that maybe this was the wrong thing to do.  I probably should've use stsadm to migrate the user.

    Now I'm left with a situation where the recently renamed user appears in the list of profiles and audiences in Sharepoint Central Administration, but not in "People and Groups" on the sharepoint site itself.  I can't see any errors in the profile import logs, and I'm not sure how People and Groups is populated, but after several re-imports and waiting patiently, this user just doesn't appear in the list, and if I try to add them to a group, or give them permission on a resource on the sharepoint site, it produces an error stating that the user can't be found.

    I readily admit that I may have caused this problem myself, but would someone be able to suggest how I might fix it?

    We're running MOSS 2007 v12.0.6425.1000 and WSS 11.0.8173.0  on Win2k3 and SQL 2005 if that helps.

    Thanks.

    • Edited by Mike Walsh FIN Thursday, March 3, 2011 8:21 AM Sharepoint 2007 - default so not useful in title
    Wednesday, March 2, 2011 6:00 AM

Answers

  • We were finally able to resolve a similar issue.

    There is a great post on how to trouble shoot this issue: Troubleshooting User Profile Sync Issues in Office SharePoint Server 2007

    We were able to find the incorrect information in SQL in the alluserdata table in the content database and do an update. 

     

    update AllUserData set nvarchar1 = 'Right, Name' where nvarchar1 = 'Wrong, Name' and nvarchar3 = 'Domain\User'

    So at least there is a way to fix it.

    • Marked as answer by Peng Lei Monday, March 21, 2011 3:21 AM
    Wednesday, March 16, 2011 6:37 PM

All replies

  • Hi folks,

    I've got a problem with a user on our Sharepoint Portal 2007 installation.  I renamed the user account in AD recently, which seemed to cause a problem where I could no longer add the user to groups in Sharepoint.  I noticed the user information hadn't updated correctly in "People and Groups" on our main Sharepoint site, so I figured if I deleted the user from here, and deleted their profile it would simply re-import the correct user profile and repopulate People and Groups (the user had no content in Sharepoint yet, so that seemed safe).  It didn't work, and now I realise that maybe this was the wrong thing to do.  I probably should've use stsadm to migrate the user.

    Now I'm left with a situation where the recently renamed user appears in the list of profiles and audiences in Sharepoint Central Administration, but not in "People and Groups" on the sharepoint site itself.  I can't see any errors in the profile import logs, and I'm not sure how People and Groups is populated, but after several re-imports and waiting patiently, this user just doesn't appear in the list, and if I try to add them to a group, or give them permission on a resource on the sharepoint site, it produces an error stating that the user can't be found.

    I readily admit that I may have caused this problem myself, but would someone be able to suggest how I might fix it?

    We're running MOSS 2007 v12.0.6425.1000 and WSS 11.0.8173.0  on Win2k3 and SQL 2005 if that helps.

    Thanks.

    Wednesday, March 2, 2011 5:42 AM
  • you need to repost this on the SharePoint 2007 Forum.
    Gary Newman MCSE, MCT, CCNA MCDBA, MCAD, MCSA MCTS SharePoint 2007 Dev & Admin MCPD SharePoint 2010 Development
    Wednesday, March 2, 2011 5:49 AM
  • Apologies, could someone please delete this question?  New thread started here .
    Wednesday, March 2, 2011 6:01 AM
  • Hi Speculator,

     

    Have you looked into this option:

    stsadm -o migrateuser

    http://technet.microsoft.com/en-us/library/cc262141(office.12).aspx

     


    Robi MCT Kompas Xnet d.o.o. Ljubljana, Slovenia
    Wednesday, March 2, 2011 10:02 AM
  • The profiles that appear in the "People and Groups" are WSS profiles. These profiles are updated from the SSP profiles through a timer job - Profile Synchronization, Quick Profile Synchronization.

    Verify that these jobs are not stuck and completing without any errors. If these jobs are running fine, you can use the following stsadm command to sync the user profiles.

    stsadm -o sync

    Ref: http://technet.microsoft.com/en-us/library/cc263196(office.12).aspx

    Thanks,
    Dip


    Dip
    http://dzeee.net/sharepoint
    Wednesday, March 2, 2011 2:56 PM
  • You might have to delete the user from the User Information List as well. I have seen this where a user gets deleted from the user profiles but still exists in the User Information List of the site collection. Can cause erractic behavior throughout the site collection.
    -SharePointNinja
    Wednesday, March 2, 2011 4:35 PM
  • Hi all,

    Thanks for all the suggestions, I've just worked through them all, sadly, with no luck.

    I have tried stsadm -o migrateuser, the command says it completed successfully, but the problem still persists.

    I looked at the two timer jobs Dip (thanks for pointing them out), they're both reporting that they've run today, and the status is "Succeeded".  So I ran stsadm -o sync, but although it completed successfully, the user still doesn't appear in "People and Groups".

    SharepointNinja - I had a look at the User Information List (I assume you mean the list at /_catalogs/users/simple.aspx), and the user isn't listed.

    So, any more suggestions would be welcome!

    Thanks.

     

    Thursday, March 3, 2011 1:22 AM
  • So, nobody has any other suggestions then?

    Do I have to go through the pain of deleting and re-creating the user in AD (surely not)?

    Thanks.

     

    Sunday, March 6, 2011 10:41 PM
  • Well, I find this a bit unfortunate.  I assume there is no fix for this.
    Tuesday, March 8, 2011 9:50 PM
  • We were finally able to resolve a similar issue.

    There is a great post on how to trouble shoot this issue: Troubleshooting User Profile Sync Issues in Office SharePoint Server 2007

    We were able to find the incorrect information in SQL in the alluserdata table in the content database and do an update. 

     

    update AllUserData set nvarchar1 = 'Right, Name' where nvarchar1 = 'Wrong, Name' and nvarchar3 = 'Domain\User'

    So at least there is a way to fix it.

    • Marked as answer by Peng Lei Monday, March 21, 2011 3:21 AM
    Wednesday, March 16, 2011 6:37 PM
  • Great solution... except for the fact that running SQL queries against your SharePoint farm puts it in an unsupported state.
    Wednesday, October 30, 2013 6:09 AM