locked
Automatic change in primary SMTP address on Exchange Svr Enterprise 2007/Exchange 2003 RRS feed

  • Question

  • Hi,

    I have Ex 07 and Ex 03 in coexistence environment.

    EAP is Deploy on Ex 07 for all users. I have multiple EAP for Multiple Email domain

    Last three for day one of my EAP misbehave and user primary email id will start changing automatically.

    Please help me to find out the issue.

    Work around i will change the User Email setting "Active Directory Users and Computers, right-click the recipient, and selectProperties. On the E-mail Addresses tab, clear the Automatically update e-mail addresses based on e-mail address policy check box" and change the primary SMTP which required.

    Once i will Update the EAP manual is working fine now. Any one can help me to find out the Issue why its happen.

    Thanks

    Saurabh

    Friday, August 3, 2012 1:01 PM

All replies

  • Hmm if you create a new user is it getting the correct primary smtp address from the EAP policy?

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, August 3, 2012 3:41 PM
  • On Fri, 3 Aug 2012 13:01:09 +0000, nath saurabh wrote:
     
    >I have Ex 07 and Ex 03 in coexistence environment.
    >
    >EAP is Deploy on Ex 07 for all users. I have multiple EAP for Multiple Email domain
    >
    >
    >
    >Last three for day one of my EAP misbehave and user primary email id will start changing automatically.
     
    Are you sure it's the EAP and not the E2K3 RUS?
     
    >Please help me to find out the issue.
     
    Try setting the domain RUS schedule to "never run".
     
    EAP shouldn't be doing anything unless the policy is being manually
    reapplied or there are cmdlets being run that modify some aspect of
    the user. But it the EAP is being run the results should be consistent
    with the policy which means there should be any "surprise" changes to
    e-mail addresses.
     
    >Work around i will change the User Email setting "Active Directory Users and Computers, right-click the recipient, and selectProperties. On the E-mail Addresses tab, clear the Automatically update e-mail addresses based on e-mail address policy check box" and change the primary SMTP which required.
     
    You shouldn't be using the ADUC at all to mange mail-enabled objects.
    Use the EMC instead.
     
    >Once i will Update the EAP manual is working fine now. Any one can help me to find out the Issue why its happen.
     
    Stop using ADUC.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Friday, August 3, 2012 10:04 PM
  • I am using EMC only. to make change in Email address. Sorry to say ADUC.


    Saturday, August 4, 2012 12:08 PM
  • Hi Jam,

    Yes its getting currect Email ID but afer some time its also changes.

    Regard

    Saturday, August 4, 2012 12:09 PM
  • Are you sure you don't have any other process, powershell scripts, (check scheduled tasks) that you can think of that may be running thats changing it?

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Saturday, August 4, 2012 1:40 PM
  • On Sat, 4 Aug 2012 12:08:21 +0000, nath saurabh wrote:
     
    >I am using EMC only. to make change in Email address. Sorry to say ADUC.
     
    Check to see if you have something "stuck" in the E2K3 gatewayProxy
    arrtibute on the domain RUS.
     
    http://support.microsoft.com/kb/821743
     
    The addresses shouldn't be modified unless there's something being
    changed (e.g. a script that uses set-mailbox) or there's something
    going on with the old RUS.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Saturday, August 4, 2012 5:34 PM
  • Hi Rich,

    I checked the RUS on Ex2003 and Found Some of Enterprise Level RUS is set up Never Run, But Other three are configure with Always run..

    But now there is no issue of SMTP change.

    I just Reapplied the EAP which create for the Primary SMTP..

    Please suggest can set RUS to Never Run.. Thanks For your Suggestion.

    Regards

    Saurabh 

    Thursday, August 9, 2012 9:55 AM
  • On Thu, 9 Aug 2012 09:55:30 +0000, nath saurabh wrote:
     
    >I checked the RUS on Ex2003 and Found Some of Enterprise Level RUS is set up Never Run, But Other three are configure with Always run..
    >
    >But now there is no issue of SMTP change.
    >
    >I just Reapplied the EAP which create for the Primary SMTP..
    >
    >Please suggest can set RUS to Never Run.. Thanks For your Suggestion.
     
    If you're no longer using ADUC to manage mail-enabled objects still in
    Exchange 2003 you can.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Thursday, August 9, 2012 3:13 PM