locked
Outlook shared mailbox not showing all mails RRS feed

  • Question

  • Hi,

    I use Outlook 2016 ProPlus version of O365. I came across a very interesting problem:

    - I set up a shared mailbox on O365 (hybrid environment)

    - I added full permissions to my account via ecp of O365

    - I get the mailbox added to my Outlook automatically (auto-mapping)

    - I send a test mail from my mailbox mame@mydomain.com to sharedmailbox@mydomain.com -> Outlook doesn't show mail, BUT I see it when opening the mailbox with my account in webmail

    - I send a test mail from gmail to sharedmailbox@mydomain.com -> Outlook shows the mail, also webmail

    - I send copy a mail from my inbox to sharedmailbox@mydomain.com within Outlook -> Outlook shows the mail, also webmail

    - I send a mail from my mailbox mame@mydomain.com to sharedmailbox@mydomain.com -> again Outlook does not show it, and webmail shows it

    Can someone tell me what is going on there?

    Best

    Martin

    Thursday, January 4, 2018 9:51 AM

Answers

  • I think I got the answer, my mailbox is sending messages with flag private.

    So I invested some time to find out it is a huge mess in my opinion.

    Bottom line: Never add mailboxes to the account in the profile in Outlook, but rather add another account to the profile. 

    If you do that, you basically use the email address of the shared mailbox, but authenticate with your user at account setup. It will show all messages.

    If you just add the mailbox to the account in the profile (in the advanced settings of the account), then private messages are hidden.

    Also, never hide the shared mailbox from address book, if you run hybrid (at least not until everyone has it up and running in their Outlook).

    Thanks for your response anyways Perry.

    • Marked as answer by Martin DCA Monday, January 8, 2018 8:50 AM
    Monday, January 8, 2018 8:50 AM

All replies

  • Hi Martin,

    Does this issue happen if messages are sent from other users’ mailboxes?

    Is your Gmail account also added to your Outlook client?

    >> I send copy a mail from my inbox to sharedmailbox@mydomain.com within Outlook -> Outlook shows the mail, also webmail

    Could we know how do you send the copy to the shared mailbox?

    Besides, if you search this message, will it be showed in the shared mailbox?

    >> I get the mailbox added to my Outlook automatically (auto-mapping)

    We can try re-adding the shared mailbox to Outlook manually to see if there are any improvements. To do this, please go to File > Account Settings > Account Settings. Double click your account and then choose more settings.

    Tick Add to add your shared mailbox under Advanced tab.

    Any updates, please feel free to post back for further assistance.


    Regards,

    Perry Pan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.



    • Edited by Perry-Pan Friday, January 5, 2018 6:45 AM
    Friday, January 5, 2018 6:42 AM
  • I think I got the answer, my mailbox is sending messages with flag private.

    So I invested some time to find out it is a huge mess in my opinion.

    Bottom line: Never add mailboxes to the account in the profile in Outlook, but rather add another account to the profile. 

    If you do that, you basically use the email address of the shared mailbox, but authenticate with your user at account setup. It will show all messages.

    If you just add the mailbox to the account in the profile (in the advanced settings of the account), then private messages are hidden.

    Also, never hide the shared mailbox from address book, if you run hybrid (at least not until everyone has it up and running in their Outlook).

    Thanks for your response anyways Perry.

    • Marked as answer by Martin DCA Monday, January 8, 2018 8:50 AM
    Monday, January 8, 2018 8:50 AM
  • Hi,

    So glad that your issue has been solved and thank you for sharing here~

    Regards,

    Perry Pan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.



    • Edited by Perry-Pan Monday, January 8, 2018 9:47 AM
    Monday, January 8, 2018 9:47 AM