none
Setting IE search providers via GP RRS feed

  • Question

  • Good Afternoon,

    All my users are on a Win7x64 platform with a Win 2008 R2 STD domain controller. I am trying to set google as the default search provider for all our users via group policy.

    I have followed the steps in the following article -

    http://blogofanitadmin.blogspot.de/2011/05/group-policy-changing-default-search.html

    I have gone through the whole article and have also adhered to the comments/feedback at the bottom of the blog. Despite this, after doing a gpupdate /force on my test machine and restarting it the default search provider is still Bing. I really dont want to have to go around to each machine manually and set google as the default search provider.

    Just a little further information - the policy is setup with following settings -

    User Configuration > Policies > Administrative Templates > Windows Components > Internet Explorer

    • Add a specific list of search providers to the users search provider list (ENABLED)
    • Turn off the Security Settings Check feature (ENABLED)

    and

    User Configuration > Policies > Administrative Templates > Classic Administrative Templates (ADM) > Windows Components > Internet Explorer

    • Select search providers to be included in policy based search list (ENABLED)

    After applying the policy I run gpupdate /force on the test machine and restart it. I then run RSOP on the test machine and then drill down as follows -

    User Configuration > Administrative Templates > Windows Components > Internet Explorer

    Neither of the settings that I have enabled above are present.

    Can anyone tell me where I might be going wrong.


    Jeet S




    • Edited by CLAWWS MCTS Wednesday, September 3, 2014 1:51 PM Additional information added
    Wednesday, September 3, 2014 1:46 PM

Answers

All replies

  • Hi,

    Have you tried to run RSOP in client PC? would the changing occures after Group Policy update?

    In addition, pleae also run gpresult to check if this policy enabled.


    Roger Lu
    TechNet Community Support

    Thursday, September 4, 2014 9:32 AM
    Moderator
  • Hi,

    As detailed in my initial post, I have run a gpupdate /force on the client/test machine and then restarted and logged into it and run RSOP.

    The RSOP results indicate that the policy is not applied.

    Also runnins gpresult indicates that the policy is not applied.


    Jeet S


    • Edited by CLAWWS MCTS Thursday, September 4, 2014 12:23 PM
    Thursday, September 4, 2014 9:39 AM
  • Hi,

    Based on my research, here is a workaround method you can use temporarilly for test.

    Customize default search provider by modifing Registry, you can refer to the link below for more details:

    http://technet.microsoft.com/en-us/magazine/ee872419.aspx

    For your current problem with Group Policy push failed problem, you can refer to the link below for further troubleshooting method:

    Top 10 Reasons Why Group Policy Fails to Apply:

    http://www.windowsnetworking.com/articles-tutorials/windows-server-2008/Top-10-Reasons-Why-Group-Policy-Fails-to-Apply-Part1.html

    Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    Roger Lu
    TechNet Community Support


    Friday, September 5, 2014 10:52 AM
    Moderator
  • Hi Roger,

    Many thanks for this. I will give it a try.


    Jeet S

    Thursday, September 11, 2014 10:04 AM
  • Based on the https://social.technet.microsoft.com/Forums/windowsserver/en-US/a50e93ec-0d63-4ed0-865e-79b62605ff46/kb2988414-and-default-search-provider-via-installins?forum=ieitprocurrentver update issue will GP actually manage this from either a server or from a local GP on WIN7x64 ENT?
    Saturday, January 10, 2015 1:12 PM
  • Based on the https://social.technet.microsoft.com/Forums/windowsserver/en-US/a50e93ec-0d63-4ed0-865e-79b62605ff46/kb2988414-and-default-search-provider-via-installins?forum=ieitprocurrentver update issue will GP actually manage this from either a server or from a local GP on WIN7x64 ENT?
    Saturday, January 10, 2015 1:12 PM
  • Does anyone from MS have an answer on this? Should I be creating a new post?
    Monday, January 12, 2015 2:27 PM
  • No response so created a new post:

    https://social.technet.microsoft.com/Forums/ie/en-US/23a169f9-9b7f-4b55-80b5-b3e09c50f196/lost-default-search-engine-control-due-to-kb2988414?forum=ieitprocurrentver

    Tuesday, January 13, 2015 2:31 PM