Errors with CustomUpdate files and HTTP 500 errors RRS feed

  • Question

  • Hi, I am raising this as a bug with our TAM having done testing with Ivan in MS' UK UAG pre-sales, but I thought I'd ask the forum as well.  I have two strange issues with CustomUpdates...

    1) A client browser loads and accesses the site published in UAG using its normal address (thus accessing login.asp), it redirects as usual to the same address with /?uniquesig followed by the UAG’s signature and the other normal parameters.  Normally this is fine and the login box shows, but our situation the UAG error page comes up with an “You have attempted to access a restricted URL. The URL contains and invalid path”.  If you access the address of the site again (deleting the uniquesig onwards, so it is just the site address) it then shows the login box.  This is totally repeatable, and does not go away with an activation or an IIS reset
    We did some testing and figured out it only does this when we replaced the login.asp with one in CustomUpdate.  Logic would dictate that it is something that I did in the login.asp file, but take a fresh copy from samples and place it in the CustomUpdate and it also does this.  Ivan and I looked at it for over an hour but got nowhere.  Logo.inc doesn’t trigger the problem, neither does a custom CSS.

    2) My second strange issue is slightly related.  Firstly, if you place InternalError.asp (any version of) in the CustomUpdate it seems to stop InternalError being shown at all, it just ends in a 500.  I realise (now) that you should change the path of InternalError in the console, but it seems strange that it does this.  When renamed to something other than InternalError.asp and referenced in the console it now only sometimes brings up a 500 error-and I have no idea why!

    In case it helps at all, I have a third issue that I am raising as a call, that I am not particularly looking for comments on here but I have pasted what i have sent to support under my sig in case it helps, as it also referneces wierd 500 errors

    Thanks,  --Chris



    Accessing from “the Internet” (in quotes because, technically, its not the Internet but its close enough).  SSO configured to back end using form based login.

    When we login in with valid credentials, it all works fine, you get to the site behind the UAG and it logs in with SSO fine.  Log into the UAG with valid credentials to the domain but not acceptable to the site behind and you get the correct error page from the site behind. However logins with invalid credentials to the domain result in a 500 error page not the InternalError page I would expect to receive saying “Authentication failed” or similar.  I have worked my way through from the most obvious, to a full trace at ‘Noise’ level and I cannot work out why it is happening.  I see in the trace that the credentials do not authenticate then I see the 500 page being created.  I am expecting that Validate.asp should be triggering an InternalError following the credentials fail, and I see the line:

    <trimmed time, cpus etc> [whlcomtrace Validate.asp@0] ERROR:[207] @ [0] @ [1] @ [Validate.asp] @ [0] @ [ERROR: Failed to authenticate the credentials of [GamesAD]]

    Then lots of function in/outs etc then the 500 page being issued.  No exceptions or anything that would indicate a problem
    I have attached the logs in the zip file – trace file (in txt ) and IIS log files 1 & 3 (2 had nothing)

    Incidently, the 500 error page doesn’t seem to be the one that exists in the UAG von folders, unless IE is showing me a nicer version.  The URL in IE when the 500 page is showing is (domain replaced by me):


    so I think its Validate.asp that is casing the failure.


    Thursday, July 15, 2010 2:54 PM


  • NB now reproduced by UK MS Support, will update when solved
    • Marked as answer by Erez Benari Friday, July 30, 2010 6:20 PM
    Wednesday, July 28, 2010 11:03 AM

All replies

  • I think I have a result on this, I had renamed my InternalError page but not allowed it in the URL rules, so it failed displaying a failure page!
    Friday, July 16, 2010 3:35 PM
  • Nope, that didn't fix it....still happening, it goes away for a bit then comes back
    Tuesday, July 20, 2010 9:06 AM
  • NB now reproduced by UK MS Support, will update when solved
    • Marked as answer by Erez Benari Friday, July 30, 2010 6:20 PM
    Wednesday, July 28, 2010 11:03 AM
  • Although marked answered, I'll post the answer when I actually have it
    Friday, July 30, 2010 10:07 PM
  • Actually I got this working. You have to do the following:

    1) Copy InternalSite/InternalError.asp to InternalSite/CustomUpdate/InternalError.asp

    2) Change all #include references from inc/filename.inc to ../inc/filename.inc

    3) Create a new custom rule for InternalSite in the URL Set (copy the existing one for InternalSite/InternalError.asp) and activate UAG config

    4) Enable Parent Paths in IIS: %windir%\system32\inetsrv\appcmd set config -section:asp -enableParentPaths:true

    Best regards


    Tuesday, January 11, 2011 9:21 PM