locked
Exchange 2013 to 2016 Migration ISSUE Database is mandatory on UserMailbox RRS feed

  • Question

  • HI,

    I have Migrated from Exchange 2013 to 2016.... I had shutdown EX2013 for 1 Month, everything worked perfectly fine and no issues were reported by any User.

    I uninstalled EX2013 which went smooth.. no issues there too, I just did one thing... Took backup of Public folders in PST and removed the Publicfolders too along with EX2013. which no one was using and we took a decision of not to migrated them to EX2016.

    Now since removal of EX2013 & Public folders We are facing 2 Issues.

    1) Outlook users are still being asked for password for PF_Mailbox... which was a Publicfolder mailbox. Clicking cancel takes them back to Outlook but it popups 3 to 4 times in 1 min. restarted Outlook many times.

    2) The ECP when a user is selected displays error "Database is mandatory on UserMailbox."

    Mails are working fine... No Issues with mail flow.

    Following is what all I have done to try to FIX it...

    1) Tried to use ADSI to remove Public Folders traits ... But there wasn't any.

    2) Recreated all Exchange System Folders, Federation, Arbitration, Monitoring, Migration, Health etc.

    3) Dismounted the databases and remounted them

    4) Restarted Both the server.

    Please advise if any one can as these issues are causing lot of annoyance to users and admins too.

    Thanks


    bikram

    Monday, July 10, 2017 1:36 PM

Answers

  • hi,

    Finally got it all sorted... The PF_Mailbox named disabled user was there on which  prevent from deletion flag was set and uninstalling Exchange2013 couldn't remove it.  I had to Uncheck it and delete the user.. After that I restarted the information Store service and now everything is working perfectly fine.

    Thanks for your help.

    Thanks


    bikram

    • Proposed as answer by Lynn-Li Thursday, July 13, 2017 9:04 AM
    • Marked as answer by bikram_singh Wednesday, July 25, 2018 7:21 AM
    Thursday, July 13, 2017 8:50 AM

All replies

  • Any One??? has any pointer???

    cant create new users...

    Thanks..


    bikram

    Monday, July 10, 2017 7:51 PM
  • Hi,

    You mean outlook asked for password for PF_Mailbox? Old PF mailbox in Exchange 2013 or new PF mailbox on Exchange 2016? Generally, if outlook asks for password for other Mailbox, it means this user has permission on this mailbox. Would you mind to post the screenshot for the window of password prompted?

    I would make sure outlook is trying to connect Public Folder when password prompted. Hold Ctrl and right-click on outlook icon in taskbar and choose connection status... Then check the following sections:

    Meanwhile, check if public folder database is configured on Exchange 2016 Mailbox Database:

    Get-MailboxDatabase | Fl *publicfolder*


    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 11, 2017 2:39 AM
  • HI,

    Thanks for replying....

    Get-MailboxDatabase | Fl *publicfolder*  returns nothing...as we have removed PFolders and EX2016 dosent have any.

    on my old EX2013 there were PublicFolders and it was having mailbox by the name PF_Mailbox. After migrating to EX2016 we didnt migrate PFolders. took backup and removed them. 

    Now biggest issue is "Database is mandatory on UserMailbox." I suspect its related to this missing PFolders link somewhere. cant create new users or alter current users....

    The PF_Mailbox issue is faced by few users only not everyone and that too randomly to those users only. 

    Thanks again for your time and comment.


    bikram

    Tuesday, July 11, 2017 3:42 AM
  • HI,

    I deleted all objects which were of TYPE "Public folder" In Active directory Users & Computers >> Microsoft Exchange System Objects>>

    The issue of PF_Mailbox is now resolved... I hope so... still its under monitoring...

    But "Database is mandatory on UserMailbox." is still persistent  and causing big annoyance.. any command run against any mailbox throws this error  "Database is mandatory on UserMailbox." and practically only mails are working and cand do any admin tasks on it.

    Thanks,


    bikram

    Tuesday, July 11, 2017 7:00 AM
  • HI,

    I deleted all objects which were of TYPE "Public folder" In Active directory Users & Computers >> Microsoft Exchange System Objects>>

    The issue of PF_Mailbox is now resolved... I hope so... still its under monitoring...

    But "Database is mandatory on UserMailbox." is still persistent  and causing big annoyance.. any command run against any mailbox throws this error  "Database is mandatory on UserMailbox." and practically only mails are working and cand do any admin tasks on it.

    Thanks,


    bikram

    For the error message "Database is mandatory on UserMailbox", system mailbox may not be attached to mailbox database. Run this command to check:

    Get-Mailbox -Arbitration

    See if all system mailboxes are configured mailbox database. If no, run the following command to re-home it.

    Set-Mailbox "SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c}" -Arbitration -Database "DBName"

    More information, refer to this blog:

    https://social.technet.microsoft.com/wiki/contents/articles/25342.exchange-2013-setup-error-database-is-mandatory-on-usermailbox.aspx


    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 11, 2017 7:22 AM
  • hi...

    Already tried that command

    [PS] C:\>get-mailbox -arbitration
    Database is mandatory on UserMailbox.
        + CategoryInfo          : NotSpecified: (:) [Get-Mailbox], DataValidationException
        + FullyQualifiedErrorId : [Server=EX01,RequestId=cadac8c1-bcac-4cb8-b1b5-f5f9b03b4ed4,TimeStamp=7/11/2017 8:48:37 AM] [FailureCategory
       =Cmdlet-DataValidationException] 5030BECB,Microsoft.Exchange.Management.RecipientTasks.GetMailbox
        + PSComputerName        : ex01.local.comapnay.com

    Thanks,


    bikram

    Tuesday, July 11, 2017 8:49 AM
  • hi...

    Already tried that command

    [PS] C:\>get-mailbox -arbitration
    Database is mandatory on UserMailbox.
        + CategoryInfo          : NotSpecified: (:) [Get-Mailbox], DataValidationException
        + FullyQualifiedErrorId : [Server=EX01,RequestId=cadac8c1-bcac-4cb8-b1b5-f5f9b03b4ed4,TimeStamp=7/11/2017 8:48:37 AM] [FailureCategory
       =Cmdlet-DataValidationException] 5030BECB,Microsoft.Exchange.Management.RecipientTasks.GetMailbox
        + PSComputerName        : ex01.local.comapnay.com

    Thanks,


    bikram

    One additional question, did you migrate the arbitrition mailbox from Exchange 2013 to Exchange 2016?

    Try to find them in ADUC, and recreate them

    https://social.technet.microsoft.com/wiki/contents/articles/6874.how-to-recreate-system-mailbox-federatedemail-discoverysearchmailbox-in-exchange-2010.aspx


    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 11, 2017 10:55 AM
  • Hi, bikram_singh

    Any updates?


    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 13, 2017 1:42 AM
  • hi,

    Finally got it all sorted... The PF_Mailbox named disabled user was there on which  prevent from deletion flag was set and uninstalling Exchange2013 couldn't remove it.  I had to Uncheck it and delete the user.. After that I restarted the information Store service and now everything is working perfectly fine.

    Thanks for your help.

    Thanks


    bikram

    • Proposed as answer by Lynn-Li Thursday, July 13, 2017 9:04 AM
    • Marked as answer by bikram_singh Wednesday, July 25, 2018 7:21 AM
    Thursday, July 13, 2017 8:50 AM
  • Great! Glad to hear that issue has been solved. 

    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 13, 2017 9:06 AM