locked
WMI information RRS feed

  • Question

  • Hi all

    I ran into a problem with my WMI. When I first discovered this, I noticed that the WEBM repository was empty, the default namespace read unknown, and I was getting Failed to initialized all required WMI classes. I tried repairing it with Windiag 2.2 with not much luck, or so I think. What I have now in the WBEM Repository is Mapping 1, Mapping 2, Mapping 3 and object data. The default namespace still reads unknown and I still have some programs acting up.

    This computer was once connected to my domain, which it too, went down from the same problem. is there a way to get it back to its original state? No, unfortunately the backup that I had I erased along with my other computers backup. That was intentional in fear that the virus or bad script would migrate to my other computers when I got the domain back up.


    • Edited by Simpleoldman Friday, September 18, 2015 3:48 PM Gramical
    Friday, September 18, 2015 3:44 PM

Answers

  • Hi,

    Have you tried this to repair your issue?

    Use PowerShell to Troubleshoot and Repair WMI Errors
    http://blogs.technet.com/b/heyscriptingguy/archive/2012/03/29/use-powershell-to-troubleshoot-and-repair-wmi-errors.aspx

    We can also try these commands to repair WMI to check your issue:

    net stop winmgmt
    c:
    cd %windir%\system32\wbem
    rd /S /Q repository
    regsvr32 /s %systemroot%\system32\scecli.dll
    regsvr32 /s %systemroot%\system32\userenv.dll
    mofcomp cimwin32.mof
    mofcomp cimwin32.mfl
    mofcomp rsop.mof
    mofcomp rsop.mfl
    for /f %%s in (’dir /b /s *.dll’) do regsvr32 /s %%s
    for /f %%s in (’dir /b *.mof’) do mofcomp %%s
    for /f %%s in (’dir /b *.mfl’) do mofcomp %%s
    mofcomp -n:root\cimv2\applications\exchange wbemcons.mof
    mofcomp -n:root\cimv2\applications\exchange smtpcons.mof
    mofcomp exmgmt.mof
    mofcomp exwmi.mof
    net start winmgmt


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, October 1, 2015 1:55 AM