locked
Word 2007 Issue - Slow Opening Files RRS feed

  • Question

  • Hi,

    I'm hoping someone else here has had or recognizes the issue I'm having.

    When I open a file in Word 2007 whether its on the network or local, it takes an age to open.

    If I open up word first, its lightning quick.

    There are no add-ins (except smart tag), everything else is inactive.

    Anyone recognize this? or put me in the direction of further tests I need to do?

    Here is a process monitor capture here ive removed file locking, name collision and successful.

    Im now stuck...

    Thanks


    Phil


    • Edited by Pilly170 Monday, April 14, 2014 2:32 PM added capture link
    Monday, April 14, 2014 10:10 AM

Answers

  • This is fixed.

    This is what I did

    Word

    HKEY_CLASSES_ROOT\Word.Document.12\Shell\Open\Command                

    Rename Subkey “Command” to “Old_Command”                

    Rename Key “ddeexec” to “Old_ddeexec”

    Using FileType Manager change .xls from Word.Sheet.8 to Word.Sheet.12 In the Open Command appended “%1”  

    .docx In the Open Command appended “%1”  

     

    Excel

    HKEY_CLASSES_ROOT\Excel.Document.12\Shell\Open\Command                

    Rename Subkey “Command” to “Old_Command”                

    Rename Key “ddeexec” to “Old_ddeexec”

    Using FileType Manager change .xls from Excel.Sheet.8 to Excel.Sheet.12 In the Open Command appended “%1”  

    .xlsx In the Open Command appended “%1”   

    Now opens really fast


    Phil

    • Marked as answer by Steve Fan Wednesday, April 16, 2014 9:03 AM
    Wednesday, April 16, 2014 8:12 AM

All replies

  • Try This

    OPENING .xls & .doc SLOWLY

    1. If documents take a long time to open when double clicking the file in Explorer do the following:
      1. Open Explorer, select “Tools” then “Folder Options”.
      2. Select “File Types” tab then type in doc to locate the file extension.
      3. When “DOC    Microsoft Office Word 97 – 2003 Document” is highlighted click the “Advanced” button.  If there is no advanced button click the “Restore” button.  Now click “Advanced”.
      4. Under “Actions” highlight “Open” then click “Edit”.
      5. Click in the “Application used to perform action” window the press the “End” key to go to the end of the text.
      6. There should be a /n /dde  at the end of the line, press spacebar then enter “%1” (including quote marks).
      7. Un-check the “Use DDE” box.
      8. Click “OK”.
      9. Click “OK”.
      10. Click on DOC to highlight it then type in docx, repeat the above for docx files.
      11. Click on DOCX to highlight it then type in xls to locate the file extension.
      12. When “XLS    Microsoft Office Word 97 – 2003 Worksheet” is highlighted click the “Advanced” button.  If there is no advanced button click the “Restore” button.  Now click “Advanced”.
      13. Under “Actions” highlight “Open” then click “Edit”.
    Click in the “Application used to perform action” window the press the “End” key to go to the end of the text.
    Monday, April 14, 2014 3:00 PM
  • Stuck on #2

    Somewhere in my GPO must be an option to disable this tab.


    Phil

    Monday, April 14, 2014 3:14 PM
  • Word Fires up immediately. Document doesn't appear.


    Phil

    Monday, April 14, 2014 3:44 PM
  • Hello,

    If you installed any antivirus software on your computer, then try to temporarily disable it to check the result.

    Please also try to delete all the temporary files that Word created in your system which may slow Word down. More information about Word temporary files, please refer:

    http://support.microsoft.com/kb/211632/en-us

    In addition, we can also try to rename the Word template file Normal.dotm file to Normal.old and then restart Word to check the result.

    Also check if the KB article below applies:

    http://support.microsoft.com/kb/280821/en-us

    Best Regards,

    Steve Fan

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Tuesday, April 15, 2014 4:50 PM
  • This is fixed.

    This is what I did

    Word

    HKEY_CLASSES_ROOT\Word.Document.12\Shell\Open\Command                

    Rename Subkey “Command” to “Old_Command”                

    Rename Key “ddeexec” to “Old_ddeexec”

    Using FileType Manager change .xls from Word.Sheet.8 to Word.Sheet.12 In the Open Command appended “%1”  

    .docx In the Open Command appended “%1”  

     

    Excel

    HKEY_CLASSES_ROOT\Excel.Document.12\Shell\Open\Command                

    Rename Subkey “Command” to “Old_Command”                

    Rename Key “ddeexec” to “Old_ddeexec”

    Using FileType Manager change .xls from Excel.Sheet.8 to Excel.Sheet.12 In the Open Command appended “%1”  

    .xlsx In the Open Command appended “%1”   

    Now opens really fast


    Phil

    • Marked as answer by Steve Fan Wednesday, April 16, 2014 9:03 AM
    Wednesday, April 16, 2014 8:12 AM
  • Dear Phil,

    Glad to hear that you have found the solution. It's very nice of you to share your solution here, it will benefit other community members who have similar question.

    Cheers,

    Steve Fan

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Wednesday, April 16, 2014 9:02 AM