none
I am getting an assertion failure can any1 tell me how to fix it RRS feed

  • Question

  •  

    this is the ASSERTION FAILUE

    .\DX8Renderer.cpp(175): (ALL BUILDS)
    Expression was: (!FAILED( result))

    Failed to create Device

     

    if any1 can tell me how to fix it it would be really good to me

     

    contact me on snake01231@hotmail.com

    Thanks

    Saturday, November 17, 2007 3:48 AM

Answers

  • hi yeah umm i got the message because me graphics driver stuffed up but its all fixed now its just i didnt know why and like a day after posting the bulliten i fixed the problem thnks 4 post a reply

    jake dettmann

    Monday, November 19, 2007 9:57 AM

All replies

  • Hi Jake,

     

    Before we go further, I would appreciate your help in clarifying the following information:

     

    Where did you encounter this error message? Are you installing any hardware/software on Vista while the error appears?

     

    In order to narrow down the root cause, please let me know the answers of the above questions.

     

    Also, please send some screenshots to me when the error occurs again as well as the System Information file. Please send all of them to WCVDATA@microsoft.com.

     

    How to collect System Information

    ------------------

    1). Click the Start menu and choose Run.

    2). Enter msinfo32 in the open box and click OK.

    3). Click File>Save and then save the information file .nfo into a specified folder.

     

    Note: We will continue to discuss the issue here in the forum and will NOT reply via emails. Please include the following three lines in the email body:

     

    Also, please post a quick note in the current thread to inform me after sending the email.

     

    Post Title: I am getting an assertion failure can any1 tell me how to fix it

    http://forums.microsoft.com/TechNet/ShowPost.aspx?postid=2421818&siteid=17 

    Robbin Meng – MSFT

     

    Hope this helps.

     

     

    Sincerely,

    Robbin Meng

    Microsoft Online Community Support

    Monday, November 19, 2007 9:51 AM
  • hi yeah umm i got the message because me graphics driver stuffed up but its all fixed now its just i didnt know why and like a day after posting the bulliten i fixed the problem thnks 4 post a reply

    jake dettmann

    Monday, November 19, 2007 9:57 AM
  • Hi Jake,

     

    Thanks for your prompt reply and feedback. I am glad to know the problem is resolved now. Just feel free to post your issue here if you have in the future. J

     

    Sincerely,

    Robbin Meng

    Microsoft Online Community Support

     

    Monday, November 19, 2007 10:17 AM
  • hey there.

    I had received this error message after i installed a game and am trying to play it but its saying the following: Assertion Failed. ./DX8Renderer.cpp(175): (ALL BUILDS) Expression was: (!FAILED(result))

    Can anyone tell me how i can play this game?

    Lani
    Monday, November 26, 2007 1:01 AM
  • Hi  Lani,

     

    Based on the symptoms and Jake's feedback, this issue may be caused by improper video driver or the current driver is incompatible with that specific game.

     

    Therefore, please consider the following steps:

     

    1. Change the Hardware acceleration;
    2. Change the display settings to your preferred configuration(select a lower resolution and Screen refresh rate);
    3. Reinstall video driver with the latest version from video card manufacturer.

     

    Since this issue only occur after you have installed the new game, as the game may change the computer's display setting and driver files. In some cases, due to hardware modifications by different manufacturers, the game driver file may cause some conflicts. So, I believe contacting the game support group is necessary to resolve this issue in an efficient manner.

     

    Hope this helps.

     

    Sincerely,


    Robbin Meng
    Microsoft Online Community Support

    Monday, November 26, 2007 6:53 AM
  • Jake,

    I am getting this same message trying to download a game on Windows XP. Can you tell me how to fix it ?

    Bev

    Tuesday, December 18, 2007 3:06 AM
  • hi umm sorry i cant really help you cause i was getin it on windows vista u may have to see some1 that knows how to fix it in XP sorry couldnt help you just ive never had it on xp

    Tuesday, December 18, 2007 3:55 AM
  • Dear Robin,
      I've the same problem , I tried your suggestions but it is the same negative result, also I tried to discrease display resolutions , and update my card to latest version of software, but it is the same ..
    plesae I need help as soon as posible ..
    Note: I tried to play an game name Luxor 3 it not requierd a high qualify PC when my system informations is as following :
    Cpu: Core2Due 2.66 Ghz
    Ram : 4Gb
    vedio Card: nVidia GeForce 256 mb GT

    • Proposed as answer by enix-12 Thursday, June 18, 2009 1:54 PM
    Sunday, March 16, 2008 3:53 PM
  • Hi,
    I am having a problem I think may be related.  I installed a children's educational game for a client (running Vista) which will not start up.  Here is the error:

    Microsoft Visual C++ Debug Library

    Debug Assertion Failed!
     Program: ...Where in the world is Carmen Sandiego for schools\CSWorld.exe
    File:fprintf.c
    Line:56

    Expression:  str !=NULL

    I don't have Vista on my own PC so I can't fool around with it to figure it out.  The program was listed as Vista compatible, tested by a 3rd party but i'm wondering if that is untrue

    My client is not particularly tech savy, so while I could change settings, I cannot expect them to do it (i.e., everytime they run this game).  Also - can you direct me to to "how to" links for things like changing hardware acceleration?  It would be particularly helpful to me if there was a resource to "translate"  how to do troubleshooting, maintenance and settings from the XP versions to  Vista.  Thanks!

    <!--[if !vml]--><!--[endif]-->
    Monday, April 14, 2008 1:55 PM
  • I just bought the same version of Carmen Sandiego and am getting the same debug error. Please help!!

     

    Saturday, July 5, 2008 9:27 PM
  • I got rid of the debug error by running Carmen Sandiego as an Administrator (right click on the link and choose run as Administrator). But the program kept seizing up after the Chief's intro ... Auugh.

     

    I fixed THAT problem by running Carmen Sandiego in a simulated Windows 98 environment. To do this in Vista, go to the Start Menu and select "Control Panel".  Click on "Programs". Under Programs and Features, choose "Use an older program with this version of Windows" then select Windows 98. You will want to set Carmen Sandiego to run in 640x480 with 256 colors. Now, right click on the shortcut and select "Run as Administrator".

     

    I am posting this in the hope that other Vista users will be able to play Where in the World is Carmen Sandiego without hours of scouring the internet for help!!

     

     

    Sunday, July 6, 2008 8:41 PM