locked
SCOM2012 R2 - SQL Server 2012 Analysis Services Management Pack - Not working ? RRS feed

  • Question

  • Hi All,

    Yesterday I installed the new SQL Server 2012 Analysis Services Management Pack on SCOM 2012R2.

    For the two profiles, "Microsoft SQL Server 2012 Analysis Services Discovery Run As Profile" and "Microsoft SQL Server 2012 Analysis Services Monitoring Run As Profile", I created a Run As account and gives to this account administrator right on the SQL Analysis services servers and the Analysis Services instances.

    This Run As account has been distributed only to the servers that have Analysis Services installed.

    I wait several hours but nothing occurs, no alerts, no states, no performance ?

    It's seems no objects are being discovered ? On all my Analysis servers I have this error message:

    SSAS 2012 MP - Event ID 6200

    Module: Microsoft.SQLServer2012.AS.Module.Discovery.AnalysisServicesProperty
    Version: 1.0.5.0

    Input string was not in a correct format.
       at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
       at System.Number.ParseDouble(String value, NumberStyles options, NumberFormatInfo numfmt)
       at System.Double.Parse(String s, NumberStyles style, NumberFormatInfo info)
       at System.Convert.ToDouble(String value)
       at Microsoft.SQLServer2012.AS.Module.Discovery.AnalysisServicesProperty.GetModuleData(DataItemBase[] inputDataItems)
       at Microsoft.SQLServer.BI.Module.Helper.Base.ModuleBasePropertyHelper`1.GetOutputData(DataItemBase[] inputDataItems)
       at Microsoft.SQLServer.BI.Module.Helper.Base.ModuleBaseHelper`1.OnNewDataItems(DataItemBase[] dataItems, Boolean logicallyGrouped, DataItemAcknowledgementCallback acknowledgeCallback, Object acknowledgedState, DataItemProcessingCompleteCallback completionCallback, Object completionState)
    mscorlib

    All of my Analysis servers are running W2K8R2 SP1 + SQL2012SP1 (Standalone or cluster)

    Does anyone has an idea ? Any help would be appreciate.

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog

    Friday, February 7, 2014 10:39 AM

Answers

  • Finally We have found what is wrong.

    We needed to logon on the SSAS server with SCOM SSAS RunAsAccount and changed "regional setting" from "French" to "English".

    Now all of our SSAS instances are discovered.

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog


    Tuesday, February 18, 2014 3:30 PM

All replies

  • Hi,

    “Input string was not in a correct format”

    Please check if the Formats under Region Settings is English. If no, please change it.  


    Niki Han

    TechNet Community Support

    Monday, February 10, 2014 9:11 AM
  • Hi Niki,

    Thks for your answer,

    We are currently using "French" Region Settings.

    I think that it won't be possible to make this change on our environnement... Change Region settings to "English" might have impact on others applications that are running on my Analysis service servers.

    Do I have another solution ?

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog

    Monday, February 10, 2014 1:54 PM
  • Hi,

    Today, for testing purpose we have deployed a new W2K8R2 SP1 servers with regional setting in "English" then I have installed two new SQL2012 SP1 Us Analysis Services instances (Multidim & Tabular).

    I have the same result...

    => SSAS 2012 MP - Event ID 6200 ???

    Another information, in my environnment SQL MP 6.4.1.0 is also deployed and my SSAS server are properly discovered in view "Microsoft SQL Server\Server Roles \Analysis Services".

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog

    Thursday, February 13, 2014 3:52 PM
  • Finally We have found what is wrong.

    We needed to logon on the SSAS server with SCOM SSAS RunAsAccount and changed "regional setting" from "French" to "English".

    Now all of our SSAS instances are discovered.

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog


    Tuesday, February 18, 2014 3:30 PM