none
storage space offline due to critical write failures even though all the drives are working fine

    Question

  • I've got this storage space that I was using to store files that I wanted protected with redundancy, but while copying a very large 7zip archive something went wrong and I was told that there was a critical write error then windows was damaged and the auto repair wasn't working so I was forced to reinstall.

    After failing to boot after reinstall I decided to pull one of the 3 drives used in the storage space and everything worked just fine, except that the storage space was under 100% I/O utilization for about 15 minutes before I was notified of "critical write error" and of course one of the drives was missing (because I pulled it) so I formatted the drive I pulled and added it to the pool and removed the "missing" drive but the storage space still won't come online due to still having critical write error and asking to add a drive

    Is there any way I can try and restore the storage space, I had some important data on there and It would really be a shame if it was gone

    Sunday, February 04, 2018 12:46 AM

All replies

  • Hi Daniel,

    Which resiliency type you chose when you create storage space?

    Try to use the following steps to bring the drive to online.

    How to Offline/Online a disk using Diskpart

    If the issue persists, please try to run the following command line as administrator to check the disk.(Replace X: drive letter with the drive letter of the hard drive you want to repair)

    attributes disk clear readonly
    Exit
    Chkdsk  X:  /r

    NOTE: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites.

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 05, 2018 10:08 AM
    Moderator
  • I was having this exact problem and it seems to be an issue brought up all over various forums. I have tried a million convoluted solutions to no avail. This simple set of diskpart commands brought my disk back online after a week of not being able to access it and the 1tb of data on it. Thank you so much
    Sunday, March 04, 2018 4:51 PM