none
Mails not getting delivered

    Question

  • Hi Team,

    we are facing issues with some users not receiving emails from external domain.

    Issue:

    we received request from user that he needs additional smtp address and it needs to be primary address as well, keep old as primary address.

    After making the changes user was able to receive email from internal users but not from external users. Currently we have 2 users facing this issue.

    NDR message says The following organization rejected your message: mx record name 

    #5.2.0 smtp;550 5.2.0 mailbox unavailable.> #SMTP#.

    Please advise how to fix this issue.

    Thanks

    Abhishek saxena


    Abhishek Saxena

    Thursday, November 5, 2015 11:17 AM

Answers

  • Issue is fixed. 

    It was directory sync issue, service was terminated due to some reason.

    After restarting the service issue is resolved.

    Thank you all for valuable and prompt feedbacks.

    Thanks

    Abhishek


    Abhishek Saxena

    Friday, November 6, 2015 7:38 AM

All replies

  • have you added this additional SMTP address space as an accepted domain ?

    you would see this in get-accepteddomain in powershell

    otherwise they might have been blocked as potential spammers
    • Edited by Jon.Knight Thursday, November 5, 2015 11:21 AM
    Thursday, November 5, 2015 11:19 AM
  • yes it is in accepted domain.

    Abhishek Saxena

    Thursday, November 5, 2015 11:22 AM
  • we have many other users using it for example

    For example :

    Germany we have abc@xyz.de

    China we have abc@xyz.cn

    So user had .DE requested to change it to .CN as he is part of that OU


    Abhishek Saxena


    Thursday, November 5, 2015 11:25 AM
  • is it a case that nobody external can send to this user, or just specific external people? it sounds like the external people are being treated as spammers to this recipient, do you have any edge spam boxes to check logs on?

    Thursday, November 5, 2015 11:33 AM
  • Hello

    check new email address with https://testconnectivity.microsoft.com/ inbound smtp email and share result.
    havent got spam filter server?


    sorry my english

    Thursday, November 5, 2015 11:34 AM
  • None of the external users are able to send email to this address.

    We are using Retarus Gateway which does spam filtering.

    PFB result for test connectivity...

    Test Details
    Testing inbound SMTP mail flow for domain 'Laurent.luong@XYX.ch'.
      The Microsoft Connectivity Analyzer failed to test inbound SMTP mail flow.
     
    Additional Details
      Elapsed Time: 28064 ms.
     
    Test Steps
     
    Attempting to retrieve DNS MX records for domain 'XYZ.ch'.
      One or more MX records were successfully retrieved from DNS.
     
    Additional Details
    Testing Mail Exchanger mailin4.rmx.de.
      One or more SMTP tests failed for this Mail Exchanger.
     
    Additional Details
      Elapsed Time: 27914 ms.
     
    Test Steps
     
    Attempting to resolve the host name mailin4.rmx.de in DNS.
      The host name resolved successfully.
     
    Additional Details
    Testing TCP port 25 on host mailin4.rmx.de to ensure it's listening and open.
      The port was opened successfully.
     
    Additional Details
    Analyzing SMTP Capabilities for server mailin4.rmx.de:25
      SMTP Capabilities were analyzed successfuly.
     
    Additional Details
    Attempting to send a test email message to Laurent.luong@XYZ.ch using MX mailin4.rmx.de.
      Delivery of the test email message failed.
     
    Additional Details
     
    The server returned status code 550 - Mailbox unavailable. The server response was: 5.2.0 mailbox unavailable.
    Exception details:
    Message: Mailbox unavailable. The server response was: 5.2.0 mailbox unavailable.
    Type: System.Net.Mail.SmtpFailedRecipientException
    Stack trace:
    at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, Boolean allowUnicode, SmtpFailedRecipientException& exception)
    at System.Net.Mail.SmtpClient.Send(MailMessage message)
    at Microsoft.Exchange.Tools.ExRca.Tests.SmtpMessageTest.PerformTestReally()
    Elapsed Time: 26738 ms

     

    Abhishek Saxena


    Thursday, November 5, 2015 11:54 AM
  • Hello

    you have two chance.

    mistyped email address or your spam filter not sync the new smtp address.


    sorry my english

    Thursday, November 5, 2015 12:04 PM
  • verified the address its correct checking sync part.

    Abhishek Saxena

    Thursday, November 5, 2015 12:10 PM
  • your appliance is blocking it, raise with vendor
    Thursday, November 5, 2015 12:15 PM
  • Issue is fixed. 

    It was directory sync issue, service was terminated due to some reason.

    After restarting the service issue is resolved.

    Thank you all for valuable and prompt feedbacks.

    Thanks

    Abhishek


    Abhishek Saxena

    Friday, November 6, 2015 7:38 AM
  • Hi Abhishek,

    I am glad to hear the issue has solved.

    Could you share with us which service you restart?

    You answer will  help someone who has similar issue.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Friday, November 6, 2015 8:18 AM
    Moderator
  • We have configured directory sync on a server and this services sync email addresses changes/addition at our Gateway.

    Service name may depends on the Gateway you are using. We are using is Retarus, and service name is RetarusDirsync.

    I hope it will help.

     


    Abhishek Saxena

    Thursday, November 19, 2015 4:33 PM