locked
Sequencing Visio Viewer 2007 RRS feed

  • General discussion

  • Hello,
    Just sequenced VV 2k7 and here comes some do's
    (I sequenced on Win XP SP2 w/ IE7 w/ APP-V 4.5 RTM Sequencer and tested on Vista SP2 with IE8RC1) 

    Install Visio Viewer 2007
    Install Visio Viewer 2007 SP1

    Stop monitoring
    Proceed to Configure Applications part and see that it has located Internet Explorer with the Visio-file extensions associated to it.

    Add "%1" (including "") to the parameter tag for any FTA and uncheck the use DDE checkbox.
    It will warn you that this will apply for all FTA's, which is OK since otherwise every single one will have to be changed manually.

    I assume that when you use DDE it will use any IE window thats open, in my case I always have a local IE window open and when it tries to open in this one it doesn't work. (local IE doesn't know about the visio-plugin since its in the bubble...)

    I also changed the working directory to the workingdir of IE, but I am not sure this had anything todo with me getting this to work.

    I decided to test this when I saw the Visio 2003 thread on softgridguru.com.

    Cheers!

    Thursday, January 29, 2009 9:54 AM

All replies

  • Hi there,

    i tried a virtualization of VisioViewer2007 your way. I have a few more problems left:

    - The SP1 ofVisioViewer from the Microsoft Website is not installable, it gives errors and ends the updating process. So I just sequenced the Viewer without SP1 (or SP2 now, which also stops the installation).

    - After configurating the package as described, I'm able to open a .vsd-file an my App-V-client, but the IE8 is not able the show anything to me. It asks for ActiveX-permissions which I allow and then the whole window of IE8 is white and empty, although it tries to tell me it opened the file.

    I tried to search the Internet, but all I came up with was: http://support.microsoft.com/kb/931987/en-us/ And this is not helping me, because I think you already fixed the "%1"-problem!

    - I also tried VisioViewer2010 which was released in the meantime, but here again, the installation-process has some sort of problems.

    I sequence on VirtualBox with Windows XP SP2 and IE7 (and the problems with the installations are there without the Sequencer, too). The App-V-Client is a Windows 7 VM with IE8, but I don't think the versions of the OS or the IE should make a big difference.

    Wednesday, October 27, 2010 10:17 AM