none
Cross forest SCP AutoDiscover RRS feed

  • Question

  • Hi,

    I’m doing an exchange 2010 cross forest migrations. Two way trust is established and working. I want to export SCP records between forests for autodiscover. I have tested in test-lab/POC and all working fine.

    In the production, source forest use outlook 2007 (through Citrix) and target forest use outlook 2010 (through Citrix).

    My issue is when I try to “Test E-mail AutoConfiguration” from source forest (Outlook 2007) using target forest email address, it fails.

    But target (Outlook 2010) to source autodiscover is working fine.

    In the “Test E-mail AutoConfiguration” log, I can see SCP only gives local forest CAS server. I have reproduced the same issue in test-lab but blocking port 389 of target AD. But In the production environment, port 398 is open between server and outlook (2007) client.

    Appreciate any help on this issue.

    Cheers

    Friday, February 1, 2013 1:18 PM

Answers

  • Hi All,

    I found the issue, it is a bug of outlook 2007. Hotfix is available.

    http://support.microsoft.com/?kbid=973404

    Hotfix works only with outlook SP1 and SP2 (tested in lab), but my environment use outlook SP3.

    Hi Evan,

    I have exported the SCP and environment is fully functioning with Outlook2010. as I said in production, most of the users have outlook 2007 with SP3.

    However the hotfix doesnot resole the issue with outlook 2007 SP3.
    Monday, February 4, 2013 2:33 PM

All replies

  • Hi All,

    I reproduce the issue in my test environment using outlook 2007. So it is outlook 2007 problem.

    As I understand, Outlook 2007 query only local forest's SCP records even target forest's SCP record is available in active directory.

    Appreciate any help to overcome this issue.

    Cheers

    Monday, February 4, 2013 3:50 AM
  • No, if you want Outlook 2007 in one forest can access the Client Access servers in the remote forest, you can follow this document run the Export-AutodiscoverConfig command in each forest.

    How to Configure the Autodiscover Service for Multiple Forests
    http://technet.microsoft.com/en-us/library/aa996849(EXCHG.80).aspx

    Thanks,

    Evan


    Evan Liu
    TechNet Community Support

    Monday, February 4, 2013 9:27 AM
  • Hi

    Autodiscover will use the SCP from the domain the machine is joined to.  You can disable this in the registry (or with GPO) and use one of the other methods instead: http://support.microsoft.com/kb/2212902 

    Cheers, Steve

    Monday, February 4, 2013 9:33 AM
  • Hi All,

    I found the issue, it is a bug of outlook 2007. Hotfix is available.

    http://support.microsoft.com/?kbid=973404

    Hotfix works only with outlook SP1 and SP2 (tested in lab), but my environment use outlook SP3.

    Hi Evan,

    I have exported the SCP and environment is fully functioning with Outlook2010. as I said in production, most of the users have outlook 2007 with SP3.

    However the hotfix doesnot resole the issue with outlook 2007 SP3.
    Monday, February 4, 2013 2:33 PM