none
2019 RDSH - not able reconnect to Disconnected session, every time new session (with fSingleSessionPerUser=0) RRS feed

All replies

  • Hi,

    If possible, please patch your RDS system fully with Windows Update/Hotfix, it would be helpful for resolving some known issues and improving the performance.

    Please open Run, type “winver” and end with enter. Compare the OS build number with the number mentioned in “Windows 10 and Windows Server 2019 update history” to determine current system patch level:
    https://support.microsoft.com/en-us/help/4464619

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 6, 2019 2:29 AM
    Moderator
  • Hi,

    How things are going there on this issue?

    Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang   

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 8, 2019 3:18 AM
    Moderator
  • i can only confirm that problem still exist after updating with all available updates from Microsoft.

    That is one of the example servers that was tested (server is Azure based D8sv3 if that is important, but we have same problem in AWS as well).

    Host Name:                 MSNV-RSPHERDS1
    OS Name:                   Microsoft Windows Server 2019 Datacenter
    OS Version:                10.0.17763 N/A Build 17763
    OS Manufacturer:           Microsoft Corporation
    OS Configuration:          Member Server
    OS Build Type:             Multiprocessor Free
    Registered Owner:          N/A
    Registered Organization:   N/A
    Product ID:                00430-00000-00000-AA188
    Original Install Date:     4/20/2019, 5:45:57 PM
    System Boot Time:          5/8/2019, 4:57:23 PM
    System Manufacturer:       Microsoft Corporation
    System Model:              Virtual Machine
    System Type:               x64-based PC
    Processor(s):              1 Processor(s) Installed.
                               [01]: Intel64 Family 6 Model 63 Stepping 2 GenuineIntel ~2397 Mhz
    BIOS Version:              American Megatrends Inc. 090007 , 6/2/2017
    Windows Directory:         C:\windows
    System Directory:          C:\windows\system32
    Boot Device:               \Device\HarddiskVolume1
    System Locale:             en-us;English (United States)
    Input Locale:              en-us;English (United States)
    Time Zone:                 (UTC-05:00) Eastern Time (US & Canada)
    Total Physical Memory:     32,768 MB
    Available Physical Memory: 28,838 MB
    Virtual Memory: Max Size:  37,632 MB
    Virtual Memory: Available: 32,928 MB
    Virtual Memory: In Use:    4,704 MB
    Page File Location(s):     D:\pagefile.sys
    Domain:                    
    Logon Server:              
    Hotfix(s):                 6 Hotfix(s) Installed.
                               [01]: KB4489192
                               [02]: KB4465065
                               [03]: KB4480056
                               [04]: KB4493478
                               [05]: KB4493510
                               [06]: KB4495667
    Network Card(s):           1 NIC(s) Installed.
                               [01]: Microsoft Hyper-V Network Adapter
                                     Connection Name: Ethernet
                                     DHCP Enabled:    Yes
                                     DHCP Server:     168.63.129.16
                                     IP address(es)
                                     [01]: 172.16.16.34
                                     [02]: fe80::a115:e12e:756a:9554
    Hyper-V Requirements:      A hypervisor has been detected. Features required for Hyper-V will not be displayed.

    Wednesday, May 8, 2019 9:19 PM
  • Hi,

    I will try to re-produce this problem on my test environment, if there is any update, I will reply to you.

    Thank you for your understanding. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, May 9, 2019 7:27 AM
    Moderator
  • I can confirm that we are experiencing the exact same re-connection issue.  This is not a new issue, it was reported back in the preview builds 2 yeas ago.

    https://techcommunity.microsoft.com/t5/Windows-Server-Insiders/Bug-no-reconnect-to-disconnected-session-with/td-p/218413

    Friday, June 7, 2019 2:11 AM
  • Any progress with testing, @Eve Wang?

    Latest update didnt help..

    Monday, August 12, 2019 4:11 PM
  • We have the same problem and are currently on OS Build 17763.678 on ESXi 6.7.0

    We have to buy additional CALs but we will wait for the solution as this version is useless for remote desktop connections as every time you login you lose all your open applications/files. The second solution would be to downgrade to Win Server 2016 but we spent so many days to install all the needed applications to the new hardware and I would like to avoid it.

    I tried also to force enable the "Restrict Remote Desktop Services to a single Remote Desktop Services session" in Local Group Policy but it does not help.

    Any plan when this will be fixed ?

    S.


    Monday, August 19, 2019 7:27 AM
  • Btw, we solved the issue of limitless open connections and related spending of RAM enabling "Set time limit for disconnected sessions" in Local Computer Policy / Windows components / Remote Desktop Services / Remote Desktop Session Host / Session Time Limits.

     But this is just a workaround that kills the "idle" disconnected sessions and resolves the RAM and resources issue of endless idle connections which are generated by each new session .


    Monday, August 19, 2019 7:32 AM
  • I have solved this issue by going to Local Group Policy Editor >> Computer Configuration >>  Administrative Templates >>  Windows Components >> Remote Desktop Services >>  Remote Desktop Session Host >> Connections.  The setting you want to change is called "Restrict Remote Desktop Services users to a single Remote Desktop Services session"  Set this to "Enabled" and users will automatically be forced to reconnect to their existing open session.
    Monday, August 19, 2019 11:02 PM
  • It does not help, I did the same before.... se my comment above "I tried also to force enable the "Restrict Remote Desktop Services to a single Remote Desktop Services session" in Local Group Policy but it does not help."
    Tuesday, August 20, 2019 12:39 PM
  • We were able to make it work... at the end the problem was the group policy that was overriding local setting (OS Build 17763.678 on ESXi 6.7.0).
    Wednesday, August 21, 2019 12:13 PM
  • Can you be more explicit on how you resolve the problem ?

    I have the same issue.

    Monday, August 26, 2019 11:43 AM
  • this is a non-solution. The way you solving this users will have no option to have multiple sessions on the same host. I need to have two to three sessions open and I want to be able to re-connect to them when my connection drops or when simply close mstsc app. Windows Server 2012R2 offers a selection to which disconnected session you would like to connect. Windows 2019 has no such option?
    Sunday, September 15, 2019 9:10 PM
  • Marko, what exact setting are you referring to? Can you elaborate, please?
    Sunday, September 15, 2019 9:11 PM
  • I confirm that the issue still exists and is main obstacle in moving to Windows Server 2019. Have anyone found a solution other than using Windows Server 2016 or limiting RDP user to a single session?

    It appears that starting from Windows Server 2019 disconnected sessions remain in unlocked state which make them 'active', hence, not reconnectable. If you lock the session before dropping connection, you can reconnect no problem.

    I was looking into a way to lock a session on disconnect - that would solve the issue, but I did not find a GPO for that. Yes, there is a GPO for locking based on time limit of inactivity. I presume it could be a 'better-than-nothing' workaround, but it is a half-measure because:

    1. It will lock RDP sessions in connected state, which may be annoying to users.
    2. It will not solve issue of disconnect/reconnect on unreliable link, as you would need to wait whatever timeout you set to be able to reconnect.

    I recall that Microsoft had very similar issue in early days of Terminal Server, which persisted for years, making solid case for using Citrix, as it was working perfectly. Hate when this happens...

    Would appreciate if anyone has any update/solution.


    • Edited by SQL-ER Thursday, September 19, 2019 7:52 PM
    Thursday, September 19, 2019 7:48 PM
  • We have the same problem. No work around we can find. I did read it was supposed to be fixed in the September update but nope! Cant say i was surprised.
    Thursday, October 10, 2019 8:46 PM
  • Marko, Could you tell me how did you make it works?
    Friday, October 11, 2019 7:25 AM
  • I am experiencing the same issue. Does anyone know if tomorrow's November update will fix this?
    Monday, November 11, 2019 4:32 PM
  • Well, this was NOT fixed in the November 2019 update. Still an ongoing issue!
    Thursday, November 14, 2019 7:55 PM
  • Still no solution for this problem? And still no answer from Microsoft?? At least the company still seems to exist as their webservers are up and running..
    Monday, November 18, 2019 7:25 AM
  • Having this same issue with users at another location attempting to reconnect to my 2016 farm. Someone on another post with the same issue said they fixed it but the fix was very vague " The issue was on the Pulse MAG, there was an entry that needed to be added into the resource policy. Seems to be working fine now." If anyone knows what that means then please let me know. My users are coming in through a WAP server.
    Friday, November 22, 2019 12:21 PM
  • I just spent 90 minutes on the phone with Microsoft Tech Support. He tried to tell me that the group policy setting "Restrict Remote Desktop Services users to a single Remote Desktop Services session" would fix my problem. It does force the session to reconnect to the previous session, but it also totally breaks functionality of Terminal Server by totally blocking all simultaneous user sessions. On our shop floor for example, the user SHOP needs to have 12 simultaneous sessions, one from each of the 12 thin clients.

    Why it took him 90 minutes to finally understand my problem, I don't know. It was if he was ignoring everything I was telling him. I pointed him to this article, noting that many other people are having the same issue. I told him it is a bug, not a setting, and that he is going to have to submit it to development. He said he is going to work in his test environment to get it fixed by the end of the day. I'm not holding my breath.

    Thursday, November 28, 2019 8:00 PM
  • Hi,  did you try to disabled Large Send Offload V2(IPv4) in network adapter Properties, I had the same problem and another problem was PDF , keep session disconnected and too fixed by changed register key FeatureLockDown "bProtectedMode"

    Friday, November 29, 2019 6:50 PM
  • Still no fix from Microsoft tech support but it HAS been submitted to development for a fix. No time frame yet. I'll let you all know if/when it is fixed.
    Friday, December 6, 2019 3:40 PM
  • We are having the same issue. December 2019 patch does not fix it either. .

    Tuesday, December 10, 2019 6:57 PM
  • Today I received this reply from Microsoft Tech Support:

    "I received an email from our backend team and confirmed that its a known issue and they are still working on it. It does not have any ETA for solution but we will email you when a fix is released."

    I'll keep you all udpated.

    Tuesday, December 10, 2019 7:47 PM
  • HI  ,

    Any update , we need to fix this issue, because in our servers 2019 around 20 people connected several time in the day and we have a lot of disconnected sessions and it's effect to our performance, and our work around is Task Schedule PowerShell script to log off disconnected users every 3 hours but still people need to reconnect back to disconnected session

    thank you

    Saturday, December 21, 2019 12:04 AM
  • Hi,


    My solution is change Local GP and after that I'm able to connect back to disconnected session


    Computer Configuration -->  Administrative Templates -->  Windows Components --> Remote Desktop Services -->  Remote Desktop Session Host --> Connections


    "Restrict Remote Desktop Services users to a single Remote Desktop Services session"  Set this to "Enabled"
    "Limit number of connections"Set this to "Enabled"  and for me need 3 users

    also

    thank you

    let me know if this help

    • Edited by Mooner09 Saturday, December 21, 2019 10:30 PM
    Saturday, December 21, 2019 4:55 PM
  • Nope, that doesn't fix the problem because it introduces a new problem where each username can only sign on once. In a manufacturing environment there is often one username "SHOP" that is shared across all terminals, so you might have 20 sessions of that one username at once. That is required. Terminal Server has operated in this way since at least Server 2008.
    Thursday, December 26, 2019 10:19 PM
  • Hi,

    i'm facing the same problem with my new 2019 RDS Farm.

    The Farm consists of 3 Session Hosts, one broker and licensing server + one gateway server.
    Luckily my environment is still in a kind of testing state and is about to go live early 2020.

    But my problem is the same as aaronssh - multiple sessions of one user across the farm.

    Would be great if someone could find a solution to this problem or Microsoft finally releases the fix.

    Please keep us up to date @aaronssh

    Friday, December 27, 2019 12:14 PM
  • I spoke with Microsoft support and they know about this issue and they told me next windows 2019 update  (1-2 week) it will be fixed

    thank you

    Wednesday, January 1, 2020 9:13 PM
  • Welp, it's still not fixed in the January 2020 update. WHY????????
    Wednesday, January 15, 2020 2:05 PM
  • yept, doesn't fixed, I will ask too , still wait answer 
    Wednesday, January 15, 2020 6:02 PM
  • Really Microsoft!!!!!! Major bug left for months
    Thursday, January 16, 2020 12:28 PM
  • Any news on this ? 
    I have the same issue
    Wednesday, January 29, 2020 3:18 PM
  • To: @aaronsh.

    Thanks for the update, I hope they will fix it because it is such a huge change in functionality from 2016 to 2019. Do you have the case number or issue ID? KB number? We should all follow it.


    • Edited by SQL-ER Saturday, February 8, 2020 3:11 PM
    Saturday, February 8, 2020 2:54 PM
  • To: @Mooner09

    Restricting RDP sessions to 1 per user is not a solution. This is a change in RDP functionality. We need to:

    1. have multiple sessions per user at a single host
    2. have users, who closed MSTC by pressing X or Win+Disconnect, to be able to reconnect to the session which is in disconnected state. If there are several, a pop-up window with session choice should be displayed.

    That how it worked prior to Win2019.

    Currently, regardless of number of disconnected sessions, a new session is created. If there is no timeout limit for disconnected session to close, the disconnected sessions will pile up on the server. Setting the timeout limit is not a solution, as in our environment users need to be able to reconnect to their existing disconnected sessions (they have some work progress going on there).

    The only current workaround is to tell users to open Task Manager in a new session, find their disconnected session and manually connect to it. They also need to sign out their "entry session" after that, again, using the Task Manager.



    • Edited by SQL-ER Saturday, February 8, 2020 3:10 PM
    Saturday, February 8, 2020 3:03 PM
  • The case number that I was assigned is: 119111824005682

    Their most recent update on 01/27 was literally: "I still have not heard back anything from our backend team and it seems that on 2019 Server its kind of default behavior. As it is not clear yet about any bug or known issue you might have to go with 2016 Windows server version for now."

    Still waiting. Maybe today's patch Tuesday will finally fix this?


    AaronSSH

    Tuesday, February 11, 2020 1:03 PM
  • To: @SQL-ER

    Thank you so much for sharing that trick about the "workaround is to tell users to open Task Manager in a new session, find their disconnected session and manually connect to it."

    In 15 years of using Terminal Services, I never knew that. It sure would have been nice if the Microsoft person understood Terminal Services well enough to make this recommendation. Not a fix, but will at least help appease our remote users who sometimes get disconnected.


    AaronSSH

    Tuesday, February 11, 2020 1:08 PM
  • @AaronSSH Doesn't look like today's patch fixed it either. 
    Tuesday, February 11, 2020 3:25 PM
  • I just tested and nope, still not fixed after February patch Tuesday.

    AaronSSH

    Thursday, February 13, 2020 1:03 PM
  • I just tested and nope, still not fixed after MARCH patch Tuesday.

    If you are reading this, PLEASE call Microsoft to report this bug. Everyone reading this but not reporting the bug is contributing to the fix being delayed. Microsoft needs to hear complaints from enough people or they won't make it a priority.


    AaronSSH



    • Edited by aaronssh Wednesday, March 11, 2020 10:25 AM
    Wednesday, March 11, 2020 10:23 AM
  • i wonder when those stupid, idiotic dumbasses will fix this ridiculous, preposterous bug.

    i just hate microsoft so much for delivering so much crap since all that live tile shit started to pop up.

    they just don't care about quality anymore. only hipsters everywhere, saying "the more updates and builds per day, the better!".

    i mean, just FO.
    Thursday, March 12, 2020 11:59 AM
  • To: @SQL-ER

    Thank you so much for sharing that trick about the "workaround is to tell users to open Task Manager in a new session, find their disconnected session and manually connect to it."

    In 15 years of using Terminal Services, I never knew that. It sure would have been nice if the Microsoft person understood Terminal Services well enough to make this recommendation. Not a fix, but will at least help appease our remote users who sometimes get disconnected.


    AaronSSH

    LOL, you're welcome. The problem wth this workaround is that the original session got disconnected and to be very clean, the users must open Task Manager again in "reconnected" session and logout the original entry session. Haven't seen anything uglier than that :-)
    Saturday, March 14, 2020 3:32 PM
  • I just tested and nope, still not fixed after MARCH patch Tuesday.

    If you are reading this, PLEASE call Microsoft to report this bug. Everyone reading this but not reporting the bug is contributing to the fix being delayed. Microsoft needs to hear complaints from enough people or they won't make it a priority.


    AaronSSH



    What number did you call to report the issue? From my old past interactions you have to sit few hours on the phone with dumb tier 1 support person who follows some sort of flowchart suggesting "have you tried to turn it off and on?" And you had to give them your cc number before they even speak to you...

    The case number you provided is not a KB number, but some sort of internal ref no. Can you ask them if they have a KB number associated with the case?


    • Edited by SQL-ER Saturday, March 14, 2020 3:40 PM
    Saturday, March 14, 2020 3:40 PM
  • Really Microsoft!!!!!! Major bug left for months
    I have a feeling they will simply promote it into the features list to resolve... LMAO
    Saturday, March 14, 2020 3:42 PM
  • The April Patch Tuesday updates did not resolve this issue.

    Microsoft has let this major bug sit there unchanged for 12 months. If anyone reading this is thinking about deploying Server 2019, it will be worth it to stay with 2016.

    Perhaps Server 2019 will go the way of Windows 8? Yeah it exists, but never to be adopted en mass, just not worth it.


    AaronSSH

    Friday, April 17, 2020 1:58 PM
  • Here is the solution:

    https://medium.com/@moshecombr/windows-2019-rdp-rdsh-not-able-reconnect-to-disconnected-session-every-time-new-session-a1891df6e9c8

    gpmc.msc — Edit users policies— User Configuration — Policies — Administrative Templates — All Settings — Remove Lock Computer — Change to Enabled

    Tuesday, May 12, 2020 5:49 PM
  • Thank you Moshe, this worked perfectly for us.

    -herb

    Wednesday, May 13, 2020 8:44 PM
  • Here is the solution:

    https://medium.com/@moshecombr/windows-2019-rdp-rdsh-not-able-reconnect-to-disconnected-session-every-time-new-session-a1891df6e9c8

    gpmc.msc — Edit users policies— User Configuration — Policies — Administrative Templates — All Settings — Remove Lock Computer — Change to Enabled

    nice one, until our security dudes come along and make us revert that setting.

    MS, just FIX THIS ALREADY! This is sooooo ridiculous. They just don't give a rat's ass.


    rant:

    MS Developers and their managers can be happy that they can hide behind those dumb Tier 1 support zombies otherwise they'd probably need a crapload of therapy sessions to not kill themselves because of the heap of hatred they'd have to face every day. my hatred about their software would easily suffice for like 80% of all the people involved in Windows development. Stupid, preposterous creatures. They're like glow sticks. I want to snap them and shake the shit out of them until the light comes on.

    server 2016/2019 (basically any windows 10 code base stuff) is buggy as sh*t! anyone noticed cortana spamming the server(!) event log with errors? only half-way loaded background images in rdp sessions (oh yes, we sure need that crappy background image on a server anyway, because we all do have 10Gb MPLS lines to AAAALL of our servers).

    Important things like mmc, PKI-, DHCP--, DNS- or NPS-management did not change for AGES but heeey we have a wallpaper, cortana and candy crush saga on our servers. Even Hyper-V is still a monsterious PITA to use and manage. oooh boy, don't get me started on this. Failover Cluster Manager... what a ridiculous piece of shitty crap-software is that? hands up everyone who actually got an outage due to microsofts ridiculous failover cluster mechanics (which were made for preventing outages, for those to whom that's not obvious)! talk to a vmware admin, he'll ROFL himself around the world twice (at least).

    /rant over

    Thursday, May 14, 2020 8:23 AM
  • Here is the solution:

    https://medium.com/@moshecombr/windows-2019-rdp-rdsh-not-able-reconnect-to-disconnected-session-every-time-new-session-a1891df6e9c8

    gpmc.msc — Edit users policies— User Configuration — Policies — Administrative Templates — All Settings — Remove Lock Computer — Change to Enabled

    This did work for me. THANK YOU MOSHE!!!

    AaronSSH

    Wednesday, June 3, 2020 7:50 PM
  • Hello,

     Did you find any solution? We have a very similiar issue...when use close but not log off from connection the next time when logon sometimes get TEMP profile (user disconnect session from SERVER1, but next time the balancer put to SERVER2...i think...)

    I'm looking for a solution to force user with disconnected state to log back to that SERVER / session..

    Tuesday, July 7, 2020 7:51 PM
  • OMG It's fixed!!!

    https://support.microsoft.com/en-us/help/4559003

    Addresses an issue that occurs when a standalone Remote Desktop Session Host (RDSH) server allows multiple sessions per user. After disconnecting from a session, if you attempt to reconnect to the original session, the server creates a new session instead.

    Thursday, July 23, 2020 12:37 AM
  • HOLY FING MOLY!! Well done Microsoft, you should be very proud of yourself and pat yourself on the back. 14 months for a major bug fix
    • Edited by Stuie1982 Friday, August 7, 2020 2:15 PM
    Friday, August 7, 2020 2:14 PM