none
Should I install Exchange again?? RRS feed

  • Question

  • We have been having some issues with some of the features with Exchange 2010 that a previous person has setup.

    Current issues are:

    - Mail tips don't work
    - Mail tracking doesn't work
    - Out of Office doesn't work
    - Can't share a calendar in Outlook 2010 only works in 2007
    - Can't connect a Mac using Outlook
    - Webmail options don't work - I keep on getting a login page.

    My current version of Exchange 2010 is 14.00.0722.000.

    Instead of trying to update the the exchange server and hoping that it would fix all my issues I decided just to create a new VM and just finished installing all the Windows updates. I'm now at the point to ready to install Exchange 2010/sp1 but I'm wondering if this is my best options.

    I have no idea what the other person has done but I have now inherited this mess and I want to get it fixed.

    What would you do? Are all my problems related? If I create a new Exchange server, it is easy to move the mailboxes over? I'm at a total lost of what I should do so I need some suggestions.

    Thanks for your help.

    James
    Thursday, June 7, 2012 5:48 PM

All replies

  • Hi,
    All of your problems is realated and has to do with Webservices.
    Probably some misconfigured URL for WebServicesVirtualDirectory. It also seems like Autodiscover isn't working for you and that is usually caused by using using a selfsigned certificate that the client doesn't trust.

    If I were you, I would start by troubleshooting Autodiscover and you will get a lot of good information by running Test-OutlookWebServices in Exchange Management Shell (EMS)


    Exchange 2010 RTM hasn't been supported since October last year, so suggest that you install SP2 and RU3.
    If you decide to install a new Server (I don't think you need to) don't go for SP1.


    Martina Miskovic

    Thursday, June 7, 2012 6:09 PM
  • I did as you suggested and here are the results and I'm not sure what it all means.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1019
    Type       : Information
    Message    : A valid Autodiscover service connection point was found. The Autodiscover URL on this object is https://Se
                       rverMX2.msdk12.local/Autodiscover/Autodiscover.xml.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1006
    Type       : Information
    Message    : Contacted the Autodiscover service at https://ServerMX2.msdk12.local/Autodiscover/Autodiscover.xml.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1016
    Type       : Information
    Message    : [EXCH] The AS is configured for this user in the AutoDiscover response received from https://ServerMX2.msd
                         k12.local/Autodiscover/Autodiscover.xml.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1015
    Type       : Information
    Message    : [EXCH] The OAB is configured for this user in the AutoDiscover response received from https://ServerMX2.ms
                        dk12.local/Autodiscover/Autodiscover.xml.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1014
    Type       : Information
    Message    : [EXCH] The UM is configured for this user in the AutoDiscover response received from https://ServerMX2.msd
                         k12.local/Autodiscover/Autodiscover.xml.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1016
    Type       : Warning
    Message    : [EXPR] The AS is not configured for this user in the AutoDiscover response received from https://ServerMX2
                        .msdk12.local/Autodiscover/Autodiscover.xml.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1015
    Type       : Information
    Message    : [EXPR] The OAB is configured for this user in the AutoDiscover response received from https://ServerMX2.ms
                 dk12.local/Autodiscover/Autodiscover.xml.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1014
    Type       : Warning
    Message    : [EXPR] The UM is not configured for this user in the AutoDiscover response received from https://ServerMX2
                       .msdk12.local/Autodiscover/Autodiscover.xml.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1022
    Type       : Success
    Message    : Autodiscover was tested successfully.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1021
    Type       : Information
    Message    : The following web services generated errors: As,UM in EXPR. Use the previous output to diagnose and correc
                        t the errors.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1013
    Type       : Error
    Message    : When contacting https://servermx2.msdk12.local/EWS/Exchange.asmx received the error The request failed wit
                       h the error message:
                 --
                 <html><head><title>Object moved</title></head><body>
                 <h2>Object moved to <a href="%2fEWS%2flogin.aspx%3fReturnUrl%3d%252fEWS%252fExchange.asmx">here</a>.</h2>
                 </body></html>

                 --.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1025
    Type       : Error
    Message    : [EXCH] Error contacting the AS service at https://servermx2.msdk12.local/EWS/Exchange.asmx. Elapsed time w
                       as 687 milliseconds.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1013
    Type       : Error
    Message    : When contacting https://servermx2.msdk12.local/EWS/Exchange.asmx received the error The remote server retu
                      rned an error: (404) Not Found.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1027
    Type       : Error
    Message    : [EXCH] Error contacting the UM service at https://servermx2.msdk12.local/EWS/Exchange.asmx. Elapsed time


                       as 234 milliseconds.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1113
    Type       : Error
    Message    : When contacting https://servermx2.msdk12.local/ews/exchange.asmx received the error The request failed wit
                 h the error message:
                 --
                 <html><head><title>Object moved</title></head><body>
                 <h2>Object moved to <a href="%2fEWS%2flogin.aspx%3fReturnUrl%3d%252fews%252fexchange.asmx">here</a>.</h2>
                 </body></html>

                 --.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1125
    Type       : Error
    Message    : [Server] Error contacting the AS service at https://servermx2.msdk12.local/ews/exchange.asmx. Elapsed time
                  was 31 milliseconds.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1113
    Type       : Error
    Message    : When contacting https://servermx2.msdk12.local/ews/exchange.asmx received the error The remote server retu
                 rned an error: (404) Not Found.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1127
    Type       : Error
    Message    : [Server] Error contacting the UM service at https://servermx2.msdk12.local/ews/exchange.asmx. Elapsed time
                  was 0 milliseconds.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1004
    Type       : Error
    Message    : The certificate for the URL https://mail.melbaschools.org/rpc is incorrect. For SSL to work, the certifica
                 te needs to have a subject of mail.melbaschools.org, instead the subject found is ServerMX2. Consider corr
                 ecting service discovery, or installing a correct SSL certificate.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1028
    Type       : Success
    Message    : [EXPR] Successfully contacted the RPC/HTTP service at https://mail.melbaschools.org/rpc. The elapsed time
                 was 374 milliseconds.

    RunspaceId : 8bb48aa5-af3b-42cc-9144-611f95e942c2
    Id         : 1128
    Type       : Success
    Message    : [EXPR] Successfully contacted the RPC/HTTP service at https://servermx2.msdk12.local/rpc. The elapsed time
                  was 0 milliseconds.

    Thursday, June 7, 2012 6:20 PM
  • Hi,
    I can see that you don't have a trusted certificate installed, instead you have the one certificate that was created during the Exchange Setup.
    This is something you should do something about!

    The best is to buy a certificate from a trusted authority, for exampel GoDaddy or Cerificate for Exchange and the names you would need is:

    Common Name: mail.melbaschools.org

    Subject Alternative Names:
    mail.melbaschools.org
    autodiscover.melbaschools.org  (if this your smtpdomain)
    ServerMX2.msdk12.local

    One easy way to create the certificate request, is to use DigiCert's Exchange 2010 CSR Tool
    Digicert also has some very nice guides on how to create the request and install the certificate, when you get it form the Trusted Authority.


    It also looks like you have redirect configured for the Virtualdirectories in IIS. Go thru all of them, like OWA, ECP, EWS etc and remove it.
    See: Simplify the Outlook Web App URL

    Installing SP2 and RU3 will not solve your problem, but I really recommend you to do so.


    Martina Miskovic

    Thursday, June 7, 2012 6:35 PM
  • So if I only have redirect on exchange, exchweb and public I should remove it?  No other directories in IIS have this.  Would this be causing all my issues?  Thanks for your help.

    James

    Thursday, June 7, 2012 8:21 PM
  • So if I only have redirect on exchange, exchweb and public I should remove it?  No other directories in IIS have this.  Would this be causing all my issues?  Thanks for your help.

    James


    Sorry, I should have mentioned that those directories should have the redirect /owa

    Can you run Get-WebServicesVirtualDirectory | fl Identity,*url*,*auth* and post the output?

    Martina Miskovic

    Thursday, June 7, 2012 8:27 PM
  • Identity                      : SERVERMail\EWS (Default Web Site)
    InternalNLBBypassUrl          : https://servermail.mdk12.local/ews/exchange.asmx
    InternalUrl                   : https://servermail.mdk12.local/EWS/Exchange.asmx
    ExternalUrl                   :
    CertificateAuthentication     :
    InternalAuthenticationMethods : {Ntlm, WindowsIntegrated, WSSecurity}
    ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated, WSSecurity}
    LiveIdSpNegoAuthentication    : False
    WSSecurityAuthentication      : True
    LiveIdBasicAuthentication     : False
    BasicAuthentication           : False
    DigestAuthentication          : False
    WindowsAuthentication         : True
    Thursday, June 7, 2012 8:32 PM
  • Where is the redirect from mail.melbaschools.org to http://webmail.melbaschools.org/Exchange comming from and why do you use port 80?

    That is not a good combination with EWS using port 443.

    I think you should patch your server. That might fix your problem with EWS, even if the above looks good but your test with Test-Outlookwebservices didn't. It really looks like you have a redirect there.

    Message    : When contacting https://servermx2.msdk12.local/EWS/Exchange.asmx received the error The request failed wit
                       h the error message:
                 --
                 <html><head><title>Object moved</title></head><body>
                 <h2>Object moved to <a href="%2fEWS%2flogin.aspx%3fReturnUrl%3d%252fEWS%252fExchange.asmx">here</a>.</h2>
                 </body></html>

    Martina Miskovic

    Thursday, June 7, 2012 8:37 PM
  • I have no idea why it's setup that way and the other admin got fired so I can't ask him why.  So, I  should update the server and see if that fixes my issues?
    Thursday, June 7, 2012 8:42 PM
  • Identity                      : SERVERMail\EWS (Default Web Site)
    InternalNLBBypassUrl          : https://servermail.mdk12.local/ews/exchange.asmx
    InternalUrl                   : https://servermail.mdk12.local/EWS/Exchange.asmx
    ExternalUrl                   :
    CertificateAuthentication     :
    InternalAuthenticationMethods : {Ntlm, WindowsIntegrated, WSSecurity}
    ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated, WSSecurity}
    LiveIdSpNegoAuthentication    : False
    WSSecurityAuthentication      : True
    LiveIdBasicAuthentication     : False
    BasicAuthentication           : False
    DigestAuthentication          : False
    WindowsAuthentication         : True

    Sorry, I missed that you don't have an externalurl configured. You should fix that

    Don't know if it should be https://webmail.melbaschools.org/EWS/Exchange.asmx or https://mail.melbaschools.orgEWS/Exchange.asmx
    That depends what name you have configured for OWA (or name you will have in the certificate you really should get)

    Martina Miskovic

    Thursday, June 7, 2012 8:42 PM
  • So, I have a redirect for OWA but nothing is listed.  I removed the checkmark, now webmail isn't working anymore.  I don't know what I should redirect it to.
    Thursday, June 7, 2012 8:46 PM
  • So, I have a redirect for OWA but nothing is listed.  I removed the checkmark, now webmail isn't working anymore.  I don't know what I should redirect it to.

    I don't follow what you just changed, but you have a redirect. Can't tell where you is, but a redirect should be configured as in the link I posted earlier.

    /Exchange was used in Exchange 2003, but should not be used in Exchange 2010. It's only for backward backword compatibility.


    Martina Miskovic

    Thursday, June 7, 2012 8:53 PM
  • I was looking at the OWA in IIS for redirection and I noticed it has a checkmark however it didn't have anything listed to the redirection.  So, I removed the checkmark, restarted IIS and now web mail isn't work.  So, I went to add the check mark back but I can't save it because it wants me to enter something in for the redirection.  The problem is nothing was listed so I don't know what i should be using.

    When I type in webmail.melbaschools.org it's going to http://webmail.melbaschools.org/exchange/ .  If I change the /exchange/ to owa, I can login to webmail.  I can't figure out why.

    Thursday, June 7, 2012 9:03 PM
  • The OWAVirtualdirectory should not have a redirect configured.

    Did you change /Exchange?

    Hers's what that directory should be set to.


    Martina Miskovic

    Thursday, June 7, 2012 9:16 PM
  • I was looking at the OWA in IIS for redirection and I noticed it has a checkmark however it didn't have anything listed to the redirection.  So, I removed the checkmark, restarted IIS and now web mail isn't work.  So, I went to add the check mark back but I can't save it because it wants me to enter something in for the redirection.  The problem is nothing was listed so I don't know what i should be using.

    When I type in webmail.melbaschools.org it's going to http://webmail.melbaschools.org/exchange/ .  If I change the /exchange/ to owa, I can login to webmail.  I can't figure out why.


    You have some redirect configured in a file in the Default Web Site. You need to find it.
    /Exchange should not be used with Exchange 2010.
    Have you looked in C:\inetpub\wwwroot ?

    Martina Miskovic

    Thursday, June 7, 2012 9:21 PM
  • Well, when I do that it still wants to add the redirect to the OWA folder.

    Thursday, June 7, 2012 9:23 PM
  • Well, when I do that it still wants to add the redirect to the OWA folder.


    When you do what?

    Check the web.config in C:\inetpub\wwwroot ?

    Martina Miskovic

    Thursday, June 7, 2012 9:24 PM
  • When I put the checkmark to the http redirect.  It wants to use the redirect for OWA,

    I don't have exchange listed in web.config in wwwroot

    Thursday, June 7, 2012 9:27 PM
  • When I put the checkmark to the http redirect.  It wants to use the redirect for OWA,

    I don't have exchange listed in web.config in wwwroot


    Sorry, I don't follow. What checkmark?

    See if this can help you find the file you do have with /exchange in it.
    http://www.sslshopper.com/iis7-redirect-http-to-https.html

    Martina Miskovic

    Thursday, June 7, 2012 9:29 PM
  • Okay, it's no longer redirecting to exchange but owa but now I have another issue.  When I type in webmail.melbaschools.org it's going to http://webmail.melbaschools.org/owa/auth/logon.aspx but I get an error saying the page isn't redirecting correctly.
    Thursday, June 7, 2012 9:35 PM
  • Having a hard time guessing what you are changing.

    I still see this:

    ..and /owa that used to work doesn't anymore.


    Martina Miskovic

    Thursday, June 7, 2012 9:42 PM
  • I went into IIS and looked for redirection.  Under OWA - Redirections - I had a checkmark but I didn't have anything listed to redirect too.  So I removed the checkmark and everything stop working.  I then went in and added /owa  to exchange.  I then looked in OWA and redirections and it had the check mark again with /owa.

    Now I'm stuck.  Webmail isn't work anymore and I don't understand why.

    Thursday, June 7, 2012 9:49 PM
  • Any redirect setting on the Default Web Site?
    Can you post a picture?

    What files do you have in C:\inetpub\wwwroot ? Anyone that has webmail.melbaschools.org/exchange ?


    Martina Miskovic

    Thursday, June 7, 2012 9:54 PM
  • See the section Use IIS Manager to remove redirection from a virtual directory in Simplify the Outlook Web App URL and run the appcmd commands.


    Martina Miskovic

    Thursday, June 7, 2012 10:00 PM
  • I have aspnet_client, iistart, iisstart.old, web and welcom in teh wwroot folder.

    This is what my IIS look like.


    This is what I have for redirection

    • Edited by kabushj Thursday, June 7, 2012 10:07 PM
    Thursday, June 7, 2012 10:02 PM
  • When I add the redirect to the exchange folder, it automatically set the OWA folder also.  Not sure if this is normal or not.
    Thursday, June 7, 2012 10:08 PM
  • Any redirect setting on the Default Web Site?
    Can you post a picture?

    Also, do look in the file IISStart.

    On the site Simplify the Outlook Web App URL there are some good comments. Do run the appcmd command.

    Martina Miskovic

    Thursday, June 7, 2012 10:09 PM
  • Found it....

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta HTTP-EQUIV="REFRESH" content="0; url=http://webmail.melbaschools.org/exchange">
    <title>IIS7</title>
    </head>
    <body>
    <p>Redirecting to http://webmail.melbaschools.org/exchange</p>

    What should I do?

    Thursday, June 7, 2012 10:11 PM
  • It looked like you had the Org IISStart still in C:\inetpub\wwwroot. Rename them.

    Configure the redirection according as described in Simplify the Outlook Web App URL  and don't forget to run the appcmd commands.


    Martina Miskovic

    Thursday, June 7, 2012 10:15 PM
  • Am I removing the redirection or adding it?  Also, just name the files .old, do I need to do anything else?
    Thursday, June 7, 2012 10:21 PM
  • Am I removing the redirection or adding it?  Also, just name the files .old, do I need to do anything else?

    I'm guessing that your users is not used to type /owa so you should add a redirection on the default web site and then remove the redirection that will be configured on the virtualdirectories with appcmd.

    Please, do consider getting a certificate.

    It's past midnight where I am, so  it's time for me to do something else now :)
    Please let me know how things go and I will check back in tomorrow. Maybe somebody else here in the Forum will take over..

    Martina Miskovic


    Thursday, June 7, 2012 10:25 PM
  • Thanks for your help.
    Thursday, June 7, 2012 10:27 PM
  • So, I have updated my exchange server to SP2 and Ru3.  I noticed with the last update, it's now using https (before it wasn't) and the look for the webmail has changed.

    Now back to my problems, I'm still having issues accessing the options in webmail, out of office and mailtips still aren't working in Outlook 2010.  What could be causing this issue?

    Friday, June 8, 2012 1:26 AM
  • So, I have updated my exchange server to SP2 and Ru3.  I noticed with the last update, it's now using https (before it wasn't) and the look for the webmail has changed.

    Now back to my problems, I'm still having issues accessing the options in webmail, out of office and mailtips still aren't working in Outlook 2010.  What could be causing this issue?

    Hi,
    Yes, the OWA GUI is different. I was changed back in SP1.
    SP2 also changed things regarding SSL, and that is described in the release notes. IF you really want to use port 80, you need to make a change in web.config. See the information about that in Simplify the Outlook Web App URL

    I want to go back to my second post in this thread...
    What you really should do is to get a certficate from a trusted authority.  Exchange is designed with security in mind and all URLs is by default configured with "https".
    I don't know if you can get Outlook to work properly without it. It's not designed for it.

    You might get it to work with port 80 in OWA, but you should make sure that all URLS (owavirtualdirectory,ecpvirtualdirectory, webservicevirtualdirectory) is configured the same way.

    If webmail is what you are using,you should change all of them. Right now you have webservicesvirtualdirectory configured with https://mail.melbaschools.org/EWS/Exchange.asmx and I can only guess that you have https://mail.melbaschools.org/ECP configured as well.

    Outlook relies heavily on Autodiscover, so please read this
    White Paper: Exchange 2007 Autodiscover Service (same in EX10)
    http://technet.microsoft.com/en-us/library/bb332063(EXCHG.80).aspx


    Martina Miskovic


    Friday, June 8, 2012 4:57 AM
  • I will work on getting a SSL cert, and post my result back in this thread.
    Friday, June 8, 2012 2:18 PM
  • I'm at the last step of assigning the cert and I'm not sure what options I should select (if any).  I'm sure  I read on another site that I have to go into IIS and install the cert, but I see I have the option on this screen.  I'm a little confused by this.

    Friday, June 8, 2012 5:35 PM
  • Hi,
    I'm glad to see that you have fixed a certificate!

    Certificates used for Exchange should never be assigned in IIS, so the person who wrote that was wrong.
    Do check IIS in the wizard.


    Martina Miskovic


    Friday, June 8, 2012 5:41 PM
  • I got the cert installed, everything seems to be working.  Now back to my original problem, OOO still won't work.
    Friday, June 8, 2012 6:16 PM
  • Hi,
    Any errors when you run Test-OutlookWebServices ? Is the problem with Outlook, OWA or both and has the other problems been resolved?

    Can you run the below command and post the output?

    • Get-ClientAccessServer | fl Identity,AutoDiscoverServiceInternalUri
    • Get-WebServicesVirtualDirectory | fl Identity,internalurl,externalurl
    • Get-OwaVirtualDirectory | fl Identity,internalurl,externalurl
    • Get-EcpVirtualDirectory | fl Identity,internalurl,externalurl

    I can see that you added the name ServerMX2 in your certificate and not ServerMX2.msdk12.local.
    The name your have configured for AutoDiscoverServiceInternalUri must be a name that you have in your certificate. If

    Also, do recyle the application pool MSExchangeAutodiscoverAppPool in IIS and restart an Outlook Client. That usually triggers Outlook to check for new Autodiscover settings.


    Martina Miskovic


    Friday, June 8, 2012 6:27 PM
  • I noticed on Get-WebServicesVirtualDirectory | fl Identity,internalurl,externalurl I don't have a external URL listed.

    Also, when I ran the Test-OutlookWebServices, I get the following error.

    C:\Windows\system32>Test-OutlookWebServices
    WARNING: An unexpected error has occurred and a Watson dump is being generated: Failed to find the mailbox. Mailbox =
    'extest_5edcf4c44ec94@msdk12.local'.
    Failed to find the mailbox. Mailbox = 'extest_5edcf4c44ec94@msdk12.local'.
        + CategoryInfo          : NotSpecified: (:) [Test-OutlookWebServices], MailboxNotFoundException
        + FullyQualifiedErrorId : Microsoft.Exchange.Monitoring.MailboxNotFoundException,Microsoft.Exchange.Management.Sys
       temConfigurationTasks.TestOutlookWebServicesTask

    Friday, June 8, 2012 6:40 PM
  • OOO is now working in webmail, externally.  It still doesn't work internally both webmail and outlook.

    A step closer....

    Friday, June 8, 2012 6:44 PM
  • I noticed on Get-WebServicesVirtualDirectory | fl Identity,internalurl,externalurl I don't have a external URL listed.

    Also, when I ran the Test-OutlookWebServices, I get the following error.

    C:\Windows\system32>Test-OutlookWebServices
    WARNING: An unexpected error has occurred and a Watson dump is being generated: Failed to find the mailbox. Mailbox =
    'extest_5edcf4c44ec94@msdk12.local'.


    Yes, I mentioned that yesterday. Do add the externalurl
    Example: set-WebServicesVirtualDirectory EWS* -externalurl https://mail.melbaschools.org/EWS/Exchange.asmx
    (or webmail is that is what you have configured for your other URLs)

    You need to create the test-casuser.
    Run the script ./new-TestCasConnectivityUser.ps1 from the scripts folder

    Martina Miskovic


    Friday, June 8, 2012 6:48 PM
  • Okay, finally got that done.  Here are the results.  I do still have my old cert on the server that was self signed, should I remove it?    How do I fix the service discovery?


    RunspaceId : 100706ed-7076-4629-877d-d1f7b2a97382
    Id         : 1104
    Type       : Error
    Message    : The certificate for the URL https://servermx2.msdk12.local/autodiscover/autodiscover.xml is incorrect. For
                  SSL to work, the certificate needs to have a subject of servermx2.msdk12.local, but the subject that was
                 found is mail.melbaschools.org. Consider correcting service discovery, or installing a correct SSL certifi
                 cate.

    RunspaceId : 100706ed-7076-4629-877d-d1f7b2a97382
    Id         : 1013
    Type       : Error
    Message    : When contacting https://webmail.melbaschools.org/ews/exchange.asmx received the error The request failed w
                 ith an empty response.

    RunspaceId : 100706ed-7076-4629-877d-d1f7b2a97382
    Id         : 1025
    Type       : Error
    Message    : [EXCH] Error contacting the AS service at https://webmail.melbaschools.org/ews/exchange.asmx. Elapsed time
                  was 201 milliseconds.



    RunspaceId : 100706ed-7076-4629-877d-d1f7b2a97382
    Id         : 1013
    Type       : Error
    Message    : When contacting https://webmail.melbaschools.org/EWS/Exchange.asmx received the error The request failed w
                 ith an empty response.

    RunspaceId : 100706ed-7076-4629-877d-d1f7b2a97382
    Id         : 1025
    Type       : Error
    Message    : [EXPR] Error contacting the AS service at https://webmail.melbaschools.org/EWS/Exchange.asmx. Elapsed time
                  was 0 milliseconds.


    RunspaceId : 100706ed-7076-4629-877d-d1f7b2a97382
    Id         : 1113
    Type       : Error
    Message    : When contacting https://servermx2.msdk12.local/ews/exchange.asmx received the error The request failed wit
                 h an empty response.

    RunspaceId : 100706ed-7076-4629-877d-d1f7b2a97382
    Id         : 1125
    Type       : Error
    Message    : [Server] Error contacting the AS service at https://servermx2.msdk12.local/ews/exchange.asmx. Elapsed time
                  was 0 milliseconds.

    Friday, June 8, 2012 7:15 PM
  • I also noticed this.

    [PS] C:\Windows\system32>Get-OwaVirtualDirectory | fl Identity,internalurl,externalurl


    Identity    : SERVERMX2\owa (Default Web Site)
    InternalUrl : http://webmail.melbaschools.org/
    ExternalUrl : http://webmail.melbaschools.org/

    Should it be https?

    Friday, June 8, 2012 7:26 PM
  • The URL should be https://webmail.melbaschools.org/owa

    Can you run the below command and post the output?

    • Get-ClientAccessServer | fl Identity,AutoDiscoverServiceInternalUri
    • Get-WebServicesVirtualDirectory | fl Identity,internalurl,externalurl
    • Get-EcpVirtualDirectory | fl Identity,internalurl,externalurl


    Martina Miskovic

    Friday, June 8, 2012 7:29 PM

  • [PS] C:\Windows\system32>Get-ClientAccessServer | fl Identity,AutoDiscoverServiceInternalUr


    Identity : SERVERMX2

    [PS] C:\Windows\system32>Get-WebServicesVirtualDirectory | fl Identity,internalurl,externalurl


    Identity    : SERVERMX2\EWS (Default Web Site)
    InternalUrl : https://webmail.melbaschools.org/ews/exchange.asmx
    ExternalUrl : https://webmail.melbaschools.org/EWS/Exchange.asmx

    [PS] C:\Windows\system32>Get-EcpVirtualDirectory | fl Identity,internalurl,externalurl


    Identity    : SERVERMX2\ecp (Default Web Site)
    InternalUrl : http://webmail.melbaschools.org/
    ExternalUrl : http://webmail.melbaschools.org/
    Friday, June 8, 2012 7:40 PM
  • Sorry, I missed a letter.
    Run this again: Get-ClientAccessServer | fl Identity,AutoDiscoverServiceInternalUri

    EcpVirtualDirectory is wrong. Should be https://webmail.melbaschools.org/ecp

    Martina Miskovic

    Friday, June 8, 2012 7:42 PM
  • [PS] C:\Windows\system32>Get-ClientAccessServer | fl Identity,AutoDiscoverServiceInternalUri


    Identity                       : SERVERMX2
    AutoDiscoverServiceInternalUri : https://webmail.melbaschools.org/autodiscover/autodiscover.xml
    Friday, June 8, 2012 7:44 PM
  • [PS] C:\Windows\system32>Get-ClientAccessServer | fl Identity,AutoDiscoverServiceInternalUri


    Identity                       : SERVERMX2
    AutoDiscoverServiceInternalUri : https://webmail.melbaschools.org/autodiscover/autodiscover.xml

    Looks good.

    While you are checking your URLS...Do it for OABVirtualDirectory as well.

    Did you recycle the application pool MSExchangeAutodiscoverAppPool in IIS?
     


    Martina Miskovic

    Friday, June 8, 2012 7:49 PM
  • Maybe I'm not using the right command, how do you set Get-WebServicesVirtualDirectory and Get-EcpVirtualDirectory

    I get the following:

    [PS] C:\Windows\system32>set-EcpVirtualDirectory -internalurl https://webmail.melbaschools.org

    cmdlet Set-EcpVirtualDirectory at command pipeline position 1
    Supply values for the following parameters:
    Identity:

    Friday, June 8, 2012 8:01 PM
  • How would I fix this issue. 

    RunspaceId : 100706ed-7076-4629-877d-d1f7b2a97382
    Id         : 1104
    Type       : Error
    Message    : The certificate for the URL https://servermx2.msdk12.local/autodiscover/autodiscover.xml is incorrect. For
                  SSL to work, the certificate needs to have a subject of servermx2.msdk12.local, but the subject that was
                 found is mail.melbaschools.org. Consider correcting service discovery, or installing a correct SSL certifi
                 cate.

    Friday, June 8, 2012 8:05 PM
  • Set-EcpVirtualDirectory ECP* -internalurl https://webmail.melbaschools.org/ecp -externalurl https://webmail.melbaschools.org/ecp

    Set-WebServicesVirtualDirectory EWS* -internalurl  https://webmail.melbaschools.org/EWS/Exchange.asmx -externalurl https://webmail.melbaschools.org/EWS/Exchange.asmx

    Martina Miskovic

    Friday, June 8, 2012 8:06 PM
  • Okay, I got that all set and looking good.  I did recycled MSExchangeAutodiscoverAppPool in IIS, log back in to Outlook still same problem.   How would I fix this

    : The certificate for the URL https://servermx2.msdk12.local/autodiscover/autodiscover.xml is incorrect. For
                  SSL to work, the certificate needs to have a subject of servermx2.msdk12.local, but the subject that was
                 found is mail.melbaschools.org. Consider correcting service discovery, or installing a correct SSL certifi

    How do you correct service discovery?

    Friday, June 8, 2012 8:27 PM
  • Well, when I got home tonight and tried to access the options in webmail, it just goes back to the login screen just like work.  Now, if I use Outlook light, I'm able to access the options without any issues.  Does anyone have any suggestions on why that would be?

    Saturday, June 9, 2012 1:21 AM