locked
Lync Server Web services not working RRS feed

  • Question

  • I installed Lync 2010, its working fine for IM, Video,Audio.

     

    But when i schedule a meeting and going to link. Its giving me this error.

    Server Error in '/meet' Application.
    --------------------------------------------------------------------------------

    URL Path is NULL or empty
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentException: URL Path is NULL or empty

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. 

    Stack Trace:


    [ArgumentException: URL Path is NULL or empty]
       Microsoft.Rtc.Internal.JoinLauncher.Default_aspx.ComputeIncomingURL() +1407
       Microsoft.Rtc.Internal.JoinLauncher.Default_aspx.CrackURL() +179
       Microsoft.Rtc.Internal.JoinLauncher.Default_aspx.Page_Load(Object sender, EventArgs e) +483
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +25
       System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +42
       System.Web.UI.Control.OnLoad(EventArgs e) +132
       System.Web.UI.Control.LoadRecursive() +66
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2428

     


    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:2.0.50727.4959; ASP.NET Version:2.0.50727.4955

     

    Any help !!!

     

    Regards

    JD

     

    Wednesday, June 1, 2011 8:29 PM

Answers

  • and if you open https://lync.abc.local/meet you receive the above error ?

    can you try to publish the topology once again and run the "setup or remove lync components (bootstrapper)" once again ?

    regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread
    • Marked as answer by JSmann Monday, June 6, 2011 5:04 PM
    Thursday, June 2, 2011 7:05 AM
  • The administrator account and all members of  high pervilege security groups like domain admins, ect... can't be enabled for lync directly because Permission propagation has been denied by default on these groups in other terms inhertance is blocked on these groups, so in order to enable those users you need to enable enheritance of these groups or try  add the following Groups and permissions manually

    RTCUniversalUserReadOnly Read account restrictions
    RTCUniversalUserReadOnly Read general information
    RTCUniversalUserReadOnly Read public information
    RTCUniversalUserReadOnly Read RTCPorpertySet
    RTCUniversalUserReadOnly Read RTCUserSearchPropertySet
    RTCUniversalUserReadOnly Read personal information
    RTCUniversalUserReadOnly Read RTCUserProvisioningPropertySet
    RTCUniversalAdmins write RTCPropertySet
    RTCUniversalAdmins write RTCUserProvisioningPropertySet
    RTCUniversalAdmins write RTCUserSearchPropertySet

     

    you can also try to run the following cmdlet from the lync powershell Grant‑CsOUPermission –OU <OU or Users container DN> ‑ObjectType user

    for me enable the enheritance did the job

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread
    • Marked as answer by JSmann Monday, June 6, 2011 5:04 PM
    Friday, June 3, 2011 10:40 AM

All replies

  • Hi,

    did you configure the simple urls in the topology builder ?

    regards,

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread
    Wednesday, June 1, 2011 10:20 PM
  • Yes , simple urls

    lync.abc.local

    and external meeting.abc.com

    Regards

    JD

    Thursday, June 2, 2011 2:26 AM
  • and if you open https://lync.abc.local/meet you receive the above error ?

    can you try to publish the topology once again and run the "setup or remove lync components (bootstrapper)" once again ?

    regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread
    • Marked as answer by JSmann Monday, June 6, 2011 5:04 PM
    Thursday, June 2, 2011 7:05 AM
  • Hi,

    Maybe you published wrong simply URLS, or you didn’t create A record for them. Reading the following article then check them:

    http://technet.microsoft.com/en-us/library/gg398287.aspx

    http://technet.microsoft.com/en-us/library/gg425874.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 2, 2011 7:49 AM
  • when i am trying to open https://lync.abc.local/meet its giving me the error of Internet explorer canot display the webpage

    but when i ping the lync.abc.local then its giving me the reply.

    Yes i can publish the topology once again and remove the lync components.

     

    in dns what i have to entre?

     

    I have aaa record for Lync

    1. lync.abc.local   pointing to 192.168.1.1 what other enteries i need to made in dns ...

    Regards

    JD

    Thursday, June 2, 2011 12:01 PM
  • It works now i renfigure everything .. and pointed simple url with dns.

     

    Thanks for support

     

    Regards

    JD

    Thursday, June 2, 2011 4:17 PM
  • When trying to add my administrator account to Lync I get the following error:

    Active Directory operations failed on <Server Name>.  You cannot retry this operation: “Insufficient access rights to perform the operation.

    Thursday, June 2, 2011 5:33 PM
  • The administrator account and all members of  high pervilege security groups like domain admins, ect... can't be enabled for lync directly because Permission propagation has been denied by default on these groups in other terms inhertance is blocked on these groups, so in order to enable those users you need to enable enheritance of these groups or try  add the following Groups and permissions manually

    RTCUniversalUserReadOnly Read account restrictions
    RTCUniversalUserReadOnly Read general information
    RTCUniversalUserReadOnly Read public information
    RTCUniversalUserReadOnly Read RTCPorpertySet
    RTCUniversalUserReadOnly Read RTCUserSearchPropertySet
    RTCUniversalUserReadOnly Read personal information
    RTCUniversalUserReadOnly Read RTCUserProvisioningPropertySet
    RTCUniversalAdmins write RTCPropertySet
    RTCUniversalAdmins write RTCUserProvisioningPropertySet
    RTCUniversalAdmins write RTCUserSearchPropertySet

     

    you can also try to run the following cmdlet from the lync powershell Grant‑CsOUPermission –OU <OU or Users container DN> ‑ObjectType user

    for me enable the enheritance did the job

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread
    • Marked as answer by JSmann Monday, June 6, 2011 5:04 PM
    Friday, June 3, 2011 10:40 AM
  • If i want to give the external user access, is thr any other way to permit without implementing Edge server.

    And can in install Edge on the front server, where Lync 2010 is intalled .

     

    Regards

    JD

     

     

    Monday, June 6, 2011 4:20 PM
  • I am getting the same exact error when browisng using IIS admin on the front end server. On a XP client with outlook and using the Lync 2010 full client I get The page cannot be displayed. What is the best way to validate that IIS is setup correctly on the front end server for web conferecing? Everything else works just fine. How can I check and validate that the meeting urls are functioning? I see that they are configured. I tried to test it via IIS admin by browsing the meeting site and get the same error as above URL Path is NULL or empty. However via outlook I get The page cannot be displayed. I do have multiple SIPS domains setup (2). The link it uses for the meeting is not the primary sip domain but is the one used for email and lync provisioned user. Any help is appreciated.


    John marques



    Wednesday, July 6, 2011 2:26 PM
  • Dear JSmann,

    Currently, I am facing the same issue. However, I have configured my Simple Urls and DNS entries.

    Note :

    I am deploying Microsoft Lync Multitenant edition wich mention to configure tenant meeting url as follow,

    https://meet.[Hoster Domain]/[Tenant SIP Domain].

    but still facing the same issue, I have configured my TMG to proxy this Url to be rediredted to Lync Director pool

    Please help me with this,

    Regards,

    Kromaih

    Tuesday, December 18, 2012 10:40 AM