locked
Doc Library->”New Document” doesn’t save the documents in the initial document library RRS feed

  • Question

  • Hi,

    In my MOSS 2007+Office 2007 environment, when I choose a new document in any of document libraries, the save button tries to save the document in my local drive instead of the initial  document library.

    At this point I have to save the document on my local disk, and upload it at the second step.

    Is there any way to have office applications automatically save document in the doc library that I clicked on “New Document”?

    Thank you,

    Sunday, April 8, 2012 5:51 PM

Answers

  • Hi amx2012,

    According to your post, you cannot save the new document directly to server. You have to save it locally and upload instead. In my opinion, there are several possible reasons that can cause the problem:

    1. If you are using SharePoint 2007 on Windows Server(e.g. Windows Server 2008), You won’t see SharePoint Lists in the “Save” dialog box and you have to save the document locally. The issue of this is that WebDav access and functionality to browser the site structure is incorporated to “Desktop Experience” feature of Windows Server. You need to install “Desktop Experience” feature manually. Normally you won’t see this on Win7 or Vista because this feature is turned on by default. Please read this article to turn on the feature on Windows Server.
    2. If there are some problem with the content type you select for the doc library or the Client Program Mapping is set incorrectly, the document may also opened incorrectly. Please check the content type or Mapping to solve the problem. You can refer to this document to learn more on the Mapping Element.

    Thanks,


    Lambda Zhao

    TechNet Community Support

    • Marked as answer by amx2012 Tuesday, April 10, 2012 3:23 PM
    Tuesday, April 10, 2012 9:57 AM

All replies

  • Is this only happening on 1 pc or do all pc's have the same problem?

    best regards,

    paul Keijzers


    Check my website http://www.kbworks.nl or follow me on @KbWorks be sure to Check my SharePoint-Specialist.nu for dutch informationworkers check Wat Is microsoft SharePoint.nl for dutch readers who want to know what microsoft office365 is.

    Monday, April 9, 2012 12:14 PM
  • Hi amx2012,

    According to your post, you cannot save the new document directly to server. You have to save it locally and upload instead. In my opinion, there are several possible reasons that can cause the problem:

    1. If you are using SharePoint 2007 on Windows Server(e.g. Windows Server 2008), You won’t see SharePoint Lists in the “Save” dialog box and you have to save the document locally. The issue of this is that WebDav access and functionality to browser the site structure is incorporated to “Desktop Experience” feature of Windows Server. You need to install “Desktop Experience” feature manually. Normally you won’t see this on Win7 or Vista because this feature is turned on by default. Please read this article to turn on the feature on Windows Server.
    2. If there are some problem with the content type you select for the doc library or the Client Program Mapping is set incorrectly, the document may also opened incorrectly. Please check the content type or Mapping to solve the problem. You can refer to this document to learn more on the Mapping Element.

    Thanks,


    Lambda Zhao

    TechNet Community Support

    • Marked as answer by amx2012 Tuesday, April 10, 2012 3:23 PM
    Tuesday, April 10, 2012 9:57 AM
  • Hi Lambda,

    Desktop Experience was the problem. It is working fine now.

    Thank you,

    Tuesday, April 10, 2012 3:24 PM