locked
Permissions Reporting Tool error (SharePoint Administration Toolkit v4 - Office SharePoint Server) RRS feed

  • Question

  • Following a deployment of  MOSS August CU recently, followed by installation of the Microsoft SharePoint Administration Toolkit v4.0 on Windows Server 2003 (x64) farm and enabling permissionreporting solution and farm feature I'm getting the following error whenever I try to navigate to the  permissionreporting solution page in the site collection settings:

    The resource object with key 'AccountPageTitle' was not found.   at System.Web.Compilation.ResourceExpressionBuilder.ParseExpression(String expression, Type propertyType, ExpressionBuilderContext context)
       at System.Web.UI.BoundPropertyEntry.ParseExpression(ExpressionBuilderContext context)
       at System.Web.UI.ControlBuilder.FillUpBoundPropertyEntry(BoundPropertyEntry entry, String name)
       at System.Web.UI.ControlBuilder.AddBoundProperty(String filter, String name, String expressionPrefix, String expression, ExpressionBuilder expressionBuilder, Object parsedExpressionData, Boolean generated, String fieldName, String formatString, Boolean twoWayBound)
       at System.Web.UI.ControlBuilder.PreprocessAttribute(String filter, String attribname, String attribvalue, Boolean mainDirectiveMode)
       at System.Web.UI.ControlBuilder.PreprocessAttributes(ParsedAttributeCollection attribs)
       at System.Web.UI.ControlBuilder.Init(TemplateParser parser, ControlBuilder parentBuilder, Type type, String tagName, String id, IDictionary attribs)
       at System.Web.UI.ControlBuilder.CreateBuilderFromType(TemplateParser parser, ControlBuilder parentBuilder, Type type, String tagName, String id, IDictionary attribs, Int32 line, String sourceFileName)
       at System.Web.UI.ControlBuilder.CreateChildBuilder(String filter, String tagName, IDictionary attribs, TemplateParser parser, ControlBuilder parentBuilder, String id, Int32 line, VirtualPath virtualPath, Type& childType, Boolean defaultProperty)
       at System.Web.UI.TemplateParser.ProcessBeginTag(Match match, String inputText)
       at System.Web.UI.TemplateParser.ParseStringInternal(String text, Encoding fileEncoding)

    Thursday, December 8, 2011 7:49 AM

Answers

  • Found the problem - for some reason the ESCM.resx file was missing from the App_GlobalResources in the IIS site folder. I manually copied it into this folder and after IISRESET it started working.
    • Marked as answer by asembler Thursday, December 8, 2011 8:19 AM
    Thursday, December 8, 2011 8:19 AM