none
How do I stop printer policies from applying to servers?

    Question

  • We use group policies to deploy printers- All works well, except that RDP logins to servers generate a bunch of extra noise in the event logs. What I'd like to do is to find a way to prevent just these policies from running. We use security filtering to only load the drivers for specific group members, so we end up with one group per printer, and simply add a user to a group to install the printer. We do have terminal servers in our deployment, so I would guess the question is how to create a group of users who have a policy, who log in to a group of servers that prevent the policy from loading? We would exclude the RDS's from the group because we want printers to load on them... I'll appreciate any ideas on how to do this.

    Thanks!


    Thanks!

    Wednesday, October 28, 2015 2:26 PM

All replies

  • Create a WMI filter for the GPO and include only  ProductType="1"

    • https://technet.microsoft.com/en-us/library/cc947846(v=ws.10).aspx
    • http://geeknotgreek.blogspot.com/2012/06/apply-group-policies-to-only-windows-7.html

    Mike Crowley | MVP
    My Blog -- Baseline Technologies

    Tuesday, November 10, 2015 4:13 PM
  • Thanks for the reply! This loos good.... but I left out that a number of our users print from terminal servers- Is there a way to include those servers? These filters seem to not apply to DC's,so is there a similar exemption for TS/RDS machines?

    Thanks!


    Thanks!

    Tuesday, November 10, 2015 5:13 PM
  • Are you using Group Policy Preferences to deploy the printers?

    Tuesday, November 10, 2015 5:24 PM
  • Why not deploy the printers using computer based policy rather than user based GPO?

    Just move the TS servers to a separate OU, link printers GPO to the terminal server OU (and workstations OU if required) then apply filter containing specific security group of AD users to the GPO. This should do the trick if my understanding of the problem is correct.

    Tuesday, November 10, 2015 5:24 PM