Unable to deploy OS on MDT2012 to laptop with multiple drives - Dell M6700


  • Hi

    Ever since Dell changed their model M6600 to the M6700 Ive not been able to deploy my OS to it with MDT 2012

    It deploys to the second drive and not the primary SSD, on the first restart it then restarts into the factory imaged SSD with its dell image firing up

    Turns out the new M6700 has different ID's for the drives now, the main primary SSD isnt drive 0 anymore and is now drive 1 and the second 700GB drive is classed as drive 0 rather than drive 1

    So i had a play with it and determined it was trying to install to the second drive and not even wiping the first drive, in the task sequence i changed the drive it needs to wipe from 0 to 1 and the drive it installs the OS to as drive 1 partition 1

    Now when it does its first restart during deployment it comes up with an error that its cant find Bootmgr, clearly its wiped the main SSD drive 1 now as it doesnt auto load up the dell OEM build, but it still tries to install the OS on the second drive 0, even though i changed the task sequence to specifically tell it to choose drive 1 partition 1, if i change the boot order to point to the second drive it happily carrie son the deployment, but thats no good as its on the wrong drive.

    All looks good in the task sequence, it wipes drive 1 fine, but doesnt then install the OS to drive 1

    so i looked at editing the unattend.xml, in the section:

    amd64_Microsoft-Windows-Setup_neutral > ImageInstall > InstallTo

    I set the DiskID to 1 (as it was still set to 0 after i made the task sequence changes), tested, still the same

    So my question is, what am i doing wrong in trying to force the task sequence to install the OS on disk 1 which is the same disk it is now succesfully wiping? rather than it insatlling on the secondary drive 0

    thanks if anyone can help

    Wednesday, February 13, 2013 3:29 PM

All replies

  • Good afternoon Scumpuppy, have you tried editing the bootstap.ini.

    Add this commands to the file

    DestinationDisk= Disk number e.g. "1" <- Your SSD drive Number

    Secondary/Optional command.

    DestinationPartition = Partition number e.g. "1" or "2" <- SDD primary partition. You may not need this due to the fact that windows will create the partition on install.

    Wednesday, February 13, 2013 7:37 PM
  • Hi

    Thanks for the reply, unfortunately this doesnt work

    Interestingly I booted off a windows 7 USB stick so i could format the disks ready to try again (as MDT doesnt like redeploying after its done a deployment, says its dirty or something i cant quite remember now, so have to format before tryign again) and strangely windows 7 when it shows you your disks to format shows the SSD as disc 0 and the large 700GB disk as disk 1

    Is there a way of viewing how the disks show in MDT? Just so i can confirm MDT is viewing the discs correctly?

    All the other multiple disc laptops build absolutely fine for me, its just these new ones that have the discs in different area's inside than how they used to be, so i was assuming the ID of the discs was different, but windows 7 clearly shows the SSD as disc 0 when i come to format it?!? Yet when i deploy using a standard task sequence that works on everything else it ignores the SSD and wipes the large 700GB disk and then installs the OS to it, yet when i create a new task sequence and tell it to wipe disc 1 and install the OS to disk 1 it succesfully wipes the SSD yet still installs to the large 700GB drive :/

    totally confusing

    Thursday, February 14, 2013 9:36 AM
  • try using the OS variable to install your windows to the right partition.

    if you use diskpart and type list disk it should show in which order the disks are connected.

    Thursday, February 14, 2013 10:09 AM
  • I also tried the OS variable to install to the correct drive, it simply refuses to install to the SSD and always installs to the large 700GB drive, I set a task to wipe drive 0 and partition it as a partition named OSDisk, set another task to wipe drive 1 and partition it as DATA, it fails.. when Im booting off windows 7 USB to format the drives and try again i see its mixed up the drives and named drive 0 (the SSD) as DATA and drive 1 (the 700GB) as OSDisk

    Even though Im telling it to do it the other way round, seems to be getting them totally confused, I take out the 700GB drive so its just running on the SSD and it builds fine, no problem at all

    Its really doing my head in now, I have loads to get out and cant waste too much time on this so im passing this to one of my colleagues so i can crack on with the workaround of just removing the second drive, build it as normal and then put the drive back in afterwards :(

    Thursday, February 14, 2013 1:23 PM