none
Branch office WDS still pullinh image from main site RRS feed

  • Question

  • Hi,

    I'm trying to configure a WDS on our branch site.

    what i did was open a new folder named DeployFilesFromMaster on the branch office server and replicate the DeploymentShare from main to branch office using DFS.

    then i installed WDS services on the branch office and add a Boot Image (taken from DeployFilesFromMaster)

    next i configured, under Scope Option on the DHCP server, options 66 (giving the ip address of the branch WDS), and option 67 (giving the path \Boot\x64\wdsnbp.com).

    now when I'm booting a computer into PXE it start working, but when pressing F8 and use the netstat command i see it has a session to my main office deploy server instead to the branch office.

    what do i need to change?

    when looking in the branch office server, there is ofcourse the DeployFilesFromMaster folder and there is another folder named DeploymentShare that was made while installiing the WDS server, and there is a wdsnbp.com file as well. how do I know, when DHCP direct me to the boot file name, that it direct me to the right file, or it doesnt matter.

    thanks for your help

    Sunday, March 30, 2014 11:11 AM

Answers

  • In the boot image the bootstrap.ini file is pointing to your main office deployment share. What you need to do is to use the %WDSServer% variable which will make it figure out the local WDS server name dynamically, meaning you can use the same boot image both at the main office as well as the branch office.

    So set the following in your boostrap.ini, then update the deployment share and then replace the boot image with the updated one.

    DeployRoot=\\%WDSServer%\DeployFilesFromMaster

    (or whatever the share name is for the deployment share)


    Blogging about Windows for IT pros at www.theexperienceblog.com

    Sunday, March 30, 2014 2:00 PM

All replies

  • In the boot image the bootstrap.ini file is pointing to your main office deployment share. What you need to do is to use the %WDSServer% variable which will make it figure out the local WDS server name dynamically, meaning you can use the same boot image both at the main office as well as the branch office.

    So set the following in your boostrap.ini, then update the deployment share and then replace the boot image with the updated one.

    DeployRoot=\\%WDSServer%\DeployFilesFromMaster

    (or whatever the share name is for the deployment share)


    Blogging about Windows for IT pros at www.theexperienceblog.com

    Sunday, March 30, 2014 2:00 PM
  • Hi,

    Did this resolve your issue?

    I use Default Gateway in my Bootstrap.ini.

    It connects to the local server at the particular site but I do also see multicast connections go back to the master...

    Thursday, April 3, 2014 5:30 PM
  • im doing it right now.

    will let you know in 1-2 hours

    Monday, April 7, 2014 9:52 AM
  • Andreas Stenhall

    thanks a lot, this worked very well for me, now the remote site is installing image from it's own site.

    however, i would like to ask:

    the WDS, when it query for %WDSServer%, who it query? the DHCP? the AD?

    because when i was trying to \\%WDSServer%\ at the 'Run...' i didn't get anywhere. the reason i'm asking is that i would like to do the same thing with the WSUS updates. if i will enter the line in the costumeSetting.ini:

    WSUSServer=http://%WSUSServer%:8530

    will it be the same? it will query for the WSUS in it's own site?

    thanks a lot for your help!!

    Tuesday, April 8, 2014 6:26 AM
  • The variable WDSSERVER is a variable that is figured out by MDT when booting a machine using the boot image created by Microsoft Deployment Toolkit. Therefore it is not available in Windows.

    If you want different WSUS servers depending on location of the client you can use for instance this technique in CustomSettings.ini. This will point clients on a specific subnet to a specific WSUS server.

    [Settings]
    Priority=DefaultGateway,Default

    [DefaultGateway]
    10.0.0.1=HQ
    10.0.1.1=BranchOffice

    [HQ]
    WSUSServer=http://wsus-hq:8530

     [BranchOffice]

    WSUSServer=http://wsus-branch:8530


    Blogging about Windows for IT pros at www.theexperienceblog.com

    Tuesday, April 8, 2014 7:24 AM
  • If you were to use this approach I would use.

    [Settings]
    Priority=DefaultGateway,Default

    [DefaultGateway]
    10.0.0.1=HQ
    10.0.1.1=BranchOffice

    [HQ]

    \\servername\ShareName
    WSUSServer=http://wsus-hq:8530

    Tuesday, April 8, 2014 10:52 AM
  • Thanks a lot guys for all your help :)

    cheers...

    Tuesday, April 8, 2014 11:33 AM