locked
Changing HAL ? RRS feed

  • Question

  • Hi all,

    I used the method mentioned in the thread below changing my HAL from ACPI-x86 to ACPI-PC which fixed the video card problem (error code 43) and discovered my Radeon X1600 Pro properly and AERO/Glass is working and looks nice.

    I wanted to attempt and change the hal back to ACPI-X86 and see if the previous issue was resolved now that everything is working with the exception of my Dual Core AMD X2 working as a Single Core.   In device manager; I don't get the option to pick from a list?

    Any ideas?

    Thanks!

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=889375&SiteID=17

     

     

    Sunday, December 3, 2006 3:49 AM

All replies

  • To get Vista (Build 6000) to re-detect the ACPI-X86 (Multi CPU suport) run msconfig, select Advanced option from the Boot.ini tab and check the redetect HAL box and reboot.

    After reboot remove the check from msconfig otherwise it will keep redetecting at boot up.

    I have done  but it will cause the same problem again! Im guessing that you have the problem with ATI drivers (Code 43) error and ACPI  X86 HAL

    Running the ACPI driver works fine but it disables the use of a second CPU / Core

    It appears to be a bug in either the ATI drivers of MS standard Multi CPU HAL.sys file

    Ive got so frustrated with this i have rolled back to XP on my desktop PC

    Im going to wait till Vista (retail) is released in Jan 07  then this problem  should / will have to be resolved!!

     

    Monday, December 4, 2006 7:53 PM
  • Yep; (code 43).  I'd like my Dual Core to work properly.  Thanks for the reply.  Maybe I'll give a shot.
    Tuesday, December 5, 2006 2:03 AM